aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-LectroTest
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-27 12:09:07 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-27 12:09:07 +0000
commit9bc4d354f96c7e24b3579d8e795615a0c903ce38 (patch)
tree9bbfff93d3411443b7272e98e434cf5fb981d146 /devel/p5-Test-LectroTest
parent7ea2b6d82fcb88ab56ebfd0191a4f4cd9dfb91f2 (diff)
downloadports-9bc4d354f96c7e24b3579d8e795615a0c903ce38.tar.gz
ports-9bc4d354f96c7e24b3579d8e795615a0c903ce38.zip
New port: devel/p5-Test-LectroTest -- specification tests maker
PR: ports/72306 Submitted by: Alex Kapranoff <kappa(at)rambler-co.ru>
Notes
Notes: svn path=/head/; revision=122606
Diffstat (limited to 'devel/p5-Test-LectroTest')
-rw-r--r--devel/p5-Test-LectroTest/Makefile33
-rw-r--r--devel/p5-Test-LectroTest/distinfo2
-rw-r--r--devel/p5-Test-LectroTest/pkg-descr7
-rw-r--r--devel/p5-Test-LectroTest/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/p5-Test-LectroTest/Makefile b/devel/p5-Test-LectroTest/Makefile
new file mode 100644
index 000000000000..30d2e17628b5
--- /dev/null
+++ b/devel/p5-Test-LectroTest/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Test-LectroTest
+# Date created: October 4th 2004
+# Whom: Alex Kapranoff <alex@kapranoff.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-LectroTest
+PORTVERSION= 0.2007
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alex@kapranoff.ru
+COMMENT= Easy, automatic, specification-based tests
+
+PERL_MODBUILD= yes
+
+MAN3= Test::LectroTest.3 Test::LectroTest::Generator.3 \
+ Test::LectroTest::Property.3 Test::LectroTest::TestRunner.3 \
+ Test::LectroTest::Tutorial.3
+
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-LectroTest/distinfo b/devel/p5-Test-LectroTest/distinfo
new file mode 100644
index 000000000000..97eed15f2352
--- /dev/null
+++ b/devel/p5-Test-LectroTest/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-LectroTest-0.2007.tar.gz) = 15ee6bfc39dd925bf73a043c0a6f9d40
+SIZE (Test-LectroTest-0.2007.tar.gz) = 37048
diff --git a/devel/p5-Test-LectroTest/pkg-descr b/devel/p5-Test-LectroTest/pkg-descr
new file mode 100644
index 000000000000..260001541782
--- /dev/null
+++ b/devel/p5-Test-LectroTest/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a simple (yet full featured) automated,
+specification-based testing system for Perl. To use it, you declare
+properties that specify the expected behavior of your software.
+LectroTest then checks your software to see whether those properties
+hold for semi-random input values in the specified range.
+
+WWW: http://community.moertel.com/LectroTest
diff --git a/devel/p5-Test-LectroTest/pkg-plist b/devel/p5-Test-LectroTest/pkg-plist
new file mode 100644
index 000000000000..f67c8211ee24
--- /dev/null
+++ b/devel/p5-Test-LectroTest/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/LectroTest.pm
+%%SITE_PERL%%/Test/LectroTest/Generator.pm
+%%SITE_PERL%%/Test/LectroTest/Property.pm
+%%SITE_PERL%%/Test/LectroTest/TestRunner.pm
+%%SITE_PERL%%/Test/LectroTest/Tutorial.pod
+@dirrm %%SITE_PERL%%/Test/LectroTest
+@dirrm %%SITE_PERL%%/Test