aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Singleton
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-17 01:05:43 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-17 01:05:43 +0000
commiteb961371c00a448fd44a72d408bb74c767e9ed7c (patch)
tree7e89dc303517394c9e95e2803c89ea2665e832d8 /devel/p5-Test-Singleton
parent1a836eaca13e795efc57b07b30f3886d17db9e3d (diff)
downloadports-eb961371c00a448fd44a72d408bb74c767e9ed7c.tar.gz
ports-eb961371c00a448fd44a72d408bb74c767e9ed7c.zip
Add p5-Test-Singleton 1.03, test for Singleton classes.
PR: ports/100370 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168032
Diffstat (limited to 'devel/p5-Test-Singleton')
-rw-r--r--devel/p5-Test-Singleton/Makefile26
-rw-r--r--devel/p5-Test-Singleton/distinfo3
-rw-r--r--devel/p5-Test-Singleton/pkg-descr11
-rw-r--r--devel/p5-Test-Singleton/pkg-plist6
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-Test-Singleton/Makefile b/devel/p5-Test-Singleton/Makefile
new file mode 100644
index 000000000000..a34e35e281ff
--- /dev/null
+++ b/devel/p5-Test-Singleton/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Test-Singleton
+# Date created: 2006-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Singleton
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/T/TP/TPG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Test for Singleton classes
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Singleton.pm:${PORTSDIR}/devel/p5-Class-Singleton \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Singleton.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Singleton/distinfo b/devel/p5-Test-Singleton/distinfo
new file mode 100644
index 000000000000..fc55b856d51c
--- /dev/null
+++ b/devel/p5-Test-Singleton/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Singleton-1.03.tar.gz) = 3732ac90e6ceab5ab6d417077b38cc13
+SHA256 (Test-Singleton-1.03.tar.gz) = c2d8c17a065e58af93b55bdfe86dcbe418b906f182d74716ccaf89a4e4b8f69f
+SIZE (Test-Singleton-1.03.tar.gz) = 25572
diff --git a/devel/p5-Test-Singleton/pkg-descr b/devel/p5-Test-Singleton/pkg-descr
new file mode 100644
index 000000000000..b6c8ecd8bfa6
--- /dev/null
+++ b/devel/p5-Test-Singleton/pkg-descr
@@ -0,0 +1,11 @@
+** If you are unfamiliar with testing read Test::Tutorial first! **
+
+This is asimple, basic module for checking whether a class is a
+Singleton. A Singleton describes an object class that can have only
+one instance in any system. An example of a Singleton might be a print
+spooler or system registry, or any kind of central dispatcher.
+
+For a description and discussion of the Singleton class, see "Design
+Patterns", Gamma et al, Addison-Wesley, 1995, ISBN 0-201-63361-2.
+
+WWW: http://search.cpan.org/dist/Test-Singleton/
diff --git a/devel/p5-Test-Singleton/pkg-plist b/devel/p5-Test-Singleton/pkg-plist
new file mode 100644
index 000000000000..3699269d3b81
--- /dev/null
+++ b/devel/p5-Test-Singleton/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Singleton/.packlist
+%%SITE_PERL%%/Test/Singleton.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Singleton
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test