aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Time/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-08-12 09:57:59 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-08-12 09:57:59 +0000
commit88f83d45d8c81a59ecaeffa54fcdf46dd391e189 (patch)
treefd0647f7d8a704838ad4cbecbfb2993433184bd2 /devel/p5-Time/Makefile
parentca335ee595c60f4784cc8498e5b1feb294c135bb (diff)
downloadports-88f83d45d8c81a59ecaeffa54fcdf46dd391e189.tar.gz
ports-88f83d45d8c81a59ecaeffa54fcdf46dd391e189.zip
Update for perl version 5.00501. Requires latest bsd.port.mk. I'm
going to be a little verbose here about the changes so people who fix up the rest of the stuff can have an idea what to do. (1) Manpages are moved to version-specific subdirectories. Since they are all defined in MAN? macros, I just needed to add ${PERL_VERSION} to the end of MAN*PREFIX and delete them from the PLIST. (2) Most of the module files are moved to version-specific subdirectories. This is usually accomplished by adding "%%PERL_VER%%/" right after "site_perl/" in the PLIST. However, some things didn't move, and some moved more than one level (like, all the way into "site_perl/%%PERL_VER%%/auto/FooBar") so some fishing, err, find'ing was necessary. (3) Fix up dependencies. See (2) above. (4) While I was there, I changed some "@dirrm foobar"'s to "@unexec rmdir %D/foobar 2>/dev/null || true", so there won't be any warnings if a directory can't be removed due to other modules sharing it. Now all of devel/p5-* will install and deinstall without a single warning. I hope others will follow suit. :)
Notes
Notes: svn path=/head/; revision=12472
Diffstat (limited to 'devel/p5-Time/Makefile')
-rw-r--r--devel/p5-Time/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/p5-Time/Makefile b/devel/p5-Time/Makefile
index 1c95d265d941..eb5ef8c1c1a7 100644
--- a/devel/p5-Time/Makefile
+++ b/devel/p5-Time/Makefile
@@ -3,7 +3,7 @@
# Date created: October 12th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.7 1997/06/24 18:43:33 jfitz Exp $
+# $Id: Makefile,v 1.8 1998/03/11 03:05:06 vanilla Exp $
#
DISTNAME= Time-modules-97.092101
@@ -18,7 +18,7 @@ USE_PERL5= YES
MAN3= Time::CTime.3 Time::JulianDay.3 Time::ParseDate.3 \
Time::Timezone.3 Time::DaysInMonth.3
-MANPREFIX= ${PREFIX}/lib/perl5
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL