aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-autodie
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-09-23 11:57:02 +0000
committerWen Heping <wen@FreeBSD.org>2009-09-23 11:57:02 +0000
commit7b7e31a76b22d03fa3a1191ff6005f42e92c466e (patch)
tree04adfe3f85b7224708e6cc80227f3671c82e0c5d /devel/p5-autodie
parent26419984670f2257fe7dd546f6b6c14154098a15 (diff)
downloadports-7b7e31a76b22d03fa3a1191ff6005f42e92c466e.tar.gz
ports-7b7e31a76b22d03fa3a1191ff6005f42e92c466e.zip
The autodie pragma provides a convenient way to replace functions
that normally return false on failure with equivalents that throw an exception on failure. The autodie pragma has lexical scope, meaning that functions and subroutines altered with autodie will only change their behaviour until the end of the enclosing block, file, or eval. If system is specified as an argument to autodie, then it uses IPC::System::Simple to do the heavy lifting. See the description of that module for more information. WWW: http://search.cpan.org/dist/autodie/ Approved by: miwi(mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=241964
Diffstat (limited to 'devel/p5-autodie')
-rw-r--r--devel/p5-autodie/Makefile25
-rw-r--r--devel/p5-autodie/distinfo3
-rw-r--r--devel/p5-autodie/pkg-descr13
-rw-r--r--devel/p5-autodie/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-autodie/Makefile b/devel/p5-autodie/Makefile
new file mode 100644
index 000000000000..33fb2d430f3b
--- /dev/null
+++ b/devel/p5-autodie/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: autodie
+# Date created: 22 Sep, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autodie
+PORTVERSION= 2.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Replace functions with ones that succeed or die with lexical scope
+
+PERL_CONFIGURE= yes
+
+MAN3= Fatal.3 \
+ autodie::exception.3 \
+ autodie::hints.3 \
+ autodie::exception::system.3 \
+ autodie.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-autodie/distinfo b/devel/p5-autodie/distinfo
new file mode 100644
index 000000000000..a14e6b80abce
--- /dev/null
+++ b/devel/p5-autodie/distinfo
@@ -0,0 +1,3 @@
+MD5 (autodie-2.06.tar.gz) = f0e72b6ec163a1bc4b83bac2b64ba438
+SHA256 (autodie-2.06.tar.gz) = 5e509fce83c17b7965ece9ae5a5feec8ca28d6c858e18f0f81028b6e65cd24b2
+SIZE (autodie-2.06.tar.gz) = 73630
diff --git a/devel/p5-autodie/pkg-descr b/devel/p5-autodie/pkg-descr
new file mode 100644
index 000000000000..f90ae7f1dbc8
--- /dev/null
+++ b/devel/p5-autodie/pkg-descr
@@ -0,0 +1,13 @@
+The autodie pragma provides a convenient way to replace functions
+that normally return false on failure with equivalents that throw
+an exception on failure.
+
+The autodie pragma has lexical scope, meaning that functions and
+subroutines altered with autodie will only change their behaviour
+until the end of the enclosing block, file, or eval.
+
+If system is specified as an argument to autodie, then it uses
+IPC::System::Simple to do the heavy lifting. See the description
+of that module for more information.
+
+WWW: http://search.cpan.org/dist/autodie/
diff --git a/devel/p5-autodie/pkg-plist b/devel/p5-autodie/pkg-plist
new file mode 100644
index 000000000000..b0b006927ac7
--- /dev/null
+++ b/devel/p5-autodie/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Fatal.pm
+%%SITE_PERL%%/autodie.pm
+%%SITE_PERL%%/autodie/exception.pm
+%%SITE_PERL%%/autodie/hints.pm
+%%SITE_PERL%%/autodie/exception/system.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/autodie/.packlist
+@dirrm %%SITE_PERL%%/autodie/exception
+@dirrm %%SITE_PERL%%/autodie
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/autodie