aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-mixin
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-22 13:02:29 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-22 13:02:29 +0000
commit6a2691acfa67944ae562a7f25c5fbef1c4370830 (patch)
tree26e5bfefcfccf13d3d5b8e1a98e9485df47efe74 /devel/p5-mixin
parente780ab75d5e2070378e7a0e2e684aff784eb5bfc (diff)
downloadports-6a2691acfa67944ae562a7f25c5fbef1c4370830.tar.gz
ports-6a2691acfa67944ae562a7f25c5fbef1c4370830.zip
New port devel/p5-mixin
Mixin inheritance is an alternative to the usual multiple-inheritance and solves the problem of knowing which parent will be called. It also solves a number of tricky problems like diamond inheritence. The idea is to solve the same sets of problems which MI solves without the problems of MI. PR: 54746 Submitted by: Mathieu Arnold <m@absolight.net> Approved by: fjoe (mentor)
Notes
Notes: svn path=/head/; revision=85366
Diffstat (limited to 'devel/p5-mixin')
-rw-r--r--devel/p5-mixin/Makefile22
-rw-r--r--devel/p5-mixin/distinfo1
-rw-r--r--devel/p5-mixin/pkg-descr8
-rw-r--r--devel/p5-mixin/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-mixin/Makefile b/devel/p5-mixin/Makefile
new file mode 100644
index 000000000000..35b4001424cf
--- /dev/null
+++ b/devel/p5-mixin/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-mixin
+# Date created: 22 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mixin
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MS/MSCHWERN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Mix-in inheritance, an alternative to multiple inheritance
+
+PERL_CONFIGURE= yes
+
+MAN3= mixin.3 mixin::with.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-mixin/distinfo b/devel/p5-mixin/distinfo
new file mode 100644
index 000000000000..6e895ef58b1f
--- /dev/null
+++ b/devel/p5-mixin/distinfo
@@ -0,0 +1 @@
+MD5 (mixin-0.04.tar.gz) = cc1932a0a90dd905726373d7c2f6377f
diff --git a/devel/p5-mixin/pkg-descr b/devel/p5-mixin/pkg-descr
new file mode 100644
index 000000000000..2d7980c74ffa
--- /dev/null
+++ b/devel/p5-mixin/pkg-descr
@@ -0,0 +1,8 @@
+Mixin inheritance is an alternative to the usual multiple-inheritance and
+solves the problem of knowing which parent will be called. It also solves a
+number of tricky problems like diamond inheritence.
+
+The idea is to solve the same sets of problems which MI solves without the
+problems of MI.
+
+WWW: http://search.cpan.org/dist/mixin/
diff --git a/devel/p5-mixin/pkg-plist b/devel/p5-mixin/pkg-plist
new file mode 100644
index 000000000000..c302772a97ee
--- /dev/null
+++ b/devel/p5-mixin/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/mixin/.packlist
+%%SITE_PERL%%/mixin.pm
+%%SITE_PERL%%/mixin/with.pm
+@dirrm %%SITE_PERL%%/mixin
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/mixin