aboutsummaryrefslogtreecommitdiff
path: root/devel/pccts
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-18 13:05:17 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-18 13:05:17 +0000
commit76d907dca4714d541bd84c781d27afc645176d20 (patch)
tree9657bb3aa8ba3fe9a46a8d60b1cdb640c9e447cf /devel/pccts
parentc14d161186c0532c58f58158339df260267553ac (diff)
downloadports-76d907dca4714d541bd84c781d27afc645176d20.tar.gz
ports-76d907dca4714d541bd84c781d27afc645176d20.zip
Update to version 1.33.33
PR: 161600 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=283782
Diffstat (limited to 'devel/pccts')
-rw-r--r--devel/pccts/Makefile83
-rw-r--r--devel/pccts/pkg-plist112
2 files changed, 105 insertions, 90 deletions
diff --git a/devel/pccts/Makefile b/devel/pccts/Makefile
index 5ab9ca4c690c..6a4a2633a062 100644
--- a/devel/pccts/Makefile
+++ b/devel/pccts/Makefile
@@ -6,59 +6,74 @@
# $FreeBSD$
#
-PORTNAME= pccts
-PORTVERSION= 1.33.33
-CATEGORIES= devel
-MASTER_SITES= http://www.polhode.com/
-DISTNAME= pccts${PORTVERSION:R:S/.//}mr${PORTVERSION:E}
+PORTNAME= pccts
+PORTVERSION= 1.33.33
+CATEGORIES= devel
+MASTER_SITES= http://www.polhode.com/
+DISTNAME= pccts${PORTVERSION:R:S/.//}mr${PORTVERSION:E}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= The Purdue Compiler Construction Tool Set
CONFLICTS= antlr*
-USE_ZIP= yes
-WRKSRC= ${WRKDIR}/pccts
-ALL_TARGET=
-MAKEFILE= makefile
-MAKE_ENV= COPT="${CFLAGS}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
-MAN1= antlr.1 dlg.1
+USE_ZIP= yes
+MAKE_ENV= COPT="${CFLAGS}"
+MAKEFILE= makefile
+ALL_TARGET= # empty
+MAKE_JOBS_SAFE= yes
+
+MAN1= antlr.1 dlg.1
post-patch:
@${FIND} ${WRKSRC} -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
's|<varargs.h>|<stdarg.h>|g'
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/antlr ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dlg ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/genmk ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/sor ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/antlr/antlr.1 ${PREFIX}/man/man1
- @ ${INSTALL_MAN} ${WRKSRC}/dlg/dlg.1 ${PREFIX}/man/man1
- @ ${MKDIR} ${PREFIX}/include/pccts
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/antlr ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dlg ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/genmk ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/sor ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/antlr/antlr.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/dlg/dlg.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/include/pccts
.for file in ast charptr
- @ ${INSTALL_DATA} ${WRKSRC}/h/${file}.c ${PREFIX}/include/pccts/${file}.c
+ ${INSTALL_DATA} ${WRKSRC}/h/${file}.c ${PREFIX}/include/pccts/${file}.c
.endfor
.for file in AParser ASTBase ATokenBuffer BufFileInput DLexerBase PCCTSAST slist
- @ ${INSTALL_DATA} ${WRKSRC}/h/${file}.cpp ${PREFIX}/include/pccts/${file}.cpp
+ ${INSTALL_DATA} ${WRKSRC}/h/${file}.cpp ${PREFIX}/include/pccts/${file}.cpp
.endfor
-.for file in AParser ASTBase ATokPtr ATokPtrImpl AToken ATokenBuffer ATokenStream BufFileInput DLG_stream_input DLexer DLexerBase PBlackBox PCCTSAST SList antlr ast charbuf charptr config dlgauto dlgdef err int pccts_assert pccts_iostream pccts_istream pccts_setjmp pccts_stdarg pccts_stdio pccts_stdlib pccts_string pcctscfg
- @ ${INSTALL_DATA} ${WRKSRC}/h/${file}.h ${PREFIX}/include/pccts/${file}.h
+.for file in AParser ASTBase ATokPtr ATokPtrImpl AToken ATokenBuffer \
+ ATokenStream BufFileInput DLG_stream_input DLexer DLexerBase \
+ PBlackBox PCCTSAST SList antlr ast charbuf charptr config dlgauto \
+ dlgdef err int pccts_assert pccts_iostream pccts_istream pccts_setjmp \
+ pccts_stdarg pccts_stdio pccts_stdlib pccts_string pcctscfg
+ ${INSTALL_DATA} ${WRKSRC}/h/${file}.h ${PREFIX}/include/pccts/${file}.h
.endfor
- @ ${MKDIR} ${PREFIX}/share/examples/pccts
-.for dir in 1 2 3 4 5 6 7 8 9 10 11 12 13
- @ ${MKDIR} ${PREFIX}/share/examples/pccts/${dir}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in CHANGES_FROM_131.txt CHANGES_FROM_133.txt \
+ CHANGES_FROM_133_BEFORE_MR13.txt KNOWN_PROBLEMS.txt README RIGHTS \
+ history.ps history.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/${file}
.endfor
-.for file in makefile 1/makefile 1/test.g 2/MyLexer.cpp 2/MyLexer.h 2/makefile 2/test.g 3/MyLexer.cpp 3/MyLexer.h 3/makefile 3/mytokens.h 3/test.g 4/makefile 4/mytokens.h 4/test.g 5/input.h 5/makefile 5/test.g 6/file1 6/file2 6/main.cpp 6/makefile 6/makefile2 6/test.g 6/test2.g 7/makefile 7/test.g 8/main.cpp 8/makefile 8/test.g 9/makefile 9/test.g 10/makefile 10/test.g 11/input.h 11/makefile 11/test.g 12/makefile 12/test.g 13/makefile 13/test.g
- @ ${INSTALL_DATA} ${WRKSRC}/testcpp/${file} ${PREFIX}/share/examples/pccts/${file}
+.endif
+.if !defined(NOPORTEXAMPLES)
+.for dir in 1 2 3 4 5 6 7 8 9 10 11 12 13
+ @${MKDIR} ${EXAMPLESDIR}/${dir}
.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/pccts
-.for file in CHANGES_FROM_131.txt CHANGES_FROM_133.txt CHANGES_FROM_133_BEFORE_MR13.txt KNOWN_PROBLEMS.txt README RIGHTS history.ps history.txt
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/pccts/${file}
+.for file in makefile 1/makefile 1/test.g \
+ 2/MyLexer.cpp 2/MyLexer.h 2/makefile 2/test.g \
+ 3/MyLexer.cpp 3/MyLexer.h 3/makefile 3/mytokens.h 3/test.g \
+ 4/makefile 4/mytokens.h 4/test.g 5/input.h 5/makefile 5/test.g \
+ 6/file1 6/file2 6/main.cpp 6/makefile 6/makefile2 6/test.g 6/test2.g \
+ 7/makefile 7/test.g 8/main.cpp 8/makefile 8/test.g \
+ 9/makefile 9/test.g 10/makefile 10/test.g \
+ 11/input.h 11/makefile 11/test.g 12/makefile 12/test.g \
+ 13/makefile 13/test.g
+ ${INSTALL_DATA} ${WRKSRC}/testcpp/${file} ${EXAMPLESDIR}/${file}
.endfor
.endif
diff --git a/devel/pccts/pkg-plist b/devel/pccts/pkg-plist
index 3f8c8c8fdc0f..94b76fe9babc 100644
--- a/devel/pccts/pkg-plist
+++ b/devel/pccts/pkg-plist
@@ -51,60 +51,60 @@ include/pccts/slist.cpp
%%PORTDOCS%%%%DOCSDIR%%/RIGHTS
%%PORTDOCS%%%%DOCSDIR%%/history.txt
%%PORTDOCS%%%%DOCSDIR%%/history.ps
-%%EXAMPLESDIR%%/makefile
-%%EXAMPLESDIR%%/1/makefile
-%%EXAMPLESDIR%%/1/test.g
-%%EXAMPLESDIR%%/2/makefile
-%%EXAMPLESDIR%%/2/test.g
-%%EXAMPLESDIR%%/2/MyLexer.h
-%%EXAMPLESDIR%%/2/MyLexer.cpp
-%%EXAMPLESDIR%%/3/test.g
-%%EXAMPLESDIR%%/3/mytokens.h
-%%EXAMPLESDIR%%/3/makefile
-%%EXAMPLESDIR%%/3/MyLexer.h
-%%EXAMPLESDIR%%/3/MyLexer.cpp
-%%EXAMPLESDIR%%/4/test.g
-%%EXAMPLESDIR%%/4/mytokens.h
-%%EXAMPLESDIR%%/4/makefile
-%%EXAMPLESDIR%%/5/test.g
-%%EXAMPLESDIR%%/5/makefile
-%%EXAMPLESDIR%%/5/input.h
-%%EXAMPLESDIR%%/6/test2.g
-%%EXAMPLESDIR%%/6/test.g
-%%EXAMPLESDIR%%/6/makefile2
-%%EXAMPLESDIR%%/6/makefile
-%%EXAMPLESDIR%%/6/main.cpp
-%%EXAMPLESDIR%%/6/file2
-%%EXAMPLESDIR%%/6/file1
-%%EXAMPLESDIR%%/7/test.g
-%%EXAMPLESDIR%%/7/makefile
-%%EXAMPLESDIR%%/8/test.g
-%%EXAMPLESDIR%%/8/makefile
-%%EXAMPLESDIR%%/8/main.cpp
-%%EXAMPLESDIR%%/9/test.g
-%%EXAMPLESDIR%%/9/makefile
-%%EXAMPLESDIR%%/10/test.g
-%%EXAMPLESDIR%%/10/makefile
-%%EXAMPLESDIR%%/11/test.g
-%%EXAMPLESDIR%%/11/makefile
-%%EXAMPLESDIR%%/11/input.h
-%%EXAMPLESDIR%%/12/makefile
-%%EXAMPLESDIR%%/12/test.g
-%%EXAMPLESDIR%%/13/makefile
-%%EXAMPLESDIR%%/13/test.g
-@dirrm include/pccts
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2/MyLexer.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/2/MyLexer.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3/mytokens.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3/MyLexer.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3/MyLexer.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/4/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/4/mytokens.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/4/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/5/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/5/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/5/input.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/test2.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/makefile2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/main.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/file2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/6/file1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/7/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/7/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/8/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/8/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/8/main.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/9/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/9/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/10/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/10/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/11/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/11/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/11/input.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/12/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/12/test.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/13/makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/13/test.g
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/13
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/12
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/11
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/10
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/9
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/8
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/7
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/6
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/5
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/4
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/3
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/2
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/1
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%/1
-@dirrm %%EXAMPLESDIR%%/2
-@dirrm %%EXAMPLESDIR%%/3
-@dirrm %%EXAMPLESDIR%%/4
-@dirrm %%EXAMPLESDIR%%/5
-@dirrm %%EXAMPLESDIR%%/6
-@dirrm %%EXAMPLESDIR%%/7
-@dirrm %%EXAMPLESDIR%%/8
-@dirrm %%EXAMPLESDIR%%/9
-@dirrm %%EXAMPLESDIR%%/10
-@dirrm %%EXAMPLESDIR%%/11
-@dirrm %%EXAMPLESDIR%%/12
-@dirrm %%EXAMPLESDIR%%/13
-@dirrm %%EXAMPLESDIR%%
+@dirrm include/pccts