aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PEAR
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
commit050dd1b1031022b49cd1623dd3892f3c4be3a1ae (patch)
tree0876fb5cc1d38a316c0fbaf87137d69775f5dad0 /devel/pear-PEAR
parentcf19879c06b65241c187f1b0663a0db0270be14f (diff)
downloadports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.tar.gz
ports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=70285
Diffstat (limited to 'devel/pear-PEAR')
-rw-r--r--devel/pear-PEAR/Makefile45
-rw-r--r--devel/pear-PEAR/distinfo1
-rw-r--r--devel/pear-PEAR/pkg-comment1
-rw-r--r--devel/pear-PEAR/pkg-descr4
-rw-r--r--devel/pear-PEAR/pkg-plist34
5 files changed, 85 insertions, 0 deletions
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
new file mode 100644
index 000000000000..b1bb6bede494
--- /dev/null
+++ b/devel/pear-PEAR/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pear-PEAR
+# Date created: 22 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PEAR
+PORTVERSION= 1.0.1
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1/b1/}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/PEAR ${PEARDIR}/PEAR.dist
+ @${MV} ${PEARDIR}/PEAR.php ${PEARDIR}/PEAR.php.dist
+ @${MV} ${PEARDIR}/System.php ${PEARDIR}/System.php.dist
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/OS
+ @${CHOWN} -R root:wheel ${PEARDIR}/PEAR*
+ @${CHOWN} -R root:wheel ${PEARDIR}/System.php
+ @${CHOWN} -R root:wheel ${PEARDIR}/package.dtd
+ @${CHOWN} -R root:wheel ${PEARDIR}/scripts
+ @${CHOWN} -R root:wheel ${PEARDIR}/template.spec
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PEAR/distinfo b/devel/pear-PEAR/distinfo
new file mode 100644
index 000000000000..fe522402bd58
--- /dev/null
+++ b/devel/pear-PEAR/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/PEAR-1.0b1.tgz) = 6109077247d825df343f766713e899de
diff --git a/devel/pear-PEAR/pkg-comment b/devel/pear-PEAR/pkg-comment
new file mode 100644
index 000000000000..bee5cc06093c
--- /dev/null
+++ b/devel/pear-PEAR/pkg-comment
@@ -0,0 +1 @@
+PEAR Base System
diff --git a/devel/pear-PEAR/pkg-descr b/devel/pear-PEAR/pkg-descr
new file mode 100644
index 000000000000..a74f3c8c6a11
--- /dev/null
+++ b/devel/pear-PEAR/pkg-descr
@@ -0,0 +1,4 @@
+PEAR Base System, with the PEAR base class and the PEAR_Error error handling
+mechanism.
+
+WWW: http://pear.php.net/manual/en/reference.php
diff --git a/devel/pear-PEAR/pkg-plist b/devel/pear-PEAR/pkg-plist
new file mode 100644
index 000000000000..9f99761be75d
--- /dev/null
+++ b/devel/pear-PEAR/pkg-plist
@@ -0,0 +1,34 @@
+%%PEARDIR%%/package.dtd
+%%PEARDIR%%/template.spec
+%%PEARDIR%%/PEAR.php
+%%PEARDIR%%/System.php
+%%PEARDIR%%/OS/Guess.php
+%%PEARDIR%%/PEAR/Autoloader.php
+%%PEARDIR%%/PEAR/Command.php
+%%PEARDIR%%/PEAR/Command/Auth.php
+%%PEARDIR%%/PEAR/Command/Build.php
+%%PEARDIR%%/PEAR/Command/Common.php
+%%PEARDIR%%/PEAR/Command/Config.php
+%%PEARDIR%%/PEAR/Command/Install.php
+%%PEARDIR%%/PEAR/Command/Package.php
+%%PEARDIR%%/PEAR/Command/Registry.php
+%%PEARDIR%%/PEAR/Command/Remote.php
+%%PEARDIR%%/PEAR/Common.php
+%%PEARDIR%%/PEAR/Config.php
+%%PEARDIR%%/PEAR/Dependency.php
+%%PEARDIR%%/PEAR/Frontend/CLI.php
+%%PEARDIR%%/PEAR/Builder.php
+%%PEARDIR%%/PEAR/Installer.php
+%%PEARDIR%%/PEAR/Packager.php
+%%PEARDIR%%/PEAR/Registry.php
+%%PEARDIR%%/PEAR/Remote.php
+%%PEARDIR%%/scripts/pear.in
+%%PEARDIR%%/scripts/pear.bat
+@dirrm %%PEARDIR%%/OS
+@dirrm %%PEARDIR%%/PEAR/Command
+@dirrm %%PEARDIR%%/PEAR/Frontend
+@dirrm %%PEARDIR%%/PEAR
+@dirrm %%PEARDIR%%/scripts
+@unexec mv %D/lib/php/PEAR.dist %D/lib/php/PEAR || true
+@unexec mv %D/lib/php/PEAR.php.dist %D/lib/php/PEAR.php || true
+@unexec mv %D/lib/php/System.php.dist %D/lib/php/System.php || true