aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PHP_Parser
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-05 21:02:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-05 21:02:28 +0000
commit0fe631cc4ba4b971551c2030e93fabdec34a38cb (patch)
tree7d067fe7ab0f1de3632d12baff81854416708733 /devel/pear-PHP_Parser
parent3a16435e442e09b3e75c6613a7b70a29de7c16cf (diff)
downloadports-0fe631cc4ba4b971551c2030e93fabdec34a38cb.tar.gz
ports-0fe631cc4ba4b971551c2030e93fabdec34a38cb.zip
PHP_Parser is a source code analysis tool based around a real Parser
generated by PHP_ParserGenerator. The parser uses the same EBNF source that PHP uses to parse itself, modified for Lemon parser format, and it therefore as robust as PHP itself. WWW: http://pear.php.net/package/PHP_Parser/
Notes
Notes: svn path=/head/; revision=197145
Diffstat (limited to 'devel/pear-PHP_Parser')
-rw-r--r--devel/pear-PHP_Parser/Makefile29
-rw-r--r--devel/pear-PHP_Parser/distinfo3
-rw-r--r--devel/pear-PHP_Parser/pkg-descr6
3 files changed, 38 insertions, 0 deletions
diff --git a/devel/pear-PHP_Parser/Makefile b/devel/pear-PHP_Parser/Makefile
new file mode 100644
index 000000000000..79834bb9ecd9
--- /dev/null
+++ b/devel/pear-PHP_Parser/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-PHP_Parser
+# Date created: 05 August 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP_Parser
+PORTVERSION= 0.2.1
+CATEGORIES= devel www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A PHP Grammar Parser
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= PHP
+FILES= Parser.php Parser/Core.php Parser/Core.y \
+ Parser/Tokenizer.php
+TESTS= basic.phpt unticked_statement1.phpt \
+ files/basic.inc files/unticked_statement1.inc
+DOCS= PHP_Parser_MsgServer.cls
+_DOCSDIR= docs/tutorials/PHP_Parser
+EXAMPLES= test.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PHP_Parser/distinfo b/devel/pear-PHP_Parser/distinfo
new file mode 100644
index 000000000000..ec6325204807
--- /dev/null
+++ b/devel/pear-PHP_Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/PHP_Parser-0.2.1.tgz) = 53f1d8d7cdc8949ad55ea0d094342aa1
+SHA256 (PEAR/PHP_Parser-0.2.1.tgz) = 335ec6ba71e63e438c709e9fc5040fc9ee134585b705a1757b426a15005dfc44
+SIZE (PEAR/PHP_Parser-0.2.1.tgz) = 70782
diff --git a/devel/pear-PHP_Parser/pkg-descr b/devel/pear-PHP_Parser/pkg-descr
new file mode 100644
index 000000000000..b6876c6ea137
--- /dev/null
+++ b/devel/pear-PHP_Parser/pkg-descr
@@ -0,0 +1,6 @@
+PHP_Parser is a source code analysis tool based around a real Parser
+generated by PHP_ParserGenerator. The parser uses the same EBNF source
+that PHP uses to parse itself, modified for Lemon parser format,
+and it therefore as robust as PHP itself.
+
+WWW: http://pear.php.net/package/PHP_Parser/