aboutsummaryrefslogtreecommitdiff
path: root/devel/pear
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-26 23:15:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-26 23:15:47 +0000
commit98d90633ba414e1bd45b202e0a9d5747fdb213e5 (patch)
treeb8825f267c3137932d2efdd72e347eca53ca4b89 /devel/pear
parent97da34fd28951c3c61c056456900354fc2aa2ac7 (diff)
downloadports-98d90633ba414e1bd45b202e0a9d5747fdb213e5.tar.gz
ports-98d90633ba414e1bd45b202e0a9d5747fdb213e5.zip
- Update to 1.8.1
Changelog: for 1.8.0 Release http://pear.php.net/package/PEAR/download/1.8.0 for 1.8.1 Release http://pear.php.net/package/PEAR/download/1.8.1 Thanks for help/testing: ale@, dhn@, beat@, tabthorpe@
Notes
Notes: svn path=/head/; revision=232787
Diffstat (limited to 'devel/pear')
-rw-r--r--devel/pear/Makefile2
-rw-r--r--devel/pear/distinfo6
-rw-r--r--devel/pear/files/patch-go-pear111
-rw-r--r--devel/pear/pkg-descr3
-rw-r--r--devel/pear/pkg-plist7
5 files changed, 79 insertions, 50 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
index cbbb79dc5308..5f14f28870fd 100644
--- a/devel/pear/Makefile
+++ b/devel/pear/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pear
-PORTVERSION= 1.7.2
+PORTVERSION= 1.8.1
CATEGORIES= devel
MASTER_SITES= http://freebsd.unixfreunde.de/sources/
diff --git a/devel/pear/distinfo b/devel/pear/distinfo
index 51ba189ebbcf..6b14ea88c36a 100644
--- a/devel/pear/distinfo
+++ b/devel/pear/distinfo
@@ -1,3 +1,3 @@
-MD5 (pear-1.7.2.tar.bz2) = 851543783b0f7227ca48279462527382
-SHA256 (pear-1.7.2.tar.bz2) = fff170baf28c8c27bc4b89443b402fc63ac1c8f2cfa0f5bc4c70d8373189ee1a
-SIZE (pear-1.7.2.tar.bz2) = 296233
+MD5 (pear-1.8.1.tar.bz2) = b63d86f9ae0dfcaf108a46d926e570c8
+SHA256 (pear-1.8.1.tar.bz2) = 9a35a28e6381c040cc2cc865ddbc49ad3badd74ed825298b5879b50de5728625
+SIZE (pear-1.8.1.tar.bz2) = 306044
diff --git a/devel/pear/files/patch-go-pear b/devel/pear/files/patch-go-pear
index ddd3e4b1134f..ee0cd5100d60 100644
--- a/devel/pear/files/patch-go-pear
+++ b/devel/pear/files/patch-go-pear
@@ -1,70 +1,100 @@
---- go-pear.orig Fri Apr 27 23:07:03 2007
-+++ go-pear Mon Apr 30 10:15:47 2007
-@@ -308,6 +308,7 @@
- $install_pfc = $_SESSION['go-pear']['install_pfc'];
+--- go-pear.orig 2009-04-08 12:20:28.000000000 +0200
++++ go-pear 2009-04-26 20:51:39.000000000 +0200
+@@ -116,7 +116,7 @@
+ );
+
+ $installer_packages = array(
+- 'PEAR',
++ 'PEAR-stable',
+ 'Structures_Graph-stable',
+ 'Archive_Tar-stable',
+ 'Console_Getopt-stable',
+@@ -250,7 +250,7 @@
+ }
+ // Anything past this step has something to do with the installation
}
-
+-
+/*
if (!WEBINSTALLER) {
$tty = WINDOWS ? @fopen('\con', 'r') : @fopen('/dev/tty', 'r');
-@@ -351,6 +352,7 @@
+@@ -294,7 +294,7 @@
$http_proxy = $tmp;
}
}
+-
+*/
-
$origpwd = getcwd();
-@@ -423,6 +425,7 @@
+ $config_vars = array_keys($config_desc);
+@@ -345,7 +345,7 @@
+ break;
}
}
-
+-
+/*
while (!WEBINSTALLER) {
print "
Below is a suggested file layout for your new PEAR installation. To
-@@ -505,6 +508,7 @@
+@@ -428,7 +428,7 @@
}
}
}
+-
+*/
-
- foreach ($config_vars as $n => $var) {
- for ($m = 1; $m <= count($config_vars); $m++) {
-@@ -573,6 +577,7 @@
+ ####
+ # Installation stuff
+ ####
+@@ -561,7 +561,7 @@
+ ob_start();
}
}
-
+-
+/*
if (!WEBINSTALLER) {
$msg = "The following PEAR packages are bundled with PHP: " .
- implode(', ', $pfc_packages);
-@@ -581,6 +586,7 @@
- $install_pfc = !stristr(fgets($tty, 1024), "n");
+ implode(', ', array_keys($pfc_packages));
+@@ -571,7 +571,7 @@
+ $install_optional_packages = array();
print "\n";
}
+-
+*/
-
####
# Download
-@@ -592,6 +598,7 @@
+ ####
+@@ -581,7 +581,7 @@
+ } else {
ini_set('include_path', $ptmp);
}
-
+-
+/*
if (!extension_loaded('zlib') && !WEBINSTALLER) { // In Web context we could be in multithread env which makes dl() end up with a fatal error.
if (WINDOWS) {
@dl('php_zlib.dll');
-@@ -616,6 +623,7 @@
+@@ -606,18 +606,19 @@
if (!$have_gzip) {
print "Downloading uncompressed packages\n";
};
+-
+*/
-
if ($install_pfc) {
- $to_install = array_merge($installer_packages, $pfc_packages);
-@@ -775,7 +783,7 @@
+ $to_install = array_merge($installer_packages, array_keys($pfc_packages));
+ } else {
+ $to_install = $installer_packages;
+-
++/*
+ // webinstaller allows to choose pfc packages individually
+ foreach ($pfc_packages as $pkg => $desc) {
+ if (in_array($pkg, $install_optional_packages)) {
+ array_push($to_install, $pkg);
+ }
+ }
++*/
+ }
+
+ // gopear_bundle usage
+@@ -750,7 +751,7 @@
if (WEBINSTALLER || isset($_SERVER['argv'][1]) && $_SERVER['argv'][1] == 'local') {
$config = &PEAR_Config::singleton($prefix."/pear.conf", '');
} else {
@@ -73,45 +103,49 @@
}
-@@ -811,6 +819,7 @@
+@@ -821,7 +822,7 @@
- // Base installation finished
+ // Base installation finished
+-
+/*
ini_restore("include_path");
if (!WEBINSTALLER) {
-@@ -968,6 +977,7 @@
+@@ -980,6 +981,7 @@
if (WINDOWS && !WEBINSTALLER) {
win32CreateRegEnv();
}
+*/
// Set of functions following
-
- // {{{ download_url()
-@@ -1364,17 +1374,17 @@
+ /**
+ * Parse the given dirname
+@@ -1418,19 +1420,17 @@
}
} else {
if ($_prefix === null) {
-- $prefix = dirname(PHP_BINDIR);
-+ $prefix = "%%PREFIX%%";
+- #$prefix = dirname(PHP_BINDIR);
+- $prefix = dirname(__FILE__);
++ $prefix = '%%PREFIX%%';
} else {
$prefix = $_prefix;
}
$bin_dir = '$prefix/bin';
- $php_dir = '$prefix/share/pear';
+- #$php_dir = '$prefix/share/pear';
+- $php_dir = '$prefix/PEAR';
- $doc_dir = '$php_dir/docs';
++ $php_dir = '$prefix/share/pear';
+ $doc_dir = '$prefix/share/doc/pear';
$data_dir = '$php_dir/data';
$test_dir = '$php_dir/tests';
- $temp_dir = '$prefix/temp';
-
-+ $temp_dir = '/tmp';
++ $temp_dir = '/tmp/go-pear';
+/*
// check if the user has installed PHP with PHP or GNU layout
if (@is_dir("$prefix/lib/php/.registry")) {
$php_dir = '$prefix/lib/php';
-@@ -1386,6 +1396,7 @@
+@@ -1442,6 +1442,7 @@
} elseif (@is_dir("$prefix/share/php/.registry")) {
$php_dir = '$prefix/share/php';
}
@@ -119,8 +153,3 @@
}
}
-@@ -2491,3 +2502,4 @@
- }
- return true;
- }
-+?>
diff --git a/devel/pear/pkg-descr b/devel/pear/pkg-descr
index e371f2cc0a22..a9e997c034d3 100644
--- a/devel/pear/pkg-descr
+++ b/devel/pear/pkg-descr
@@ -8,6 +8,3 @@ pronounced just like the fruit. The purpose of PEAR is to provide:
- The PHP Extension Community Library (PECL)
WWW: http://pear.php.net/
-
-- Alex Dupre
-ale@FreeBSD.org
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
index 71375eec0120..9da5a80692ee 100644
--- a/devel/pear/pkg-plist
+++ b/devel/pear/pkg-plist
@@ -4,6 +4,7 @@ bin/pecl
etc/pear.conf
%%DOCSDIR%%/Archive_Tar/docs/Archive_Tar.txt
%%DOCSDIR%%/PEAR/INSTALL
+%%DOCSDIR%%/PEAR/LICENSE
%%DOCSDIR%%/PEAR/README
%%DOCSDIR%%/Structures_Graph/docs/generate.sh
%%DOCSDIR%%/Structures_Graph/docs/html/Structures_Graph/Structures_Graph.html
@@ -28,7 +29,9 @@ etc/pear.conf
%%DOCSDIR%%/Structures_Graph/docs/tutorials/Structures_Graph/Structures_Graph.pkg
%%DATADIR%%/.channels/.alias/pear.txt
%%DATADIR%%/.channels/.alias/pecl.txt
+%%DATADIR%%/.channels/.alias/phpdocs.txt
%%DATADIR%%/.channels/__uri.reg
+%%DATADIR%%/.channels/doc.php.net.reg
%%DATADIR%%/.channels/pear.php.net.reg
%%DATADIR%%/.channels/pecl.php.net.reg
@exec touch %D/share/pear/.depdb
@@ -72,7 +75,6 @@ etc/pear.conf
%%DATADIR%%/PEAR/Command.php
%%DATADIR%%/PEAR/Common.php
%%DATADIR%%/PEAR/Config.php
-%%DATADIR%%/PEAR/Dependency.php
%%DATADIR%%/PEAR/Dependency2.php
%%DATADIR%%/PEAR/DependencyDB.php
%%DATADIR%%/PEAR/Downloader/Package.php
@@ -118,7 +120,6 @@ etc/pear.conf
%%DATADIR%%/PEAR/FixPHP5PEARWarnings.php
%%DATADIR%%/PEAR/REST.php
%%DATADIR%%/PEAR/Registry.php
-%%DATADIR%%/PEAR/Remote.php
%%DATADIR%%/PEAR/RunTest.php
%%DATADIR%%/PEAR/Task/Common.php
%%DATADIR%%/PEAR/Task/Postinstallscript/rw.php
@@ -133,6 +134,7 @@ etc/pear.conf
%%DATADIR%%/PEAR/Validator/PECL.php
%%DATADIR%%/PEAR/XMLParser.php
%%DATADIR%%/PEAR.php
+%%DATADIR%%/PEAR5.php
%%DATADIR%%/Structures/Graph/Manipulator/AcyclicTest.php
%%DATADIR%%/Structures/Graph/Manipulator/TopologicalSorter.php
%%DATADIR%%/Structures/Graph/Node.php
@@ -167,6 +169,7 @@ etc/pear.conf
@dirrmtry share/pear/.channels/.alias
@dirrmtry share/pear/.channels
@dirrmtry share/pear/.registry/.channel.__uri
+@dirrmtry share/pear/.registry/.channel.doc.php.net
@dirrmtry share/pear/.registry/.channel.pecl.php.net
@dirrmtry share/pear/.registry
@dirrm %%DATADIR%%/Archive