aboutsummaryrefslogtreecommitdiff
path: root/devel/perforce
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-01-18 15:43:36 +0000
committerLars Thegler <lth@FreeBSD.org>2005-01-18 15:43:36 +0000
commita306f64971833bdabd84eeabcd9995cf27820aed (patch)
tree39bc9c5d9b5c792ce87779b6df47647ef167b640 /devel/perforce
parent1abaada90953ee5358aea7178bc93113a227fa91 (diff)
downloadports-a306f64971833bdabd84eeabcd9995cf27820aed.tar.gz
ports-a306f64971833bdabd84eeabcd9995cf27820aed.zip
- Start p4web from rc.d script [1]
- Assume maintainership Submitted by: Mark Santcroos <marks@ripe.net> [1] Reviewed by: tobez
Notes
Notes: svn path=/head/; revision=126720
Diffstat (limited to 'devel/perforce')
-rw-r--r--devel/perforce/Makefile8
-rw-r--r--devel/perforce/files/perforce.conf.in15
-rw-r--r--devel/perforce/files/perforce.sh.in8
3 files changed, 27 insertions, 4 deletions
diff --git a/devel/perforce/Makefile b/devel/perforce/Makefile
index 7b07337b4981..2038d9691c7e 100644
--- a/devel/perforce/Makefile
+++ b/devel/perforce/Makefile
@@ -16,7 +16,7 @@ DISTFILES= ${BIN_FILES} ${SBIN_FILES}
DIST_SUBDIR= perforce/${VERSION}/${ARCH}
EXTRACT_ONLY= # none
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lth@FreeBSD.org
COMMENT= Perforce client and server
#
@@ -29,10 +29,10 @@ ARCH?= i386
MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
.if ${ARCH} == i386
VERSION= 04.2
-REVISION= 7
+REVISION= 8
PLATFORM= freebsd4
-BIN_FILES= p4 p4web
-SBIN_FILES= p4d p4ftpd p4p
+BIN_FILES= p4
+SBIN_FILES= p4d p4ftpd p4p p4web
REL_NOTES= http://www.perforce.com/perforce/doc.042/user/relnotes.txt
.elif ${ARCH} == alpha
VERSION= 99.1
diff --git a/devel/perforce/files/perforce.conf.in b/devel/perforce/files/perforce.conf.in
index 5db4fded51a2..803c56f86d17 100644
--- a/devel/perforce/files/perforce.conf.in
+++ b/devel/perforce/files/perforce.conf.in
@@ -58,3 +58,18 @@ PERFORCE_PROXY_OPTIONS="-d -p $PERFORCE_PORT -t $PERFORCE_PROXY_TARGET -r $PERFO
# Uncomment this line to have the proxy server started automatically
#
#PERFORCE_PROXY_START=yes
+
+#
+# p4web port
+#
+PERFORCE_WEB_PORT="6060"
+
+#
+# p4web options (see p4web -h)
+#
+PERFORCE_WEB_OPTIONS="-B -w $PERFORCE_WEB_PORT -p $PERFORCE_PORT -v server=1"
+
+#
+# Uncomment this line to have the web server started automatically
+#
+#PERFORCE_WEB_START=yes
diff --git a/devel/perforce/files/perforce.sh.in b/devel/perforce/files/perforce.sh.in
index e32da8484282..f0ed1db1c3b5 100644
--- a/devel/perforce/files/perforce.sh.in
+++ b/devel/perforce/files/perforce.sh.in
@@ -5,6 +5,7 @@
p4d=@PREFIX@/sbin/p4d
p4ftpd=@PREFIX@/sbin/p4ftpd
p4p=@PREFIX@/sbin/p4p
+p4web=@PREFIX@/sbin/p4web
case $1 in
start)
@@ -21,6 +22,10 @@ start)
echo -n ' p4p'
$p4p $PERFORCE_PROXY_OPTIONS
fi
+ if [ -x $p4web -a x$PERFORCE_WEB_START = xyes ]; then
+ echo -n ' p4web'
+ su -fm $PERFORCE_USER -c "$p4web $PERFORCE_WEB_OPTIONS > /dev/null 2>&1 &"
+ fi
;;
stop)
@@ -34,6 +39,9 @@ stop)
if [ -x $p4p ]; then
killall -u 0 p4p > /dev/null 2>&1 && echo -n ' p4p'
fi
+ if [ -x $p4web ]; then
+ killall -u $PERFORCE_USER p4web > /dev/null 2>&1 && echo -n ' p4web'
+ fi
;;
restart)
$0 stop