aboutsummaryrefslogtreecommitdiff
path: root/devel/physfs-devel
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-26 16:22:18 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-26 16:22:18 +0000
commit21864d5f393d1dceb25c1289356c0781cd35e0ca (patch)
treefea8e6d7f1b6d26412613213bba47c184915539c /devel/physfs-devel
parent39ac94bc8433b950a3ec2455fa0ffdfd9d06c6ca (diff)
downloadports-21864d5f393d1dceb25c1289356c0781cd35e0ca.tar.gz
ports-21864d5f393d1dceb25c1289356c0781cd35e0ca.zip
Add physfs, a library to provide abstract access to various archives
Notes
Notes: svn path=/head/; revision=85630
Diffstat (limited to 'devel/physfs-devel')
-rw-r--r--devel/physfs-devel/Makefile21
-rw-r--r--devel/physfs-devel/distinfo1
-rw-r--r--devel/physfs-devel/pkg-descr19
-rw-r--r--devel/physfs-devel/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/physfs-devel/Makefile b/devel/physfs-devel/Makefile
new file mode 100644
index 000000000000..7c753a272a64
--- /dev/null
+++ b/devel/physfs-devel/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: physfs
+# Date Created: 26 July 2003
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= physfs
+PORTVERSION= 0.1.8
+CATEGORIES= devel
+MASTER_SITES= http://icculus.org/${PORTNAME}/downloads/
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A library to provide abstract access to various archives
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_ARGS= --program-transform-name=''
+
+.include <bsd.port.mk>
diff --git a/devel/physfs-devel/distinfo b/devel/physfs-devel/distinfo
new file mode 100644
index 000000000000..1fd158eb7ef8
--- /dev/null
+++ b/devel/physfs-devel/distinfo
@@ -0,0 +1 @@
+MD5 (physfs-0.1.8.tar.gz) = 4993d229d38c0207c00074831fd7b8be
diff --git a/devel/physfs-devel/pkg-descr b/devel/physfs-devel/pkg-descr
new file mode 100644
index 000000000000..c1e07bc80f7d
--- /dev/null
+++ b/devel/physfs-devel/pkg-descr
@@ -0,0 +1,19 @@
+PhysicsFS is a library to provide abstract access to various archives.
+It is intended for use in video games, and the design was somewhat
+inspired by Quake 3's file subsystem. The programmer defines a "write
+directory" on the physical filesystem. No file writing done through the
+PhysicsFS API can leave that write directory, for security. For example,
+an embedded scripting language cannot write outside of this path if it
+uses PhysFS for all of its I/O, which means that untrusted scripts can
+run more safely. Symbolic links can be disabled as well, for added
+safety. For file reading, the programmer lists directories and archives
+that form a "search path". Once the search path is defined, it becomes
+a single, transparent hierarchical filesystem. This makes for easy
+access to ZIP files in the same way as you access a file directly on the
+disk, and it makes it easy to ship a new archive that will override a
+previous archive on a per-file basis. Finally, PhysicsFS gives you
+platform-abstracted means to determine if CD-ROMs are available, the
+user's home directory, where in the real filesystem your program is
+running, etc.
+
+WWW: http://icculus.org/physfs/
diff --git a/devel/physfs-devel/pkg-plist b/devel/physfs-devel/pkg-plist
new file mode 100644
index 000000000000..840e41b40823
--- /dev/null
+++ b/devel/physfs-devel/pkg-plist
@@ -0,0 +1,5 @@
+bin/test_physfs
+include/physfs.h
+lib/libphysfs-0.1.so.8
+lib/libphysfs.la
+lib/libphysfs.a