aboutsummaryrefslogtreecommitdiff
path: root/devel/pinba_engine
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-01-07 23:52:46 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-01-07 23:52:46 +0000
commiteb67ad58d8484e416758344dda401087e8b4c125 (patch)
treeb79ef5e8e8d01567019bb0c87fd7df325fe2d653 /devel/pinba_engine
parent794a0f62810e2dddb49a13b8be3e9bafdbcd10fc (diff)
downloadports-eb67ad58d8484e416758344dda401087e8b4c125.tar.gz
ports-eb67ad58d8484e416758344dda401087e8b4c125.zip
Pinba is a statistics server for PHP using MySQL as a read-only
interface. It accumulates and processes data sent over UDP by multiple PHP processes and displays statistics in a nice human-readable form of simple "reports", also providing a read-only interface to the raw data to enable generation of more sophisticated reports. With the Pinba extension, users can also measure particular parts of the code using timers with arbitrary tags. Pinba is not a debugging tool in the common sense, since you're not supposed to do debugging on production servers, but its main goal is to help developers to locate bottlenecks in realtime and direct their attention to the code that really needs it. WWW: http://pinba.org/ - raven428 raven428@gmail.com PR: ports/141997 Submitted by: raven428 <raven428 at gmail.com>
Notes
Notes: svn path=/head/; revision=247357
Diffstat (limited to 'devel/pinba_engine')
-rw-r--r--devel/pinba_engine/Makefile53
-rw-r--r--devel/pinba_engine/distinfo3
-rw-r--r--devel/pinba_engine/files/patch-src__ha_pinba.cc10
-rw-r--r--devel/pinba_engine/files/pkg-message.in10
-rw-r--r--devel/pinba_engine/pkg-descr19
-rw-r--r--devel/pinba_engine/pkg-plist6
6 files changed, 101 insertions, 0 deletions
diff --git a/devel/pinba_engine/Makefile b/devel/pinba_engine/Makefile
new file mode 100644
index 000000000000..d2156dcd2da8
--- /dev/null
+++ b/devel/pinba_engine/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: pinba_engine
+# Date created: 24 Dec 2009
+# Whom: raven428 <raven428@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pinba_engine
+PORTVERSION= 2009.12.24
+CATEGORIES= devel
+MASTER_SITES= http://aston2.com/~raven/unix/pinba/ \
+ http://mks-chel.ru/~raven/FreeBSD/pinba/
+DISTNAME= pinba_engine-200912240755
+
+MAINTAINER= raven428@gmail.com
+COMMENT= Mysql-engine part of statistics server for PHP
+
+BUILD_DEPENDS= ${LOCALBASE}/include/google/protobuf/descriptor.h:${PORTSDIR}/devel/protobuf \
+ ${LOCALBASE}/include/event.h:${PORTSDIR}/devel/libevent \
+ ${LOCALBASE}/include/Judy.h:${PORTSDIR}/devel/judy \
+ ${LOCALBASE}/lib/mysql/plugin:${MYSQL_PORTDIR} \
+ ${NONEXISTENT}:${MYSQL_PORTDIR}:configure
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_MYSQL= yes
+WANT_MYSQL_VER= 51
+MYSQL_PORTDIR= ${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+MYSQL_WRKSRC= $$(cd ${MYSQL_PORTDIR} && ${MAKE} -V WRKSRC)
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= \
+ --with-mysql=${MYSQL_WRKSRC} \
+ --libdir=${PREFIX}/lib/mysql/plugin
+CFLAGS+= -I${LOCALBASE}/include/mysql
+USE_LDCONFIG= ${PREFIX}/lib/mysql/plugin
+
+SUB_FILES= pkg-message
+.if !defined(NOPORTDOCS)
+PORTDOCS= NEWS TODO README
+.endif
+
+post-install:
+.if !defined(NOPORTDATA)
+ @${MKDIR} ${DATADIR}
+ @${INSTALL} ${WRKSRC}/default_tables.sql ${DATADIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${DOCSDIR}
+.endif
+ @${CAT} ${WRKDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/devel/pinba_engine/distinfo b/devel/pinba_engine/distinfo
new file mode 100644
index 000000000000..b523f37b7276
--- /dev/null
+++ b/devel/pinba_engine/distinfo
@@ -0,0 +1,3 @@
+MD5 (pinba_engine-200912240755.tar.gz) = 92aa2f0d67f84cd9fb89dc6752a8a4b5
+SHA256 (pinba_engine-200912240755.tar.gz) = 5822a7859e86e24796531a002aa3e866e98a83e6fdf7726356dd5f8ab311f082
+SIZE (pinba_engine-200912240755.tar.gz) = 607588
diff --git a/devel/pinba_engine/files/patch-src__ha_pinba.cc b/devel/pinba_engine/files/patch-src__ha_pinba.cc
new file mode 100644
index 000000000000..dc4e0e7be1dc
--- /dev/null
+++ b/devel/pinba_engine/files/patch-src__ha_pinba.cc
@@ -0,0 +1,10 @@
+--- ./src/ha_pinba.cc.orig 2009-12-23 23:55:04.000000000 -0500
++++ ./src/ha_pinba.cc 2010-01-07 16:22:50.000000000 -0500
+@@ -283,6 +283,7 @@
+ int error = 0;
+ DBUG_ENTER("pinba_engine_shutdown");
+
++ pthread_detach(collector_thread);
+ pthread_cancel(collector_thread);
+ pthread_join(collector_thread, NULL);
+
diff --git a/devel/pinba_engine/files/pkg-message.in b/devel/pinba_engine/files/pkg-message.in
new file mode 100644
index 000000000000..68c08b9bb1f7
--- /dev/null
+++ b/devel/pinba_engine/files/pkg-message.in
@@ -0,0 +1,10 @@
+After you've installed the plugin, you need to enable it in MySQL.
+To do this log in to the MySQL console (as root) and execute the
+following:
+mysql> INSTALL PLUGIN pinba SONAME 'libpinba_engine.so';
+
+We'd also suggest you to create a separate database, this way:
+mysql> CREATE DATABASE pinba;
+
+And then create the default tables:
+mysql -D pinba < %%DATADIR%%/default_tables.sql
diff --git a/devel/pinba_engine/pkg-descr b/devel/pinba_engine/pkg-descr
new file mode 100644
index 000000000000..d1afbff0b137
--- /dev/null
+++ b/devel/pinba_engine/pkg-descr
@@ -0,0 +1,19 @@
+Pinba is a statistics server for PHP using MySQL as a read-only
+interface.
+
+It accumulates and processes data sent over UDP by multiple PHP
+processes and displays statistics in a nice human-readable form of
+simple "reports", also providing a read-only interface to the raw
+data to enable generation of more sophisticated reports.
+
+With the Pinba extension, users can also measure particular parts
+of the code using timers with arbitrary tags.
+
+Pinba is not a debugging tool in the common sense, since you're not
+supposed to do debugging on production servers, but its main goal
+is to help developers to locate bottlenecks in realtime and direct
+their attention to the code that really needs it.
+
+WWW: http://pinba.org/
+
+- raven428 raven428@gmail.com
diff --git a/devel/pinba_engine/pkg-plist b/devel/pinba_engine/pkg-plist
new file mode 100644
index 000000000000..28c28a03ee58
--- /dev/null
+++ b/devel/pinba_engine/pkg-plist
@@ -0,0 +1,6 @@
+lib/mysql/plugin/libpinba_engine.so
+lib/mysql/plugin/libpinba_engine.so.0
+lib/mysql/plugin/libpinba_engine.la
+lib/mysql/plugin/libpinba_engine.a
+%%PORTDATA%%%%DATADIR%%/default_tables.sql
+%%PORTDATA%%@dirrm %%DATADIR%%