aboutsummaryrefslogtreecommitdiff
path: root/devel/plan9port
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
commit42542fb07642b8336e808272918f3ae46aa67e0b (patch)
tree98ff235c33c6493aa26457284f122652c38935f7 /devel/plan9port
parent4c9cd257fd4e6eca46807a43e128d298429ee3cd (diff)
downloadports-42542fb07642b8336e808272918f3ae46aa67e0b.tar.gz
ports-42542fb07642b8336e808272918f3ae46aa67e0b.zip
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=197075
Diffstat (limited to 'devel/plan9port')
-rw-r--r--devel/plan9port/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 2a22853f4ab3..ce9589496339 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -24,7 +24,7 @@ SUB_FILES= pkg-message
REINPLACE_ARGS= -i ""
ONLY_FOR_ARCHS= i386
-PLAN9= ${TARGETDIR}/plan9
+PLAN9= ${PREFIX}/plan9
MANPREFIX= ${PLAN9}
MAN1= 9term.1 acmeevent.1 ascii.1 acme.1 9p.1 basename.1 cal.1 \
@@ -109,14 +109,14 @@ post-build:
${FIND} plan9 -type f \
-a ! -path "plan9/man/man[0-9]/*.[0-9]*"; \
for D in ${EMPTY_DIRS}; do \
- ${ECHO_CMD} "@exec ${MKDIR} ${TARGETDIR}/$${D}"; \
+ ${ECHO_CMD} "@exec ${MKDIR} ${PREFIX}/$${D}"; \
done; \
${FIND} plan9 -type d | ${SORT} -r \
| ${SED} -e 's|^|@dirrm |'; \
) > ${PLIST}
do-install:
- ${CP} -rp ${WRKSRC} ${TARGETDIR}
+ ${CP} -rp ${WRKSRC} ${PREFIX}
post-install:
cd ${PLAN9} && \