aboutsummaryrefslogtreecommitdiff
path: root/devel/pmake
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-11-15 22:54:25 +0000
committerSteve Price <steve@FreeBSD.org>1998-11-15 22:54:25 +0000
commit901fb78c07a3a4bc36c40fcad8ddfd414d1ef3df (patch)
treebaa8433b3e090f28b3a0c1eaa5e7131f645ac1b5 /devel/pmake
parented8c024b4618b97a6731b58c3fb4156eb866ac67 (diff)
downloadports-901fb78c07a3a4bc36c40fcad8ddfd414d1ef3df.tar.gz
ports-901fb78c07a3a4bc36c40fcad8ddfd414d1ef3df.zip
Initial import of pmake version 2.1.33.
A parallel make(1) from the Sprite OS project. Reviewed by: asami
Notes
Notes: svn path=/head/; revision=14545
Diffstat (limited to 'devel/pmake')
-rw-r--r--devel/pmake/Makefile51
-rw-r--r--devel/pmake/distinfo1
-rw-r--r--devel/pmake/files/patch-aa13
-rw-r--r--devel/pmake/files/patch-ab11
-rw-r--r--devel/pmake/files/patch-ac74
-rw-r--r--devel/pmake/files/patch-ad13
-rw-r--r--devel/pmake/files/patch-ae11
-rw-r--r--devel/pmake/files/patch-af23
-rw-r--r--devel/pmake/files/patch-ag8
-rw-r--r--devel/pmake/files/patch-ah18
-rw-r--r--devel/pmake/pkg-comment1
-rw-r--r--devel/pmake/pkg-descr7
-rw-r--r--devel/pmake/pkg-plist27
-rw-r--r--devel/pmake/pkg-plist.customs45
14 files changed, 303 insertions, 0 deletions
diff --git a/devel/pmake/Makefile b/devel/pmake/Makefile
new file mode 100644
index 000000000000..9c6b745349ee
--- /dev/null
+++ b/devel/pmake/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: pmake
+# Version required: 2.1.33
+# Date created: 12 November 1998
+# Whom: steve
+#
+# $Id$
+#
+
+DISTNAME= pmake-2.1.33
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.icsi.berkeley.edu/pub/ai/stolcke/software/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= steve@freebsd.org
+
+RESTRICTED= "Non-commercial use only"
+
+WRKSRC= ${WRKDIR}/pmake
+MAKEFILE= makefile
+ALL_TARGET= pmake
+PMAKE_ENV= ${MAKE_ENV} MAKE=${PREFIX}/bin/pmake
+MAN1= pmake.1
+
+#
+# Define this if you want to build and install with the 'customs'
+# server support and the pmake to match. Note, you'll still get
+# the plain pmake in ${PREFIX}/bin/pmake.nocustoms.
+#
+#WANT_CUSTOMS= yes
+
+do-install::
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} install)
+
+.if defined(WANT_CUSTOMS)
+PLIST= ${PKGDIR}/PLIST.customs
+MAN1+= export.1 reginfo.1 rexport.1
+MAN8= cctrl.8 customs.8 importquota.8 logd.8
+
+do-install::
+ @(cd ${WRKSRC}; ${SETENV} ${PMAKE_ENV} ${PREFIX}/bin/pmake new; \
+ ${SETENV} ${PMAKE_ENV} ${PREFIX}/bin/pmake install)
+ @${ECHO} "Adding customs service to /etc/services..."
+ @${ECHO} -e 'customs\t\t8231/tcp\t# pmake customs server'>>/etc/services
+ @${ECHO} -e 'customs\t\t8231/udp\t# pmake customs server'>>/etc/services
+.else
+do-install::
+ @(cd ${WRKSRC}/doc; ${SETENV} ${PMAKE_ENV} ${PREFIX}/bin/pmake)
+ ${INSTALL_MAN} ${WRKSRC}/doc/pmake.1 ${PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/pmake/distinfo b/devel/pmake/distinfo
new file mode 100644
index 000000000000..ad5b7ab4a9f3
--- /dev/null
+++ b/devel/pmake/distinfo
@@ -0,0 +1 @@
+MD5 (pmake-2.1.33.tar.Z) = 330e17d66c8b2a299074aa740699a4f3
diff --git a/devel/pmake/files/patch-aa b/devel/pmake/files/patch-aa
new file mode 100644
index 000000000000..e54bb2a72fac
--- /dev/null
+++ b/devel/pmake/files/patch-aa
@@ -0,0 +1,13 @@
+--- makefile.orig Thu Nov 12 10:59:34 1998
++++ makefile Thu Nov 12 11:01:51 1998
+@@ -21,8 +21,8 @@
+ # LSTDIR location of linked-list library
+ #
+ DESTDIR =
+-BINDIR = /usr/local/bin
+-LIBDIR = /usr/local/lib/pmake
++BINDIR = $(PREFIX)/bin
++LIBDIR = $(PREFIX)/lib/pmake
+ SYSTEM_MK = system.mk
+
+ LIBSRC = lib
diff --git a/devel/pmake/files/patch-ab b/devel/pmake/files/patch-ab
new file mode 100644
index 000000000000..687380ba60aa
--- /dev/null
+++ b/devel/pmake/files/patch-ab
@@ -0,0 +1,11 @@
+--- lib/sprite/strsignal.c.orig Thu Nov 12 10:47:48 1998
++++ lib/sprite/strsignal.c Thu Nov 12 10:48:36 1998
+@@ -23,7 +23,7 @@
+
+ #ifndef _sys_siglist /* SVR4 has strsignal() */
+
+-#ifndef hpux
++#if !defined(hpux) && !defined(__FreeBSD__)
+ extern char *sys_siglist[];
+ #endif /* hpux */
+
diff --git a/devel/pmake/files/patch-ac b/devel/pmake/files/patch-ac
new file mode 100644
index 000000000000..ca6672825fb5
--- /dev/null
+++ b/devel/pmake/files/patch-ac
@@ -0,0 +1,74 @@
+--- lib/mk/system.mk.orig Thu Nov 12 14:33:01 1998
++++ lib/mk/system.mk Thu Nov 12 14:56:51 1998
+@@ -20,9 +20,9 @@
+ .EXPORT: SAME
+ #endif .MACHINE
+
+-#ifdef .MACHINE
+-#include <sys-$(.MACHINE:S@/@-@g).mk>
+-#endif
++##ifdef .MACHINE
++##include <sys-$(.MACHINE:S@/@-@g).mk>
++##endif
+
+
+ .SUFFIXES : .out .a .ln .o .c .cc .F .f .e .r .y .l .s .cl .p .h .i \
+@@ -45,39 +45,40 @@
+
+ # Use absolute paths whenever possible. This greatly reduces server load
+ # once pmake has created parallel jobs all over the network ...
+-YACC ?= /usr/bin/yacc
+-YFLAGS ?=
+-LEX ?= /usr/bin/lex
++YACC ?= yacc
++YFLAGS ?= -d
++LEX ?= lex
+ LFLAGS ?=
+-CC ?= /bin/cc
+-CXX ?= CC
+-RM ?= /bin/rm -f
+-MV ?= /bin/mv
+-AS ?= /bin/as
+-PC ?= /usr/ucb/pc
++CC ?= cc
++CXX ?= c++
++RM ?= rm -f
++MV ?= mv
++AS ?= as
++PC ?= pc
+ PFLAGS ?=
+-CFLAGS ?=
+-CXXFLAGS?=
++CFLAGS ?= -O -pipe
++CXXFLAGS?= $(CFLAGS)
+ AFLAGS ?=
+-RC ?= /usr/bin/f77
++RC ?= f77
+ RFLAGS ?=
+-FC ?= /usr/bin/f77
++FC ?= f77
+ EFLAGS ?=
+-FFLAGS ?=
++FFLAGS ?= -O
+ LOADLIBES ?=
+ CO ?= co
+ COFLAGS ?=
+ CI ?= ci
+ CIFLAGS ?=
+-AR ?= /bin/ar
+-ARFLAGS ?= r
++AR ?= ar
++ARFLAGS ?= -rv
+ #ifdef SYSV
+ RANLIB ?= /bin/true
+ #else
+ RANLIB ?= ranlib
+ #endif
+-LD ?= /bin/ld
+-LINT ?= /usr/bin/lint
++LD ?= ld
++LINT ?= lint
++LINTFLAGS ?= -chapbx
+ MKDEP ?= makedepend
+
+ .c,v.c .y,v.y .l,v.l .s,v.s .h,v.h :
diff --git a/devel/pmake/files/patch-ad b/devel/pmake/files/patch-ad
new file mode 100644
index 000000000000..21f90d174a51
--- /dev/null
+++ b/devel/pmake/files/patch-ad
@@ -0,0 +1,13 @@
+--- common.mk.orig Thu Nov 12 15:49:34 1998
++++ common.mk Thu Nov 12 15:50:31 1998
+@@ -30,8 +30,8 @@
+ # INCLUDE where the sprite include files are
+ #
+ DESTDIR =
+-BINDIR = /usr/local/bin
+-LIBDIR = /usr/local/lib/pmake
++BINDIR = $(PREFIX)/bin
++LIBDIR = $(PREFIX)/lib/pmake
+ SYSTEM_MK = system.mk
+
+ #
diff --git a/devel/pmake/files/patch-ae b/devel/pmake/files/patch-ae
new file mode 100644
index 000000000000..4b4918a3c5bf
--- /dev/null
+++ b/devel/pmake/files/patch-ae
@@ -0,0 +1,11 @@
+--- doc/Makefile.orig Thu Nov 12 17:51:30 1998
++++ doc/Makefile Thu Nov 12 17:54:24 1998
+@@ -19,7 +19,7 @@
+ # most of the stuff here is machine independent
+ .EXPORT:
+
+-MANDIR = /usr/local/man
++MANDIR = $(PREFIX)/man
+ MANEXT1 = 1
+ MANEXT8 = 8
+
diff --git a/devel/pmake/files/patch-af b/devel/pmake/files/patch-af
new file mode 100644
index 000000000000..b8427c754a64
--- /dev/null
+++ b/devel/pmake/files/patch-af
@@ -0,0 +1,23 @@
+--- customs/Makefile.orig Thu Nov 12 16:41:07 1998
++++ customs/Makefile Thu Nov 12 16:42:14 1998
+@@ -19,16 +19,16 @@
+ #
+ # Owner of the various binaries
+ #
+-OWNER = $$USER
++OWNER = root
+
+ #
+ # ETCDIR is where the system-control clients and the daemon itself go.
+ # USRLIBDIR is where the customs library (archive) goes.
+ # INCLUDEDIR is where the header files belonging to the customs library go.
+ #
+-ETCDIR = /usr/local/etc
+-USRLIBDIR = /usr/local/lib
+-INCLUDEDIR = /usr/local/include/customs
++ETCDIR = $(PREFIX)/etc
++USRLIBDIR = $(PREFIX)/lib
++INCLUDEDIR = $(PREFIX)/include/customs
+
+ #
+ # Strip installed binaries
diff --git a/devel/pmake/files/patch-ag b/devel/pmake/files/patch-ag
new file mode 100644
index 000000000000..2a7ce00df058
--- /dev/null
+++ b/devel/pmake/files/patch-ag
@@ -0,0 +1,8 @@
+--- customs/sigList.c.orig Thu Nov 12 16:43:25 1998
++++ customs/sigList.c Thu Nov 12 16:43:54 1998
+@@ -20,4 +20,5 @@
+ #endif /* not lint */
+
++#include <sys/types.h>
+ #include <sys/signal.h>
+
diff --git a/devel/pmake/files/patch-ah b/devel/pmake/files/patch-ah
new file mode 100644
index 000000000000..b291985ddd61
--- /dev/null
+++ b/devel/pmake/files/patch-ah
@@ -0,0 +1,18 @@
+--- customs/os-bsd.c.orig Thu Nov 12 16:45:42 1998
++++ customs/os-bsd.c Thu Nov 12 16:47:14 1998
+@@ -162,6 +162,15 @@
+ # define NO_SWAP /* doesn't have old BSD kernel structures */
+ #endif /* bsdi */
+
++#ifdef __FreeBSD__
++# define KERNEL_FILE "/kernel"
++# define NLIST_AVENRUN "_averunnable"
++# define NLIST_NPROC "_maxproc"
++# define NLIST_NPROCS "_nprocs"
++# define UTMP_FILE "/var/run/utmp"
++# define NO_SWAP /* doesn't have old BSD kernel structures */
++#endif /* __FreeBSD__ */
++
+ /* defaults for most BSD systems */
+ #ifndef n_symbol
+ # define n_symbol n_name
diff --git a/devel/pmake/pkg-comment b/devel/pmake/pkg-comment
new file mode 100644
index 000000000000..23ebe351f209
--- /dev/null
+++ b/devel/pmake/pkg-comment
@@ -0,0 +1 @@
+The parallel make(1) program from the Sprite project.
diff --git a/devel/pmake/pkg-descr b/devel/pmake/pkg-descr
new file mode 100644
index 000000000000..ed8999c3beb6
--- /dev/null
+++ b/devel/pmake/pkg-descr
@@ -0,0 +1,7 @@
+This is the parallel make(1) program originally developed for the Sprite
+operating system. You can also build this port with support for the
+'customs' service. Customs is a load-balancing system designed for a
+local area network of cooperating workstations.
+
+NOTE: this software's copyright restricts its use to non-commercial
+applications only.
diff --git a/devel/pmake/pkg-plist b/devel/pmake/pkg-plist
new file mode 100644
index 000000000000..4b7b2d557164
--- /dev/null
+++ b/devel/pmake/pkg-plist
@@ -0,0 +1,27 @@
+bin/pmake
+bin/vmake
+lib/pmake/linksprite.mk
+lib/pmake/makedepend.mk
+lib/pmake/makelib.mk
+lib/pmake/makelint.mk
+lib/pmake/po.mk
+lib/pmake/shx.mk
+lib/pmake/sys-9000-720.mk
+lib/pmake/sys-9000-730.mk
+lib/pmake/sys-IP19.mk
+lib/pmake/sys-IP20.mk
+lib/pmake/sys-IP22.mk
+lib/pmake/sys-IP25.mk
+lib/pmake/sys-IP7.mk
+lib/pmake/sys-alpha.mk
+lib/pmake/sys-i386.mk
+lib/pmake/sys-i686.mk
+lib/pmake/sys-i86pc.mk
+lib/pmake/sys-iris.mk
+lib/pmake/sys-mips.mk
+lib/pmake/sys-next.mk
+lib/pmake/sys-snake.mk
+lib/pmake/sys-sun3.mk
+lib/pmake/sys-sun4.mk
+lib/pmake/system.mk
+@dirrm lib/pmake
diff --git a/devel/pmake/pkg-plist.customs b/devel/pmake/pkg-plist.customs
new file mode 100644
index 000000000000..1adb7f1cdf99
--- /dev/null
+++ b/devel/pmake/pkg-plist.customs
@@ -0,0 +1,45 @@
+bin/export
+bin/pmake
+bin/pmake.nocustoms
+bin/reginfo
+bin/rexport
+bin/vmake
+etc/cctrl
+etc/customs
+etc/importquota
+etc/logd
+include/customs/customs.h
+include/customs/rpc.h
+include/customs/lst.h
+include/customs/sprite.h
+include/customs/config.h
+lib/libcustoms.a
+lib/pmake/linksprite.mk
+lib/pmake/makedepend.mk
+lib/pmake/makelib.mk
+lib/pmake/makelint.mk
+lib/pmake/po.mk
+lib/pmake/shx.mk
+lib/pmake/sys-9000-720.mk
+lib/pmake/sys-9000-730.mk
+lib/pmake/sys-IP19.mk
+lib/pmake/sys-IP20.mk
+lib/pmake/sys-IP22.mk
+lib/pmake/sys-IP25.mk
+lib/pmake/sys-IP7.mk
+lib/pmake/sys-alpha.mk
+lib/pmake/sys-i386.mk
+lib/pmake/sys-i686.mk
+lib/pmake/sys-i86pc.mk
+lib/pmake/sys-iris.mk
+lib/pmake/sys-mips.mk
+lib/pmake/sys-next.mk
+lib/pmake/sys-snake.mk
+lib/pmake/sys-sun3.mk
+lib/pmake/sys-sun4.mk
+lib/pmake/system.mk
+@dirrm include/customs
+@dirrm lib/pmake
+@exec echo -e 'customs\t\t8231/tcp\t# pmake customs server'>>/etc/services
+@exec echo -e 'customs\t\t8231/udp\t# pmake customs server'>>/etc/services
+@unexec perl -pi.bak -e '/^customs/ && ($_="")' /etc/services