aboutsummaryrefslogtreecommitdiff
path: root/devel/popt
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-30 12:31:24 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-30 12:31:24 +0000
commit281777db42bdcdd69aba1f62656b96da5491222f (patch)
tree936fc8a152c95a7d50534b9d6baf1c568dd00fb0 /devel/popt
parent08e2ce737b4e8af2862add7db6af81ff4e3cf1eb (diff)
downloadports-281777db42bdcdd69aba1f62656b96da5491222f.tar.gz
ports-281777db42bdcdd69aba1f62656b96da5491222f.zip
popt is an enhanced getopt(3)-style command line option parsing library.
PR: 15759 Submitted by: Yuan-Chen Cheng <ycheng@ml.tw.freebsd.org>
Notes
Notes: svn path=/head/; revision=24287
Diffstat (limited to 'devel/popt')
-rw-r--r--devel/popt/Makefile32
-rw-r--r--devel/popt/distinfo1
-rw-r--r--devel/popt/pkg-comment1
-rw-r--r--devel/popt/pkg-descr11
-rw-r--r--devel/popt/pkg-plist5
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
new file mode 100644
index 000000000000..d69bee600f09
--- /dev/null
+++ b/devel/popt/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: popt
+# Version required: 1.4
+# Date Created: 29 Dec 1999
+# Whom: Yuan-Chen Cheng <ycheng@sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+DISTNAME= popt-1.4
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.redhat.com/pub/redhat/current/SRPMS/SRPMS/ \
+ ftp://ftp.cdrom.com/pub/linux/redhat/current/SRPMS/SRPMS/
+EXTRACT_SUFX= -1.src.rpm
+
+MAINTAINER= ycheng@sinica.edu.tw
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/rpm2cpio:${PORTSDIR}/misc/rpm
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN3= popt.3
+MANCOMPRESSED= no
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${LOCALBASE}/bin/rpm2cpio ${_DISTDIR}${DISTFILES} | (cd ${WRKDIR}; cpio -i)
+ @tar -xzf ${WRKDIR}/${DISTNAME}.tar.gz -C ${WRKDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/popt/distinfo b/devel/popt/distinfo
new file mode 100644
index 000000000000..4f1daf5c71e1
--- /dev/null
+++ b/devel/popt/distinfo
@@ -0,0 +1 @@
+MD5 (popt-1.4-1.src.rpm) = a4a87c369b0d7aa7cfa5ee575efeccfd
diff --git a/devel/popt/pkg-comment b/devel/popt/pkg-comment
new file mode 100644
index 000000000000..8713d3418113
--- /dev/null
+++ b/devel/popt/pkg-comment
@@ -0,0 +1 @@
+A getopt(3) like library with a number of enhancements, from Redhat.
diff --git a/devel/popt/pkg-descr b/devel/popt/pkg-descr
new file mode 100644
index 000000000000..6571ae2d9746
--- /dev/null
+++ b/devel/popt/pkg-descr
@@ -0,0 +1,11 @@
+Quoted from README file:
+
+This is the popt command line option parsing library. While it is similiar
+to getopt(3), it contains a number of enhancements, including:
+
+ 1) popt is fully reentrant
+ 2) popt can parse arbitrary argv[] style arrays while
+ getopt(2) makes this quite difficult
+ 3) popt allows users to alias command line arguments
+ 4) popt provides convience functions for parsing strings
+ into argv[] style arrays
diff --git a/devel/popt/pkg-plist b/devel/popt/pkg-plist
new file mode 100644
index 000000000000..ada5b6a3852e
--- /dev/null
+++ b/devel/popt/pkg-plist
@@ -0,0 +1,5 @@
+share/locale/sk/LC_MESSAGES/popt.mo
+share/locale/ro/LC_MESSAGES/popt.mo
+lib/libpopt.la
+lib/libpopt.a
+include/popt.h