aboutsummaryrefslogtreecommitdiff
path: root/devel/pth
diff options
context:
space:
mode:
authorAlfred Perlstein <alfred@FreeBSD.org>2005-06-15 21:03:03 +0000
committerAlfred Perlstein <alfred@FreeBSD.org>2005-06-15 21:03:03 +0000
commit8aef8486ecfda2fd7633a25036fad8c72b9997b5 (patch)
tree833cedba1262c687b5d5236749b12d43834077b0 /devel/pth
parent4c4e020d3640fd8d984db78120bad78a2e714de9 (diff)
downloadports-8aef8486ecfda2fd7633a25036fad8c72b9997b5.tar.gz
ports-8aef8486ecfda2fd7633a25036fad8c72b9997b5.zip
support toggling of HARD/SOFT syscalls.
Notes
Notes: svn path=/head/; revision=137507
Diffstat (limited to 'devel/pth')
-rw-r--r--devel/pth/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index ecd1fe6bf4b8..3f9ff91eef7e 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -19,17 +19,22 @@ LDCONFIG_DIRS= %%PREFIX%%/lib/pth
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-pthread \
- --enable-syscall-soft \
--enable-optimize \
--enable-batch \
--includedir="${PREFIX}/include/pth" \
--libdir="${PREFIX}/lib/pth"
+
+.if !defined(WITH_SYSCALL_HARD)
+CONFIGURE_ARGS+= --enable-syscall-soft
+.endif
+
USE_REINPLACE= yes
MAN1= pth-config.1 pthread-config.1
MAN3= pth.3 pthread.3
-OPTIONS= OPTIMIZED_CFLAGS "Build with optimized CFLAGS" on
+OPTIONS= OPTIMIZED_CFLAGS "Build with optimized CFLAGS" on \
+ SYSCALL_HARD "Build with hard syscalls" off
.include <bsd.port.pre.mk>