aboutsummaryrefslogtreecommitdiff
path: root/devel/pth
diff options
context:
space:
mode:
authorAlfred Perlstein <alfred@FreeBSD.org>2005-06-17 19:01:30 +0000
committerAlfred Perlstein <alfred@FreeBSD.org>2005-06-17 19:01:30 +0000
commitbbdc6fa005a63092afcea1d21f68b027d7e07faa (patch)
treeeb920bbf71ea8a32d772046bbbc862489aaf31c7 /devel/pth
parent6ead93ac151c886fd3664245758deb96ce26b59c (diff)
downloadports-bbdc6fa005a63092afcea1d21f68b027d7e07faa.tar.gz
ports-bbdc6fa005a63092afcea1d21f68b027d7e07faa.zip
Explicitly disable "soft syscalls" when compiling WITH_HARD_SYSCALLS.
Notes
Notes: svn path=/head/; revision=137649
Diffstat (limited to 'devel/pth')
-rw-r--r--devel/pth/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 3f9ff91eef7e..57be18f0b07d 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -18,16 +18,11 @@ INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/pth
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-pthread \
- --enable-optimize \
+CONFIGURE_ARGS= --enable-optimize \
--enable-batch \
--includedir="${PREFIX}/include/pth" \
--libdir="${PREFIX}/lib/pth"
-.if !defined(WITH_SYSCALL_HARD)
-CONFIGURE_ARGS+= --enable-syscall-soft
-.endif
-
USE_REINPLACE= yes
MAN1= pth-config.1 pthread-config.1
@@ -36,8 +31,25 @@ MAN3= pth.3 pthread.3
OPTIONS= OPTIMIZED_CFLAGS "Build with optimized CFLAGS" on \
SYSCALL_HARD "Build with hard syscalls" off
+
+#OPTIONS+= SYSCALL_SOFT_DISABLED "Disable soft syscalls" off \
+# SYSCALL_SOFT "Disable soft syscalls" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_SYSCALL_HARD)
+CONFIGURE_ARGS+= --enable-syscall-hard --disable-syscall-soft
+.else
+CONFIGURE_ARGS+= --enable-syscall-soft
+CONFIGURE_ARGS+= --enable-pthread
+.endif
+
+#.if defined(WITH_SYSCALL_SOFT_DISABLED)
+#CONFIGURE_ARGS+= --disable-syscall-soft
+#.else
+#CONFIGURE_ARGS+= --enable-syscall-soft
+#.endif
+
post-patch:
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e \