aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib152/Makefile
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2003-08-28 07:58:51 +0000
committerRoger Hardiman <roger@FreeBSD.org>2003-08-28 07:58:51 +0000
commit72e610aa055f0036b7c55b04ad90e58b9ce081c5 (patch)
tree24271c29f3165dff0a592b07d88697becc57c500 /devel/pwlib152/Makefile
parent6dfae884310305643d29351bd388825b7c7f3c64 (diff)
downloadports-72e610aa055f0036b7c55b04ad90e58b9ce081c5.tar.gz
ports-72e610aa055f0036b7c55b04ad90e58b9ce081c5.zip
Add PWlib 1.5.0, a cross platform C++ library which is used by OpenH323.
Notes
Notes: svn path=/head/; revision=87860
Diffstat (limited to 'devel/pwlib152/Makefile')
-rw-r--r--devel/pwlib152/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/pwlib152/Makefile b/devel/pwlib152/Makefile
new file mode 100644
index 000000000000..aae17c1f7484
--- /dev/null
+++ b/devel/pwlib152/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pwlib
+# Date created: Fri Aug 22 07:11:44 GMT 2003
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pwlib
+PORTVERSION= 1.5.0
+CATEGORIES= devel
+MASTER_SITES= http://www.openh323.org/bin/ \
+ http://www.de.openh323.org/bin/ \
+ http://www.gnomemeeting.org/downloads/0.98.0/sources/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= roger@freebsd.org
+COMMENT= A cross platform C++ library, used by OpenH323
+
+LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BISON= yes
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+ALL_TARGET= optnoshared
+MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+# ${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
+
+.include <bsd.port.mk>