aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib152
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-01-31 20:56:24 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-01-31 20:56:24 +0000
commit8a5a741bf84c945f41d99e46611c5ea273b7e990 (patch)
tree5d8c183f0a2f6922a14493ce22a584e7615be990 /devel/pwlib152
parentbd61a52c3af9fc39dd4afaa5d5ea12bc0d0e10fe (diff)
downloadports-8a5a741bf84c945f41d99e46611c5ea273b7e990.tar.gz
ports-8a5a741bf84c945f41d99e46611c5ea273b7e990.zip
After repocopy from devel/pwlib:
- fix PORTNAME - remove PORTEPOCH - "chase" expat libversion bump (marcus won the race ;-) ) - use current autoconf (259) [1] - add patch to play nice (in preparation for the update of devel/pwlib) [1] PR: 83396 (parts of) [1] Submitted by: Steve Ames <steve@energistic.com> [1] Repocopy by: marcus
Notes
Notes: svn path=/head/; revision=154924
Diffstat (limited to 'devel/pwlib152')
-rw-r--r--devel/pwlib152/Makefile12
-rw-r--r--devel/pwlib152/files/patch-make-ptbuildopts.mak.in14
2 files changed, 20 insertions, 6 deletions
diff --git a/devel/pwlib152/Makefile b/devel/pwlib152/Makefile
index f9bee15d41c6..d8bb3569a939 100644
--- a/devel/pwlib152/Makefile
+++ b/devel/pwlib152/Makefile
@@ -5,26 +5,26 @@
# $FreeBSD$
#
-PORTNAME= pwlib
+PORTNAME= pwlib152
PORTVERSION= 1.5.2
-PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
http://www.gnomemeeting.org/downloads/0.98.0/sources/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= ${NAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A cross platform C++ library, used by OpenH323
-LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${NAME}
+NAME= pwlib
USE_BISON= yes
USE_GMAKE= yes
USE_OPENLDAP= yes
-USE_AUTOTOOLS= autoconf:253
+USE_AUTOTOOLS= autoconf:259
CONFIGURE_ENV= OSRELEASE=${OSVERSION}
ALL_TARGET= optnoshared
MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib
diff --git a/devel/pwlib152/files/patch-make-ptbuildopts.mak.in b/devel/pwlib152/files/patch-make-ptbuildopts.mak.in
new file mode 100644
index 000000000000..0091a706d0c8
--- /dev/null
+++ b/devel/pwlib152/files/patch-make-ptbuildopts.mak.in
@@ -0,0 +1,14 @@
+--- make/ptbuildopts.mak.in.orig Thu Jul 7 14:17:24 2005
++++ make/ptbuildopts.mak.in Thu Jul 7 14:15:47 2005
+@@ -9,6 +9,11 @@
+ OSTYPE = @OSTYPE@
+ OSRELEASE = @OSRELEASE@
+
++# This line makes this port of pwlib play well with others... otherwise
++# /usr/local/include gets inserted first and causes the inclusion of
++# files from different versions of pwlib
++STDCCFLAGS += -I@PWLIBDIR@/include/ptlib/unix -I@PWLIBDIR@/include
++
+ STDCCFLAGS += @STDCCFLAGS@
+ OPTSTDCCFLAGS += @OPTSTDCCFLAGS@
+ LDFLAGS += @LDFLAGS@