aboutsummaryrefslogtreecommitdiff
path: root/devel/py-Breve
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-02-16 08:59:16 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-02-16 08:59:16 +0000
commit573b551297f5e84d7e45904fdb10dc019bc32215 (patch)
tree328982d0935a1c0d4b6faf4457c5d9de7f7a852e /devel/py-Breve
parent67c1c8ae7f9094ea0f9e79b49db8b61eb49412b8 (diff)
downloadports-573b551297f5e84d7e45904fdb10dc019bc32215.tar.gz
ports-573b551297f5e84d7e45904fdb10dc019bc32215.zip
Breve is a Python template engine that is designed to be clean and
elegant with minimal syntax. Unlike most Python template engines, Breve is implemented as an `internal DSL`_ rather than a parser. Author: Cliff Wells WWW: http://breve.twisty-industries.com/
Notes
Notes: svn path=/head/; revision=185294
Diffstat (limited to 'devel/py-Breve')
-rw-r--r--devel/py-Breve/Makefile36
-rw-r--r--devel/py-Breve/distinfo3
-rw-r--r--devel/py-Breve/pkg-descr6
-rw-r--r--devel/py-Breve/pkg-plist4
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/py-Breve/Makefile b/devel/py-Breve/Makefile
new file mode 100644
index 000000000000..72474efd169a
--- /dev/null
+++ b/devel/py-Breve/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: py-breve
+# Date created: 2007-02-14
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Breve
+PORTVERSION= 1.0.35
+CATEGORIES= devel python
+MASTER_SITES= http://breve.twisty-industries.com/downloads/ \
+ LOCAL/nivit
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A Python s-expression style template engine
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_BUILD_TARGET= bdist_egg
+PYDISTUTILS_INSTALL_TARGET= easy_install
+PYDISTUTILS_INSTALLARGS= -N -s ${PREFIX}/bin -S ${PYTHON_SITELIBDIR} dist/${PYBREVE_EGG}
+
+PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
+ PYBREVE_EGG=${PYBREVE_EGG}
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+PYBREVE_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>
diff --git a/devel/py-Breve/distinfo b/devel/py-Breve/distinfo
new file mode 100644
index 000000000000..b4b25bb43c65
--- /dev/null
+++ b/devel/py-Breve/distinfo
@@ -0,0 +1,3 @@
+MD5 (Breve-1.0.35.tar.gz) = 76b08573da4c371bc3cbebce968e822b
+SHA256 (Breve-1.0.35.tar.gz) = 1e76154dde1387b1f10fe012969fcd91d8f32d08d0d465f1a64fde672ec1e3ea
+SIZE (Breve-1.0.35.tar.gz) = 25714
diff --git a/devel/py-Breve/pkg-descr b/devel/py-Breve/pkg-descr
new file mode 100644
index 000000000000..9226a2f95ead
--- /dev/null
+++ b/devel/py-Breve/pkg-descr
@@ -0,0 +1,6 @@
+Breve is a Python template engine that is designed to be clean and
+elegant with minimal syntax. Unlike most Python template engines,
+Breve is implemented as an `internal DSL`_ rather than a parser.
+
+Author: Cliff Wells
+WWW: http://breve.twisty-industries.com/
diff --git a/devel/py-Breve/pkg-plist b/devel/py-Breve/pkg-plist
new file mode 100644
index 000000000000..f0d3ab90dd59
--- /dev/null
+++ b/devel/py-Breve/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+@unexec %%EASY_INSTALL_CMD%% -q -N -m -S %D/%%PYTHON_SITELIBDIR%% %%PORTNAME%%==%%PORTVERSION%%
+%%PYTHON_SITELIBDIR%%/%%PYBREVE_EGG%%
+@exec %%EASY_INSTALL_CMD%% -q -N -S %D/%%PYTHON_SITELIBDIR%% %%PORTNAME%%==%%PORTVERSION%%