aboutsummaryrefslogtreecommitdiff
path: root/devel/py-astroid/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-10 14:29:45 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-10 14:46:13 +0000
commit9fe65c8089239059fe94f68478725f8a4b4168ab (patch)
tree9bb25a3072c69d02c4021592751d1cc0a41ecccf /devel/py-astroid/Makefile
parent66ac7829da7c4e9c5f5fad0869991b1a759773cc (diff)
downloadports-9fe65c8089239059fe94f68478725f8a4b4168ab.tar.gz
ports-9fe65c8089239059fe94f68478725f8a4b4168ab.zip
devel/py-astroid: Update to 2.5.7
Diffstat (limited to 'devel/py-astroid/Makefile')
-rw-r--r--devel/py-astroid/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/py-astroid/Makefile b/devel/py-astroid/Makefile
index 610ce56e3615..479698694bf5 100644
--- a/devel/py-astroid/Makefile
+++ b/devel/py-astroid/Makefile
@@ -1,5 +1,5 @@
PORTNAME= astroid
-PORTVERSION= 2.5.6
+PORTVERSION= 2.5.7
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,6 +10,7 @@ COMMENT= Abstract syntax tree for Python with inference support
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lazy-object-proxy>=1.4.0:devel/py-lazy-object-proxy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wrapt>=1.11<1.13:devel/py-wrapt@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
@@ -22,7 +23,8 @@ NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 30800
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typed-ast>=1.4.0<1.5:devel/py-typed-ast@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typed-ast>=1.4.0<1.5:devel/py-typed-ast@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4:devel/py-typing-extensions@${PY_FLAVOR}
.endif
do-test: