aboutsummaryrefslogtreecommitdiff
path: root/devel/py-cykhash
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-08-06 15:34:43 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-08-06 15:36:37 +0000
commit21e0240b8fe6a1552665bdc2e52c1b198e4df49c (patch)
tree479b35718b323b867c342ce9bf2c80a2d97097dc /devel/py-cykhash
parent2eff09595997f14e2a589568fdf3289643a093c1 (diff)
downloadports-21e0240b8fe6a1552665bdc2e52c1b198e4df49c.tar.gz
ports-21e0240b8fe6a1552665bdc2e52c1b198e4df49c.zip
devel/py-cykhash: Cython equivalent to khash-sets/maps
Cykhash is a cython equivalent to khash-sets/maps, efficient implementation of isin and unique Benefits: Brings functionality of khash to Python and Cython and can be used seamlessly in numpy or pandas. Numpy's world is lacking the concept of a (hash-)set. This shortcoming is fixed and efficient (memory- and speedwise compared to pandas') unique and isin are implemented. Python-set/dict have big memory-footprint. For some datatypes the overhead can be reduced by using khash by factor 4-8.
Diffstat (limited to 'devel/py-cykhash')
-rw-r--r--devel/py-cykhash/Makefile20
-rw-r--r--devel/py-cykhash/distinfo3
-rw-r--r--devel/py-cykhash/pkg-descr14
3 files changed, 37 insertions, 0 deletions
diff --git a/devel/py-cykhash/Makefile b/devel/py-cykhash/Makefile
new file mode 100644
index 000000000000..765dcbde2035
--- /dev/null
+++ b/devel/py-cykhash/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= cykhash
+DISTVERSION= 2.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Cython equivalent to khash-sets/maps
+WWW= https://pypi.python.org/project/cykhash/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist cython distutils
+
+post-stage:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cykhash/*.so
+
+.include <bsd.port.mk>
diff --git a/devel/py-cykhash/distinfo b/devel/py-cykhash/distinfo
new file mode 100644
index 000000000000..07e7db282c6b
--- /dev/null
+++ b/devel/py-cykhash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691328170
+SHA256 (cykhash-2.0.1.tar.gz) = b4794bc9f549114d8cf1d856d9f64e08ff5f246bf043cf369fdb414e9ceb97f7
+SIZE (cykhash-2.0.1.tar.gz) = 44895
diff --git a/devel/py-cykhash/pkg-descr b/devel/py-cykhash/pkg-descr
new file mode 100644
index 000000000000..dc8460a45675
--- /dev/null
+++ b/devel/py-cykhash/pkg-descr
@@ -0,0 +1,14 @@
+Cykhash is a cython equivalent to khash-sets/maps, efficient
+implementation of isin and unique
+
+Benefits:
+
+ Brings functionality of khash to Python and Cython and can be used
+ seamlessly in numpy or pandas.
+
+ Numpy's world is lacking the concept of a (hash-)set. This
+ shortcoming is fixed and efficient (memory- and speedwise compared
+ to pandas') unique and isin are implemented.
+
+ Python-set/dict have big memory-footprint. For some datatypes the
+ overhead can be reduced by using khash by factor 4-8.