aboutsummaryrefslogtreecommitdiff
path: root/devel/py-expandvars/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 08:56:51 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 08:56:51 +0000
commit92223841af27c549e0c452611f5f37b99a635ab2 (patch)
tree470c32896e915c1e78886e56da88ea3c58589581 /devel/py-expandvars/Makefile
parent49cf58210a20ce8ec1ca037d03fff0cd2a9d6707 (diff)
downloadports-92223841af27c549e0c452611f5f37b99a635ab2.tar.gz
ports-92223841af27c549e0c452611f5f37b99a635ab2.zip
devel/py-expandvars: Add py-expandvars 0.12.0
expandvars is inspired by GNU bash's variable expansion features. It can be used as an alternative to Python's os.path.expandvars function. A good use case is reading config files with the flexibility of reading values from environment variables using advanced features like returning a default value if some variable is not defined.
Diffstat (limited to 'devel/py-expandvars/Makefile')
-rw-r--r--devel/py-expandvars/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/py-expandvars/Makefile b/devel/py-expandvars/Makefile
new file mode 100644
index 000000000000..0aefcb159004
--- /dev/null
+++ b/devel/py-expandvars/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= expandvars
+PORTVERSION= 0.12.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Expand system variables Unix style
+WWW= https://github.com/sayanarijit/expandvars
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>