aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ply
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-31 09:56:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-31 09:56:58 +0000
commit21eb89848bef16449057c7a933824648fc4566ac (patch)
tree77dc54e9d02ff258373fdbf7eaf4ac26514a42a7 /devel/py-ply
parent91c0d28e69f236a3cd750a0328da79431514ddef (diff)
downloadports-21eb89848bef16449057c7a933824648fc4566ac.tar.gz
ports-21eb89848bef16449057c7a933824648fc4566ac.zip
add ply
Python Lex-Yacc
Notes
Notes: svn path=/head/; revision=45659
Diffstat (limited to 'devel/py-ply')
-rw-r--r--devel/py-ply/Makefile30
-rw-r--r--devel/py-ply/distinfo1
-rw-r--r--devel/py-ply/pkg-comment1
-rw-r--r--devel/py-ply/pkg-descr9
-rw-r--r--devel/py-ply/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/py-ply/Makefile b/devel/py-ply/Makefile
new file mode 100644
index 000000000000..5e42658d458d
--- /dev/null
+++ b/devel/py-ply/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: ply
+# Date created: Jul 31, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ply
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= http://systems.cs.uchicago.edu/ply/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/lex.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/yacc.py ${PYTHON_SITELIBDIR}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/ply.html ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/example ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-ply/distinfo b/devel/py-ply/distinfo
new file mode 100644
index 000000000000..1e92a8e452ff
--- /dev/null
+++ b/devel/py-ply/distinfo
@@ -0,0 +1 @@
+MD5 (ply-1.0.tar.gz) = ece59c1be8ccc8875410d77490747488
diff --git a/devel/py-ply/pkg-comment b/devel/py-ply/pkg-comment
new file mode 100644
index 000000000000..357e13cc8114
--- /dev/null
+++ b/devel/py-ply/pkg-comment
@@ -0,0 +1 @@
+Python Lex-Yacc
diff --git a/devel/py-ply/pkg-descr b/devel/py-ply/pkg-descr
new file mode 100644
index 000000000000..afcdc6775057
--- /dev/null
+++ b/devel/py-ply/pkg-descr
@@ -0,0 +1,9 @@
+PLY is a Python-only implementation of the popular compiler construction
+tools lex and yacc. The implementation borrows ideas from a number of
+previous efforts; most notably John Aycock's SPARK toolkit. However, the
+overall flavor of the implementation is more closely modeled after the C
+version of lex and yacc. The other significant feature of PLY is that it
+provides extensive input validation and error reporting--much more so than
+other Python parsing tools.
+
+WWW: http://systems.cs.uchicago.edu/ply/
diff --git a/devel/py-ply/pkg-plist b/devel/py-ply/pkg-plist
new file mode 100644
index 000000000000..ce3ad0fbfdbf
--- /dev/null
+++ b/devel/py-ply/pkg-plist
@@ -0,0 +1,10 @@
+lib/%%PYTHON_VERSION%%/site-packages/lex.py
+lib/%%PYTHON_VERSION%%/site-packages/yacc.py
+%%PORTDOCS%%share/doc/ply/ply.html
+%%PORTDOCS%%share/doc/ply/example/ansic/clex.py
+%%PORTDOCS%%share/doc/ply/example/ansic/cparse.py
+%%PORTDOCS%%share/doc/ply/example/calc/calc.py
+%%PORTDOCS%%@dirrm share/doc/ply/example/ansic
+%%PORTDOCS%%@dirrm share/doc/ply/example/calc
+%%PORTDOCS%%@dirrm share/doc/ply/example
+%%PORTDOCS%%@dirrm share/doc/ply