aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pycosat/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-23 07:11:36 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-23 07:11:36 +0000
commit3783caf25327bc33fb0a23b545ac48d0ec7393fb (patch)
treec67d889e5692fd9cc2a6f2339a8d954f89f3d362 /devel/py-pycosat/Makefile
parente3c5070587722756ad228e35952ee2413e3804ae (diff)
downloadports-3783caf25327bc33fb0a23b545ac48d0ec7393fb.tar.gz
ports-3783caf25327bc33fb0a23b545ac48d0ec7393fb.zip
[NEW] devel/py-pycosat: Bindings to PicoSAT (a SAT solver)
PicoSAT is a popular SAT solver written by Armin Biere in pure C. This package provides efficient Python bindings to picosat on the C level, i.e. when importing pycosat, the picosat solver becomes part of the Python process itself. WWW: https://github.com/ContinuumIO/pycosat
Notes
Notes: svn path=/head/; revision=365712
Diffstat (limited to 'devel/py-pycosat/Makefile')
-rw-r--r--devel/py-pycosat/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/py-pycosat/Makefile b/devel/py-pycosat/Makefile
new file mode 100644
index 000000000000..58e780ff6f77
--- /dev/null
+++ b/devel/py-pycosat/Makefile
@@ -0,0 +1,32 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pycosat
+PORTVERSION= 0.6.0
+CATEGORIES= devel math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Bindings to PicoSAT (a SAT solver)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpicosat.so:${PORTSDIR}/devel/picosat
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+PYDISTUTILS_BUILDARGS= build_ext \
+ -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -DDONT_INCLUDE_PICOSAT \
+ -lpicosat
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/python2.7/site-packages/pycosat.so
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>