aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pynest2d/Makefile
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-10-24 18:51:36 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-01-27 06:12:26 +0000
commit4f0a5e1540c391610950d6ae9ce64ba0dd218d72 (patch)
treee0e3a0327237691d3fe5df542835ced376d3bfae /devel/py-pynest2d/Makefile
parentcc7a787d5f043014dcea80bd0058dd7117a5e308 (diff)
downloadports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.tar.gz
ports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.zip
PyQt: Update sip to 6.5.0, reintroduce sip4 and simplify PyQt framework.
SIP: As mentioned in the update from sip to sip5, this is a transitional version to remove what is deprecated in sip4. Sip6 completely removes the deprecated parts. Unfortunately, some ports — mostly cura things — can not use sip6, so we reintroduce sip4. PyQt: At the same time, we took the opportunity to simplify PyQT and propose only one package as for devel/pyside2. */py-qt5-* have been merged — excepted chart, networkauth and webengine — into devel/py-qt5-pyqt. This allows us to be in adequacy with the packages that the author of these libraries proposes, namely: PyQt - devel/py-qt5-pyqt PyQt-Charts - x11-toolkits/py-qt5-chart PyQt-NetworkAuth – net/py-qt5-networkauth PyQt-WebEngine – www/py-qt5-webengine SIP – devel/py-sip py-sip - devel/py-qt5-sip PyQt-builder - devel/py-qtbuilder Qscintilla - devel/py-qt5-qscintilla2 Reviewed by: diizzy, kde Tested by: kai, rhurlin, arrowd, madpilot Approved by: makc, tcberner, kde Differential Revision: https://reviews.freebsd.org/D33237 Exp-run by: antoine
Diffstat (limited to 'devel/py-pynest2d/Makefile')
-rw-r--r--devel/py-pynest2d/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/py-pynest2d/Makefile b/devel/py-pynest2d/Makefile
index b41138701b93..73ef8c7b69b3 100644
--- a/devel/py-pynest2d/Makefile
+++ b/devel/py-pynest2d/Makefile
@@ -1,6 +1,5 @@
PORTNAME= pynest2d
-DISTVERSION= 4.8.0
-PORTREVISION= 4
+DISTVERSION= 4.12.1
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +10,8 @@ LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${LOCALBASE}/include/libnest2d/libnest2d.hpp:devel/libnest2d-ultimaker
-BUILD_DEPENDS= ${LOCALBASE}/include/libnest2d/libnest2d.hpp:devel/libnest2d-ultimaker
+BUILD_DEPENDS= ${LOCALBASE}/include/libnest2d/libnest2d.hpp:devel/libnest2d-ultimaker \
+ sip:devel/py-sip4
LIB_DEPENDS= libpolyclipping.so:graphics/polyclipping \
libboost_system.so:devel/boost-libs \
libnlopt.so:math/nlopt
@@ -20,10 +20,8 @@ USES= python:3.6+ cmake compiler:c++11-lang pyqt:5 pkgconfig
USE_PYTHON= flavors
USE_GITHUB= yes
-GH_TUPLE= Ultimaker:pynest2d:d31a381
-USE_PYQT= sip pysip
-CMAKE_ARGS= -DSIP_EXECUTABLE=${SIP} \
- -DLIBNEST2D_INCLUDE_DIRS=${PREFIX}/include/libnest2d
+GH_TUPLE= Ultimaker:pynest2d:baec470
+CMAKE_ARGS= -DLIBNEST2D_INCLUDE_DIRS=${PREFIX}/include/libnest2d
CONFIGURE_ENV= CLIPPER_PATH=${LOCALBASE} VERBOSE=y
.include <bsd.port.mk>