aboutsummaryrefslogtreecommitdiff
path: root/devel/py-xdg/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-02 16:45:36 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-02 16:45:36 +0000
commit2a1b673cbb5485aa7144c25ec3243f27ec824bd7 (patch)
tree2b8113374ea552edb3cb3f0b907ce0515ce676e7 /devel/py-xdg/Makefile
parente6eb991af27b0eb6db21db017d9e524f26a17733 (diff)
downloadports-2a1b673cbb5485aa7144c25ec3243f27ec824bd7.tar.gz
ports-2a1b673cbb5485aa7144c25ec3243f27ec824bd7.zip
- Update to 0.9
- Add patch work to add path to xdg stuff [1] Requested by: mezz and marcus for a gnome menu editor [1]
Notes
Notes: svn path=/head/; revision=132215
Diffstat (limited to 'devel/py-xdg/Makefile')
-rw-r--r--devel/py-xdg/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/py-xdg/Makefile b/devel/py-xdg/Makefile
index a9da38d00ebe..4e95a89d76a0 100644
--- a/devel/py-xdg/Makefile
+++ b/devel/py-xdg/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= xdg
-PORTVERSION= 0.8
+PORTVERSION= 0.9
CATEGORIES= devel python
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ahze
+MASTER_SITES= http://www.freedesktop.org/~lanius/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py${PORTNAME}-${PORTVERSION}
@@ -21,10 +20,11 @@ USE_PYDISTUTILS=yes
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g ; \
- s|/usr/share|/usr/share:${X11BASE}/share|g' \
- ${WRKSRC}/xdg/BaseDirectory.py
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/xdg/IconTheme.py
+ @${REINPLACE_CMD} -e \
+ 's|/etc|${PREFIX}/etc|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/xdg/BaseDirectory.py \
+ ${WRKSRC}/xdg/IconTheme.py
.include <bsd.port.mk>