aboutsummaryrefslogtreecommitdiff
path: root/devel/qsa
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 19:44:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 19:44:02 +0000
commitd095d4a96566a3ab095ab2e30430ce93a154f1a7 (patch)
treeca5cd97e4ad40da4b6e4a6c197453610fd6c69b1 /devel/qsa
parentc0a7a1f97264b914fa27603f8433b87b38b15f14 (diff)
downloadports-d095d4a96566a3ab095ab2e30430ce93a154f1a7.tar.gz
ports-d095d4a96566a3ab095ab2e30430ce93a154f1a7.zip
- Remove conditional checks for FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225293
Diffstat (limited to 'devel/qsa')
-rw-r--r--devel/qsa/Makefile4
-rw-r--r--devel/qsa/files/extrapatch-src_engine_qsoperations.cpp16
2 files changed, 0 insertions, 20 deletions
diff --git a/devel/qsa/Makefile b/devel/qsa/Makefile
index 497a33b5cc88..0b2138fa2e4e 100644
--- a/devel/qsa/Makefile
+++ b/devel/qsa/Makefile
@@ -42,10 +42,6 @@ OPTIONS= IDE "Enable the QSA Workbench (embedded scripting IDE)" on
CONFIGURE_ARGS+=-no-ide
.endif
-.if ${OSVERSION} < 502124
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-src_engine_qsoperations.cpp
-.endif
-
pre-configure:
# Adjust installation directories for the documentation and the qmake feature extension
@${REINPLACE_CMD} -e 's|$$$$QSA_INSTALL_PREFIX/doc/html|$$$$QSA_INSTALL_PREFIX/share/doc/qsa/html|g' \
diff --git a/devel/qsa/files/extrapatch-src_engine_qsoperations.cpp b/devel/qsa/files/extrapatch-src_engine_qsoperations.cpp
deleted file mode 100644
index 26e08bba551c..000000000000
--- a/devel/qsa/files/extrapatch-src_engine_qsoperations.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/engine/qsoperations.cpp.orig Mon Jul 12 15:04:29 2004
-+++ src/engine/qsoperations.cpp Mon Jul 12 15:23:49 2004
-@@ -61,6 +61,13 @@
- }
- #endif
-
-+#ifdef __FreeBSD__
-+extern "C" {
-+ int isnan( double );
-+ int isinf( double );
-+}
-+#endif
-+
- using namespace QS;
-
- bool QS::isNaN( double d )