aboutsummaryrefslogtreecommitdiff
path: root/devel/quilt/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-19 00:14:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-19 00:14:09 +0000
commit3543ac34f585fbd498fbe27c70e185df4207c799 (patch)
tree4f9b16bcbb56dac36c804c153a0355bdebe23244 /devel/quilt/Makefile
parente0d66346b4abbd48845f4a14ce54c6a8a504c93b (diff)
downloadports-3543ac34f585fbd498fbe27c70e185df4207c799.tar.gz
ports-3543ac34f585fbd498fbe27c70e185df4207c799.zip
- depend on correct version of bash (bash3)
- fix plist for WITH_RPMBUILD case - fix plist for the case where sendmail binary not beeing in the default directory (/usr/sbin/). PR: 132762 Submitted by: Dirk Jagdmann <doj at cubic dot org> (maintainer)
Notes
Notes: svn path=/head/; revision=230385
Diffstat (limited to 'devel/quilt/Makefile')
-rw-r--r--devel/quilt/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/quilt/Makefile b/devel/quilt/Makefile
index 5b3795666c8c..8811b8cee2e0 100644
--- a/devel/quilt/Makefile
+++ b/devel/quilt/Makefile
@@ -12,9 +12,9 @@ MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= quilt
MAINTAINER= doj@cubic.org
-COMMENT= A collection of bash scripts to ease working with patch files
+COMMENT= A collection of bash3 scripts to ease working with patch files
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash3 \
gcp:${PORTSDIR}/sysutils/coreutils \
gsed:${PORTSDIR}/textproc/gsed \
gpatch:${PORTSDIR}/devel/patch \
@@ -54,6 +54,12 @@ PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+= --disable-nls
.endif
+.if !exists(${LOCALBASE}/sbin/sendmail)
+PLIST_SUB+= SENDMAIL=""
+.else
+PLIST_SUB+= SENDMAIL="@comment "
+.endif
+
.if defined(NOPORTDOCS)
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Makefile.in
.endif