aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-pathname/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:01:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:01:03 +0000
commit370d39657e1795dd16d8c5437b7a9d3176e756e1 (patch)
tree4528236221a26efd67aa2415be66bb285e199425 /devel/rubygem-pathname/Makefile
parentd3835f61ced7bde03f52a3b91fe7ce498089e2d6 (diff)
downloadports-370d39657e1795dd16d8c5437b7a9d3176e756e1.tar.gz
ports-370d39657e1795dd16d8c5437b7a9d3176e756e1.zip
Add rubygem-pathname 0.1.0
Pathname represents the name of a file or directory on the filesystem, but not the file itself. The pathname depends on the Operating System: Unix, Windows, etc. This library works with pathnames of local OS, however non-Unix pathnames are supported experimentally. A Pathname can be relative or absolute. It's not until you try to reference the file that it even matters whether the file exists or not. Pathname is immutable. It has no method for destructive update. The goal of this class is to manipulate file path information in a neater way than standard Ruby provides. The examples below demonstrate the difference. All functionality from File, FileTest, and some from Dir and FileUtils is included, in an unsurprising way. It is essentially a facade for all of these, and more. WWW: https://github.com/ruby/pathname
Notes
Notes: svn path=/head/; revision=560067
Diffstat (limited to 'devel/rubygem-pathname/Makefile')
-rw-r--r--devel/rubygem-pathname/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devel/rubygem-pathname/Makefile b/devel/rubygem-pathname/Makefile
new file mode 100644
index 000000000000..c3c5bb264f44
--- /dev/null
+++ b/devel/rubygem-pathname/Makefile
@@ -0,0 +1,19 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pathname
+PORTVERSION= 0.1.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Representation of the name of a file or directory on the filesystem
+
+LICENSE= BSD2CLAUSE RUBY
+LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>