aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-prometheus-client-mmap/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:44:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:48:20 +0000
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /devel/rubygem-prometheus-client-mmap/Makefile
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadports-95274bf4f99c71fc056013d966aec239161dfd74.tar.gz
ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'devel/rubygem-prometheus-client-mmap/Makefile')
-rw-r--r--devel/rubygem-prometheus-client-mmap/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/rubygem-prometheus-client-mmap/Makefile b/devel/rubygem-prometheus-client-mmap/Makefile
index 60afa52c46fb..4805ca089ebf 100644
--- a/devel/rubygem-prometheus-client-mmap/Makefile
+++ b/devel/rubygem-prometheus-client-mmap/Makefile
@@ -15,7 +15,7 @@ USES= gem
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif