aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl12/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-07 23:53:17 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-07 23:53:17 +0000
commit8b6e81981aeb8e3575f65602d5b700150e2a94f0 (patch)
treeb0d14b301a2748b4737044e00030443fa1c60658 /devel/sdl12/Makefile
parent84c834ee8fcd257e31c450ea1ffd53f11140b612 (diff)
downloadports-8b6e81981aeb8e3575f65602d5b700150e2a94f0.tar.gz
ports-8b6e81981aeb8e3575f65602d5b700150e2a94f0.zip
[patch] unbreak packaging of devel/sdl12 with NOPORTDOCS
In the current state of the port Makefile and pkg-plist are not in sync. Makefile obeys NOPORTDOCS, but pkg-plist would enlist not installed files anyway breaking packaging when NOPORTDOCS is set. PR: ports/62587 Submitted by: Piotr Smyrak <piotr.smyrak@heron.pl>
Notes
Notes: svn path=/head/; revision=103244
Diffstat (limited to 'devel/sdl12/Makefile')
-rw-r--r--devel/sdl12/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index aedb6a8e68c4..fdcf830f3b5d 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -31,6 +31,10 @@ CONFIGURE_ARGS= --enable-video-aalib \
CFLAGS+= ${PTHREAD_CFLAGS}
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
.if exists(/usr/lib/libvgl.so.3)
CONFIGURE_ARGS+=--enable-video-vgl
DISPLAY_MSG= ${CAT} ${PKGMESSAGE}
@@ -93,15 +97,15 @@ post-configure:
${WRKSRC}/libtool
post-install:
- @${MKDIR} ${PREFIX}/share/examples/SDL11
- ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL11
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/SDL11/docs
+ @${MKDIR} ${DOCSDIR}/docs
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL11
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
@cd ${WRKSRC}/docs; ${TAR} cf - `${ECHO_CMD} [^Mm]*` | \
- (cd ${PREFIX}/share/doc/SDL11/docs; ${TAR} --unlink -xf - )
+ (cd ${DOCSDIR}/docs; ${TAR} --unlink -xf - )
.endif
@${DISPLAY_MSG}