aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16/files
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2003-10-09 12:50:16 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2003-10-09 12:50:16 +0000
commit18c82f1b151e37ba088cc5ae353fd065d09d133d (patch)
tree8e9e21250d0245c819f69a4c038c4c772162aee2 /devel/subversion16/files
parent016a4aa1e9831906d9351e518e8e10d864c140b8 (diff)
downloadports-18c82f1b151e37ba088cc5ae353fd065d09d133d.tar.gz
ports-18c82f1b151e37ba088cc5ae353fd065d09d133d.zip
[1] Update to 0.31.0
[2] Add (optional) ability to create repository [3] Add (optional) svnserve wrapper to fix svn+ssh access problems. PR: [2,3] ports/57754
Notes
Notes: svn path=/head/; revision=90709
Diffstat (limited to 'devel/subversion16/files')
-rw-r--r--devel/subversion16/files/build-outputs.mk.patch11
-rw-r--r--devel/subversion16/files/patch-configure11
-rw-r--r--devel/subversion16/files/svnserve.wrapper7
3 files changed, 24 insertions, 5 deletions
diff --git a/devel/subversion16/files/build-outputs.mk.patch b/devel/subversion16/files/build-outputs.mk.patch
new file mode 100644
index 000000000000..3612f626c7ce
--- /dev/null
+++ b/devel/subversion16/files/build-outputs.mk.patch
@@ -0,0 +1,11 @@
+--- build-outputs.mk.orig Wed Oct 8 16:01:40 2003
++++ build-outputs.mk Wed Oct 8 16:02:00 2003
+@@ -447,7 +447,7 @@
+ cd subversion/svnadmin ; $(INSTALL_FS_BIN) svnadmin$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnadmin$(EXEEXT)
+ cd subversion/svndumpfilter ; $(INSTALL_FS_BIN) svndumpfilter$(EXEEXT) $(DESTDIR)$(fs_bindir)/svndumpfilter$(EXEEXT)
+ cd subversion/svnlook ; $(INSTALL_FS_BIN) svnlook$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnlook$(EXEEXT)
+- cd subversion/svnserve ; $(INSTALL_FS_BIN) svnserve$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnserve$(EXEEXT)
++ cd subversion/svnserve ; $(INSTALL_FS_BIN) svnserve$(EXEEXT) $(DESTDIR)$(fs_bindir)/svnserve.bin$(EXEEXT)
+
+ install-fs-lib: subversion/libsvn_fs/libsvn_fs-1.la subversion/libsvn_repos/libsvn_repos-1.la subversion/libsvn_ra_local/libsvn_ra_local-1.la
+ $(MKDIR) $(DESTDIR)$(fs_libdir)
diff --git a/devel/subversion16/files/patch-configure b/devel/subversion16/files/patch-configure
index a61b6659305d..8ad6cd1ae5ed 100644
--- a/devel/subversion16/files/patch-configure
+++ b/devel/subversion16/files/patch-configure
@@ -1,13 +1,14 @@
---- configure.orig Fri Jul 25 09:25:23 2003
-+++ configure Fri Jul 25 09:25:28 2003
-@@ -1820,8 +1820,8 @@
+--- configure.orig Thu Oct 9 09:10:22 2003
++++ configure Thu Oct 9 09:10:30 2003
+@@ -2952,9 +2952,9 @@
-APR_VER_REGEX="0\.9\.[4-9]"
--APU_VER_REGEX="0\.9\.[4-9]"
+APR_VER_REGEX="0\.9\.[3-9]"
+ APR_VER_REGEX_TOO="1\.0"
+-APU_VER_REGEX="0\.9\.[4-9]"
+APU_VER_REGEX="0\.9\.[3-9]"
-
+ APU_VER_REGEX_TOO="1\.0"
diff --git a/devel/subversion16/files/svnserve.wrapper b/devel/subversion16/files/svnserve.wrapper
new file mode 100644
index 000000000000..6797f9478ad5
--- /dev/null
+++ b/devel/subversion16/files/svnserve.wrapper
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+SVNSERVE=$(dirname $(realpath $0))/svnserve.bin
+
+umask 002
+$SVNSERVE "$@"
+