aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion16
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2005-12-16 18:52:10 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2005-12-16 18:52:10 +0000
commit33d0e8ee263235fc736e2f9b660cb2cb4d266e5c (patch)
tree8138059e94ec0db91a67e2517604dc40eb105d7d /devel/subversion16
parent0d280936ef844dde6ac00dcb66e306d2f49ff806 (diff)
downloadports-33d0e8ee263235fc736e2f9b660cb2cb4d266e5c.tar.gz
ports-33d0e8ee263235fc736e2f9b660cb2cb4d266e5c.zip
(1) Properly process apache port versions.
(2) Set proper permissions on ${PREFIX}/share/subversion PR: 89606 [2]
Notes
Notes: svn path=/head/; revision=151338
Diffstat (limited to 'devel/subversion16')
-rw-r--r--devel/subversion16/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index 1acef9289264..e43d138020d6 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -6,7 +6,7 @@
PORTNAME= subversion
DISTVERSION= 1.3.0-rc4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.1/:book
@@ -156,7 +156,7 @@ SVNGROUP?= svn
.if defined(WITH_APACHE2_APR)
USE_APACHE= 2.0+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
-.if ${APACHE_PORT} == "www/apache21"
+.if ${APACHE_VERSION} >= 21
APR_APU_DIR= ${LOCALBASE}/bin
APR_CONFIG= apr-1-config
APU_CONFIG= apu-1-config
@@ -363,6 +363,7 @@ post-install: ${MKREPOS_TARGET}
@${MKDIR} ${PREFIX}/share/subversion
cd ${WRKSRC}/tools ; \
tar --exclude '*.in' -cf - * | tar -C ${PREFIX}/share/subversion -xf -
+ @${CHMOD} -R a-st,o+rX ${PREFIX}/share/subversion
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
for f in ${TXT_DOCS}; do \