aboutsummaryrefslogtreecommitdiff
path: root/devel/tbb/pkg-plist
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-10-02 18:39:18 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-10-02 18:39:18 +0000
commit953d689ce3c783d1a9272062fac2b7f93fb299d0 (patch)
tree56dc4cf5b6c758bc0e2e10bd295a52c57e5e757a /devel/tbb/pkg-plist
parentf0bb9c6ed889ebd31ca0f292f3c4a01577582b74 (diff)
downloadports-953d689ce3c783d1a9272062fac2b7f93fb299d0.tar.gz
ports-953d689ce3c783d1a9272062fac2b7f93fb299d0.zip
Intel Threading Building Blocks (TBB) offers a rich and complete
approach to expressing parallelism in a C++ program. It is a library that helps you take advantage of multi-core processor performance without having to be a threading expert. Threading Building Blocks is not just a threads-replacement library. It represents a higher-level, task-based parallelism that abstracts platform details and threading mechanism for performance and scalability. WWW: http://tbb.sourceforge.net/ - Arun Sharma arun@FreeBSD.org PR: ports/116771 Submitted by: Arun Sharma <arun at sharma-home.net>
Notes
Notes: svn path=/head/; revision=200682
Diffstat (limited to 'devel/tbb/pkg-plist')
-rw-r--r--devel/tbb/pkg-plist40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/tbb/pkg-plist b/devel/tbb/pkg-plist
new file mode 100644
index 000000000000..11df2056c1c4
--- /dev/null
+++ b/devel/tbb/pkg-plist
@@ -0,0 +1,40 @@
+include/tbb/aligned_space.h
+include/tbb/atomic.h
+include/tbb/blocked_range.h
+include/tbb/blocked_range2d.h
+include/tbb/cache_aligned_allocator.h
+include/tbb/concurrent_hash_map.h
+include/tbb/concurrent_queue.h
+include/tbb/concurrent_vector.h
+include/tbb/mutex.h
+include/tbb/parallel_for.h
+include/tbb/parallel_reduce.h
+include/tbb/parallel_scan.h
+include/tbb/parallel_sort.h
+include/tbb/parallel_while.h
+include/tbb/pipeline.h
+include/tbb/queuing_mutex.h
+include/tbb/queuing_rw_mutex.h
+include/tbb/scalable_allocator.h
+include/tbb/task.h
+include/tbb/spin_mutex.h
+include/tbb/spin_rw_mutex.h
+include/tbb/task_scheduler_init.h
+include/tbb/tbb_stddef.h
+include/tbb/tick_count.h
+include/tbb/_tbb_windef.h
+include/tbb/partitioner.h
+include/tbb/tbb_machine.h
+include/tbb/machine/linux_ia32.h
+include/tbb/machine/linux_em64t.h
+include/tbb/machine/linux_itanium.h
+include/tbb/machine/mac_ppc.h
+include/tbb/machine/windows_ia32.h
+include/tbb/machine/windows_ia32_inline.h
+include/tbb/machine/windows_em64t.h
+include/tbb/machine/freebsd_em64t.h
+include/tbb/machine/freebsd_ia32.h
+include/tbb/machine/freebsd_itanium.h
+lib/libtbb.so
+@dirrm include/tbb/machine
+@dirrm include/tbb