aboutsummaryrefslogtreecommitdiff
path: root/devel/terminality
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-28 17:55:53 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-28 17:55:53 +0000
commitfd96745bd5a59118b5cbd7624da288d441a2f00f (patch)
treedca4ca2dc1f32e611107873ae037a14af16e2be8 /devel/terminality
parent3f3da42fc33161016c1e08a10201b17a88e73f47 (diff)
downloadports-fd96745bd5a59118b5cbd7624da288d441a2f00f.tar.gz
ports-fd96745bd5a59118b5cbd7624da288d441a2f00f.zip
add terminality
A cross-platform terminal manipulation library
Notes
Notes: svn path=/head/; revision=42010
Diffstat (limited to 'devel/terminality')
-rw-r--r--devel/terminality/Makefile33
-rw-r--r--devel/terminality/distinfo1
-rw-r--r--devel/terminality/files/patch-Makefile29
-rw-r--r--devel/terminality/files/patch-demo::Makefile22
-rw-r--r--devel/terminality/files/patch-dlgc::Makefile13
-rw-r--r--devel/terminality/pkg-comment1
-rw-r--r--devel/terminality/pkg-descr6
-rw-r--r--devel/terminality/pkg-plist32
8 files changed, 137 insertions, 0 deletions
diff --git a/devel/terminality/Makefile b/devel/terminality/Makefile
new file mode 100644
index 000000000000..74043f896050
--- /dev/null
+++ b/devel/terminality/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: terminality
+# Date created: Apr 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= terminality
+PORTVERSION= 1.8
+CATEGORIES= devel
+MASTER_SITES= http://members.optushome.com.au/darkmoon7/
+DISTNAME= tn-${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/tn
+USE_GMAKE= yes
+MAKE_ENV= CPP=${CXX} INSTALL="${INSTALL}" INSTALL_DATA="${INSTALL_DATA}"
+
+post-patch:
+ @find ${WRKSRC} -name Makefile | xargs \
+ ${PERL} -pi -e "s, -lstdc\\+\\+,,g"
+ @${PERL} -pi -e "s,make,gmake,g ; \
+ s,/usr/local,${PREFIX},g" ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/terminality
+ ${CP} -R ${WRKSRC}/doc/ ${PREFIX}/share/doc/terminality
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/terminality/distinfo b/devel/terminality/distinfo
new file mode 100644
index 000000000000..f75dff3431d6
--- /dev/null
+++ b/devel/terminality/distinfo
@@ -0,0 +1 @@
+MD5 (tn-1.8.tar.gz) = 0991b1668b53f18efdae3ab2dadf5872
diff --git a/devel/terminality/files/patch-Makefile b/devel/terminality/files/patch-Makefile
new file mode 100644
index 000000000000..a57aa617368c
--- /dev/null
+++ b/devel/terminality/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig Sun Feb 18 13:48:12 2001
++++ Makefile Sun Apr 29 01:41:18 2001
+@@ -19,9 +19,7 @@
+ #
+ # Makefile for the ncurses frontend of the library
+
+-CC = gcc
+-CPP = g++
+-CFLAGS = -DUSE_NCURSES -g -I. -Wall
++CFLAGS += -DUSE_NCURSES -I.
+ LIBS = -lncurses
+
+ .SUFFIXES: .c .cpp .h
+@@ -83,13 +81,9 @@
+
+ # for G.Gabriele ;)
+ install:
+- install libtn.a -m 0644 /usr/local/lib
++ ${INSTALL} libtn.a /usr/local/lib
+ install -m 0755 -d /usr/local/include/tn
+- install *.h -m 0644 /usr/local/include/tn
+- install -m 0755 -d /usr/local/doc/tn
+- install doc/tn/*.html -m 0644 /usr/local/doc/tn
+- install doc/tn/*.jpeg -m 0644 /usr/local/doc/tn
+- install doc/tn/*.css -m 0644 /usr/local/doc/tn
++ ${INSTALL_DATA} *.h /usr/local/include/tn
+
+ # $Log: Makefile,v $
+ # Revision 1.24 2001/02/18 05:48:12 darkmoon
diff --git a/devel/terminality/files/patch-demo::Makefile b/devel/terminality/files/patch-demo::Makefile
new file mode 100644
index 000000000000..4f3e922d7eb8
--- /dev/null
+++ b/devel/terminality/files/patch-demo::Makefile
@@ -0,0 +1,22 @@
+--- demo/Makefile.orig Tue Feb 20 19:28:28 2001
++++ demo/Makefile Sun Apr 29 01:19:20 2001
+@@ -21,9 +21,7 @@
+ # Description: Terminality demos Makefile (Unix/ncurses)
+ # Author: Emil Mikulic, Michal Safranek
+
+-CC = gcc
+-CPP = g++
+-CFLAGS = -g -I.. -Wall -DUSE_NCURSES
++CFLAGS += -I.. -DUSE_NCURSES
+ LIBS = -lncurses ../libtn.a
+
+ .SUFFIXES: .c .cpp .h
+@@ -34,7 +32,7 @@
+ $(CC) -o demo $< $(CFLAGS) $(LIBS) -lstdc++
+
+ demo3d: demo3d.o ../libtn.a precalc.o Makefile
+- $(CC) -o demo3d $< precalc.o $(CFLAGS) $(LIBS) -lstdc++
++ $(CPP) -o demo3d $< precalc.o $(CFLAGS) $(LIBS) -lstdc++
+
+ demoansi: demoansi.o ../libtn.a precalc.o Makefile
+ $(CC) -o demoansi $< precalc.o $(CFLAGS) $(LIBS)
diff --git a/devel/terminality/files/patch-dlgc::Makefile b/devel/terminality/files/patch-dlgc::Makefile
new file mode 100644
index 000000000000..ea45f416b8b5
--- /dev/null
+++ b/devel/terminality/files/patch-dlgc::Makefile
@@ -0,0 +1,13 @@
+--- dlgc/Makefile.orig Sun Jan 7 17:53:21 2001
++++ dlgc/Makefile Sun Apr 29 00:13:09 2001
+@@ -4,9 +4,7 @@
+ # Description: DLGC Makefile
+ # Author: Michal Safranek
+
+-CC = gcc
+-CPP = g++
+-CFLAGS = -g -I.. -Wall -DUSE_NCURSES
++CFLAGS += -I.. -DUSE_NCURSES
+ LIBS = -lncurses ../libtn.a
+
+ .SUFFIXES: .c .cpp .h
diff --git a/devel/terminality/pkg-comment b/devel/terminality/pkg-comment
new file mode 100644
index 000000000000..f5522ae6e6de
--- /dev/null
+++ b/devel/terminality/pkg-comment
@@ -0,0 +1 @@
+A cross-platform terminal manipulation library
diff --git a/devel/terminality/pkg-descr b/devel/terminality/pkg-descr
new file mode 100644
index 000000000000..0f1ec15d8602
--- /dev/null
+++ b/devel/terminality/pkg-descr
@@ -0,0 +1,6 @@
+Terminality aims to be a cross-platform terminal manipulation library. It
+provides a set of functions which are used to manipulate a text terminal,
+functions such as clearing the screen, changing text colours, moving the
+cursor, etc.
+
+WWW: http://members.optushome.com.au/darkmoon7/term.html
diff --git a/devel/terminality/pkg-plist b/devel/terminality/pkg-plist
new file mode 100644
index 000000000000..cea30eb88c4c
--- /dev/null
+++ b/devel/terminality/pkg-plist
@@ -0,0 +1,32 @@
+lib/libtn.a
+include/tn/colors.h
+include/tn/dscheme.h
+include/tn/elements.h
+include/tn/extra.h
+include/tn/gui.h
+include/tn/keyhndl.h
+include/tn/list.h
+include/tn/register.h
+include/tn/tn.h
+include/tn/tn_nc.h
+include/tn/tn_w32.h
+include/tn/xmem.h
+@dirrm include/tn
+%%PORTDOCS%%share/doc/terminality/curs1.c
+%%PORTDOCS%%share/doc/terminality/extra1.c
+%%PORTDOCS%%share/doc/terminality/extra2.c
+%%PORTDOCS%%share/doc/terminality/hello1.c
+%%PORTDOCS%%share/doc/terminality/hello2.c
+%%PORTDOCS%%share/doc/terminality/index.html
+%%PORTDOCS%%share/doc/terminality/keyb1.c
+%%PORTDOCS%%share/doc/terminality/ref-tn.html
+%%PORTDOCS%%share/doc/terminality/screenshot/curs1.png
+%%PORTDOCS%%share/doc/terminality/screenshot/extra1.png
+%%PORTDOCS%%share/doc/terminality/screenshot/extra2.png
+%%PORTDOCS%%share/doc/terminality/screenshot/hello1.png
+%%PORTDOCS%%share/doc/terminality/screenshot/hello2.png
+%%PORTDOCS%%share/doc/terminality/screenshot/keyb1.png
+%%PORTDOCS%%share/doc/terminality/tutor-extra.html
+%%PORTDOCS%%share/doc/terminality/tutor-tn.html
+%%PORTDOCS%%@dirrm share/doc/terminality/screenshot
+%%PORTDOCS%%@dirrm share/doc/terminality