aboutsummaryrefslogtreecommitdiff
path: root/devel/tpasm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-09-01 08:01:55 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-09-01 08:01:55 +0000
commit7a8f1119d0bcdb8391d8a62b364627b9a04a8eb8 (patch)
treef5c00767d5692db9aa6a6af12f4fca829ff6cb2b /devel/tpasm
parent6ce3b2c65a22487e7cc3f32b23f8bcbb6fda510c (diff)
downloadports-7a8f1119d0bcdb8391d8a62b364627b9a04a8eb8.tar.gz
ports-7a8f1119d0bcdb8391d8a62b364627b9a04a8eb8.zip
- Generalize COMMENT: an increasing list of supported chips makes it overly
long and hard to keep accurate - Define LICENSE (GPLv2) - Install one additional document - Make port description fit the standard 80x24 terminal screen and reformat for better consistency while I'm here; also adjust some wording
Notes
Notes: svn path=/head/; revision=280942
Diffstat (limited to 'devel/tpasm')
-rw-r--r--devel/tpasm/Makefile7
-rw-r--r--devel/tpasm/pkg-descr23
2 files changed, 16 insertions, 14 deletions
diff --git a/devel/tpasm/Makefile b/devel/tpasm/Makefile
index e6edb26bd33d..38df204c2b2f 100644
--- a/devel/tpasm/Makefile
+++ b/devel/tpasm/Makefile
@@ -13,7 +13,9 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Cross-assembler for 680x, 68HC11, 6502, Sunplus, 8051, Z80, PIC, AVR
+COMMENT= Cross-assembler for variety of microprocessors and controllers
+
+LICENSE= GPLv2
USE_GMAKE= yes
PORTDOCS= *
@@ -25,7 +27,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/libdata/${PORTNAME}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/MANUAL.TXT ${WRKSRC}/README*.TXT ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CONVERSION_C166.TXT ${WRKSRC}/MANUAL.TXT \
+ ${WRKSRC}/README*.TXT ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
diff --git a/devel/tpasm/pkg-descr b/devel/tpasm/pkg-descr
index 989666df7daa..b11f4705f81f 100644
--- a/devel/tpasm/pkg-descr
+++ b/devel/tpasm/pkg-descr
@@ -1,23 +1,22 @@
-Tpasm is a command line based cross assembler for a variety of common
+Tpasm is a command line based cross assembler for a vast variety of common
microprocessors and controllers, currently supporting:
- Rockwell 6502 (6502, 65c02)
- Motorola 6805 (6805, 68705), 6809, 68hc11
- Intel 8051 (8031, 8032, 8051, 8052, 80c390)
- Atmel AVR (avt, attiny, at90, atmega series)
- Core Technologies CTXP-1
- Microchip PIC (12xxx, 14xxx, 16xxx, 17xxx series)
- Sunplus SPCxxx series
- Zilog Z80 (z80, z180)
+ * Rockwell 6502 (6502, 65c02)
+ * Motorola 6805 (6805, 68705), 6809, 68hc11
+ * Intel 8051 (8031, 8032, 8051, 8052, 80c390)
+ * Atmel AVR (avt, attiny, at90, atmega series)
+ * Core Technologies CTXP-1
+ * Microchip PIC (12xxx, 14xxx, 16xxx, 17xxx series)
+ * Sunplus SPCxxx series
+ * Zilog Z80 (z80, z180)
-Features include:
+Its features include:
* True multi-pass assembly (will take as many passes as needed)
* Multiple segments
* Sophisticated expressions
* Macros, repeats, conditionals
- * Arbitrary length labels
- * Local labels
+ * Arbitrary length labels, local labels
* Supporting new processors is reasonably straightforward
* Can switch between processors during assembly