aboutsummaryrefslogtreecommitdiff
path: root/devel/uds
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-05 02:56:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-05 02:56:17 +0000
commitb5593ef4c9a688b589711cc3e1d66f1deb56d050 (patch)
tree930473cfa7b542c1b06697a36ac8abc209d8f804 /devel/uds
parent1d9e82e234f2488ac671a0e896d4810829ec2652 (diff)
downloadports-b5593ef4c9a688b589711cc3e1d66f1deb56d050.tar.gz
ports-b5593ef4c9a688b589711cc3e1d66f1deb56d050.zip
upgrade to 1.0.6
drop maintainership
Notes
Notes: svn path=/head/; revision=65641
Diffstat (limited to 'devel/uds')
-rw-r--r--devel/uds/Makefile15
-rw-r--r--devel/uds/distinfo2
-rw-r--r--devel/uds/files/patch-uds::alloc.cc33
-rw-r--r--devel/uds/files/patch-uds::fdbuf.cc10
-rw-r--r--devel/uds/files/patch-uds::io_util.hh47
-rw-r--r--devel/uds/files/patch-uds::packetsocket.cc6
-rw-r--r--devel/uds/files/patch-uds::streamsocket.cc6
-rw-r--r--devel/uds/pkg-plist18
8 files changed, 120 insertions, 17 deletions
diff --git a/devel/uds/Makefile b/devel/uds/Makefile
index d9aa25b5d66d..bba52a2f3c5d 100644
--- a/devel/uds/Makefile
+++ b/devel/uds/Makefile
@@ -7,29 +7,30 @@
#
PORTNAME= uds
-PORTVERSION= 0.9.5
+PORTVERSION= 1.0.6
CATEGORIES= devel
MASTER_SITES= http://frost.flewid.de/dist/
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
+USE_GCC= 3.1
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
pre-patch:
- @${PERL} -pi -e 's|\$$OPTFLAGS|\$$CFLAGS|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name 'Makefile.in' | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
's|install-data-hook|#install-data-hook|g ; \
s|-D_REENTRANT|-D_REENTRANT ${PTHREAD_CFLAGS}|g ; \
s|-lpthread|${PTHREAD_LIBS}|g'
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/uds
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/uds
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/uds/distinfo b/devel/uds/distinfo
index 7804b38a4543..eeab1cc7d7b5 100644
--- a/devel/uds/distinfo
+++ b/devel/uds/distinfo
@@ -1 +1 @@
-MD5 (uds-0.9.5.tar.gz) = acafc3167c4abbd1f2aac57865d4a0a6
+MD5 (uds-1.0.6.tar.gz) = a6996e317c4898deddc620a7e0a903da
diff --git a/devel/uds/files/patch-uds::alloc.cc b/devel/uds/files/patch-uds::alloc.cc
new file mode 100644
index 000000000000..15ca46404bb9
--- /dev/null
+++ b/devel/uds/files/patch-uds::alloc.cc
@@ -0,0 +1,33 @@
+--- uds/alloc.cc.orig Thu Sep 5 10:07:25 2002
++++ uds/alloc.cc Thu Sep 5 10:08:48 2002
+@@ -27,26 +27,26 @@
+
+
+ void*
+-operator new ( size_t size )
++operator new ( size_t size ) throw ( std::bad_alloc )
+ {
+ return uds::sentinel().Allocate( size );
+ }
+
+ void*
+-operator new [] ( size_t size )
++operator new [] ( size_t size ) throw ( std::bad_alloc )
+ {
+ return uds::sentinel().Allocate( size );
+ }
+
+ void
+-operator delete ( void* p )
++operator delete ( void* p ) throw ()
+ {
+ if ( p )
+ uds::sentinel().Release( p );
+ }
+
+ void
+-operator delete [] ( void* p )
++operator delete [] ( void* p ) throw ()
+ {
+ if ( p )
+ uds::sentinel().Release( p );
diff --git a/devel/uds/files/patch-uds::fdbuf.cc b/devel/uds/files/patch-uds::fdbuf.cc
new file mode 100644
index 000000000000..9a58debe0611
--- /dev/null
+++ b/devel/uds/files/patch-uds::fdbuf.cc
@@ -0,0 +1,10 @@
+--- uds/fdbuf.cc.orig Thu Sep 5 10:23:14 2002
++++ uds/fdbuf.cc Thu Sep 5 10:23:23 2002
+@@ -22,6 +22,7 @@
+
+ // includes
+
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <uds/stdexcpt.hh>
+ #include <uds/fdbuf.hh>
diff --git a/devel/uds/files/patch-uds::io_util.hh b/devel/uds/files/patch-uds::io_util.hh
new file mode 100644
index 000000000000..3e86e2906432
--- /dev/null
+++ b/devel/uds/files/patch-uds::io_util.hh
@@ -0,0 +1,47 @@
+--- uds/io_util.hh.orig Thu Sep 5 10:14:44 2002
++++ uds/io_util.hh Thu Sep 5 10:21:14 2002
+@@ -27,8 +27,7 @@
+
+ #include <uds/fdstream.hh>
+ #include <uds/stdexcpt.hh>
+-#include <byteswap.h>
+-#include <endian.h>
++#include <sys/endian.h>
+ #include <limits>
+ #include <unistd.h>
+
+@@ -45,33 +44,10 @@
+ end_little = 1234, ///< little-endian
+ end_big = 4321, ///< big-endian
+ end_net = end_big, ///< network byte order
+- end_host = __BYTE_ORDER ///< host byte order
++ end_host = BYTE_ORDER ///< host byte order
+ };
+
+ typedef unsigned endianess_t;
+-
+-
+-// the following bswap* functions need to be defined since
+-// gcc (at least 2.95.3) aborts with an error if the bswap_* macros are
+-// used inside of a template function and expand to assembly code.
+-
+-inline u_int16_t
+-bswap16( u_int16_t x )
+-{
+- return bswap_16( x );
+-}
+-
+-inline u_int32_t
+-bswap32( u_int32_t x )
+-{
+- return bswap_32( x );
+-}
+-
+-inline u_int64_t
+-bswap64( u_int64_t x )
+-{
+- return bswap_64( x );
+-}
+
+
+ /** changes the endianess of an integral type
diff --git a/devel/uds/files/patch-uds::packetsocket.cc b/devel/uds/files/patch-uds::packetsocket.cc
index 8a26a8db1e72..cbc67757ff7e 100644
--- a/devel/uds/files/patch-uds::packetsocket.cc
+++ b/devel/uds/files/patch-uds::packetsocket.cc
@@ -1,5 +1,5 @@
---- uds/packetsocket.cc.orig Wed May 9 15:24:10 2001
-+++ uds/packetsocket.cc Thu May 10 19:52:41 2001
+--- uds/packetsocket.cc.orig Thu Sep 5 02:36:31 2002
++++ uds/packetsocket.cc Thu Sep 5 02:37:03 2002
@@ -22,6 +22,7 @@
// includes
@@ -14,6 +14,6 @@
- hostent* he = gethostbyaddr( &si.sin_addr, sizeof( si.sin_addr ), AF_INET );
+ hostent* he = gethostbyaddr( (const char *)&si.sin_addr, sizeof( si.sin_addr ), AF_INET );
- clog<<he<<endl;
if ( he )
+ {
diff --git a/devel/uds/files/patch-uds::streamsocket.cc b/devel/uds/files/patch-uds::streamsocket.cc
index 8ed71219d640..af2615419f98 100644
--- a/devel/uds/files/patch-uds::streamsocket.cc
+++ b/devel/uds/files/patch-uds::streamsocket.cc
@@ -1,10 +1,10 @@
---- uds/streamsocket.cc.orig Thu May 10 19:59:24 2001
-+++ uds/streamsocket.cc Thu May 10 19:59:52 2001
+--- uds/streamsocket.cc.orig Thu Sep 5 02:38:14 2002
++++ uds/streamsocket.cc Thu Sep 5 02:38:24 2002
@@ -25,6 +25,7 @@
#include "config.h"
#ifdef HAVE_SOCKET
+#include <sys/types.h>
+ #include <sys/socket.h>
#include <netinet/in.h>
#include <sys/un.h>
- #include <uds/stdexcpt.hh>
diff --git a/devel/uds/pkg-plist b/devel/uds/pkg-plist
index 64a57b73616b..c01e2edf4ecc 100644
--- a/devel/uds/pkg-plist
+++ b/devel/uds/pkg-plist
@@ -10,10 +10,15 @@ include/uds/diagnose.hh
include/uds/errnodiag.hh
include/uds/exception.hh
include/uds/exit.hh
+include/uds/fdbuf.hh
+include/uds/fdstream.hh
include/uds/fileinfo.hh
+include/uds/filestream.hh
include/uds/flex_func.hh
include/uds/functional.hh
+include/uds/idep.hh
include/uds/init.hh
+include/uds/io_util.hh
include/uds/log.hh
include/uds/md5.h
include/uds/packetsocket.hh
@@ -25,20 +30,24 @@ include/uds/sockbase.hh
include/uds/stdexcpt.hh
include/uds/stl_ext.hh
include/uds/stl_util.hh
-include/uds/strstream.hh
+include/uds/str_util.hh
include/uds/streamsocket.hh
include/uds/swanpipe.hh
include/uds/sys_util.hh
include/uds/thread.hh
+include/uds/thread_nreent.hh
+include/uds/thread_reent.hh
include/uds/time.hh
include/uds/uds.hh
@dirrm include/uds
lib/libuds.a
+lib/libuds.la
lib/libuds.so
-lib/libuds.so.0
+lib/libuds.so.2
lib/libudsthread.a
+lib/libudsthread.la
lib/libudsthread.so
-lib/libudsthread.so.0
+lib/libudsthread.so.2
%%PORTDOCS%%share/doc/uds/config.html
%%PORTDOCS%%share/doc/uds/contributing.html
%%PORTDOCS%%share/doc/uds/download.html
@@ -46,14 +55,17 @@ lib/libudsthread.so.0
%%PORTDOCS%%share/doc/uds/history.html
%%PORTDOCS%%share/doc/uds/index.html
%%PORTDOCS%%share/doc/uds/relnotes.html
+%%PORTDOCS%%share/doc/uds/todo.html
%%PORTDOCS%%@dirrm share/doc/uds
share/uds/udsdeff.cc
@dirrm share/uds
share/aclocal/uds_base.m4
share/aclocal/uds_check.m4
+share/aclocal/uds_daemon.m4
share/aclocal/uds_debug.m4
share/aclocal/uds_def.m4
share/aclocal/uds_extra.m4
+share/aclocal/uds_flex.m4
share/aclocal/uds_opt.m4
share/aclocal/uds_paths.m4
share/aclocal/uds_profile.m4