aboutsummaryrefslogtreecommitdiff
path: root/devel/viewvc-devel/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-21 16:38:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-25 17:54:07 +0000
commit40843b1ccb8f70cca82dd115a71a46ae2a97a450 (patch)
treeeab403c2779e9e34988645d31bb779a42ff3be86 /devel/viewvc-devel/Makefile
parent455187b1323a74758a56578b37760fd554a9144a (diff)
downloadports-40843b1ccb8f70cca82dd115a71a46ae2a97a450.tar.gz
ports-40843b1ccb8f70cca82dd115a71a46ae2a97a450.zip
Mk/Uses/apache.mk: Refactor after removal of older versions
apache22 and apache25 had been removed a long time ago however the apache.mk file has never been refactored and is out of sync from the file Mk/bsd.default-versions.mk. These changes refactors the removals of the older versions. In addition: - Move some keywords like USE_APACHE, USE_APACHE_BUILD, USE_APACHE_RUN from SANITY_DEPRECATED to SANITY_UNSUPPORTED - Remove apache versions from ports Makefiles as currently there is only one available version in the tree. However the version checks are still valid and should work flawlessly whenever a new version is added. For example USES=apache:2.2+ are simply replaced with USES=apache. As currently there are no other versions available for test this could not be checked on it's own ground. - Update FOO_USE=APACHE=yes to FOO_USES=apache - Remove trailing whitespaces Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D38113
Diffstat (limited to 'devel/viewvc-devel/Makefile')
-rw-r--r--devel/viewvc-devel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/viewvc-devel/Makefile b/devel/viewvc-devel/Makefile
index e87671525480..2ec4881524fa 100644
--- a/devel/viewvc-devel/Makefile
+++ b/devel/viewvc-devel/Makefile
@@ -29,7 +29,7 @@ WEBSRV_DESC= Enable web server support
APMOD_DESC= depend on Apache module
MODWSGI_DESC= Add mod_wsgi to the list of package dependencies
-APACHE_USE= APACHE_RUN=24+
+APACHE_USES= apache:run
LIGHTTPD_RUN_DEPENDS= lighttpd:www/lighttpd
MODWSGI_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}${PYTHON_PKGNAMEPREFIX}mod_wsgi>=4.4.13:www/mod_wsgi4@${PY_FLAVOR}