aboutsummaryrefslogtreecommitdiff
path: root/devel/viewvc/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 02:30:16 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 02:30:16 +0000
commit19b0909c4f6186311f9ce435c12a529b803243ba (patch)
treeca08a70358c574551e85afdaeec23e2021821568 /devel/viewvc/Makefile
parent70e13fddac4dcd3458dd10a54d4bd0ed33596c8c (diff)
downloadports-19b0909c4f6186311f9ce435c12a529b803243ba.tar.gz
ports-19b0909c4f6186311f9ce435c12a529b803243ba.zip
- Change OPTION
o APACHE2 -> APACHE (WITH_APACHE2) is deprecated APACHE_PORT's value will be used - Bump PORTREVISION - Add UPDATING note
Notes
Notes: svn path=/head/; revision=234047
Diffstat (limited to 'devel/viewvc/Makefile')
-rw-r--r--devel/viewvc/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index 31a16ae252d5..715452f0aee6 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -7,18 +7,20 @@
PORTNAME= viewvc
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://viewvc.tigris.org/files/documents/3330/44050/
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Web-based Version Control Repository Browsing
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
-OPTIONS= SUBVERSION "use svn binding" on \
- APACHE2 "use Apache as webserver" on \
- LIGHTTPD "use Lighttp as webserver" off \
- MODPYTHON3 "enable mod_python3 support" off \
+OPTIONS=\
+ SUBVERSION "use svn binding" on \
+ APACHE "use ${APACHE_PORT} as webserver" on \
+ LIGHTTPD "use Lighttp as webserver" off \
+ MODPYTHON3 "enable mod_python3 support" off \
MYSQL "enable experimental MYSQL support" off
NO_BUILD= yes
@@ -41,7 +43,7 @@ USE_RC_SUBR= viewvc
RUN_DEPENDS+= ${PYTHON_LIBDIR}/site-packages/svn/__init__.py:${PORTSDIR}/devel/py-subversion
.endif
-.if defined (WITH_APACHE2)
+.if defined (WITH_APACHE)
USE_APACHE= 2.0+
.endif
@@ -61,15 +63,15 @@ RUN_DEPENDS+= ${PYTHON_LIBDIR}/site-packages/_mysql.so:${PORTSDIR}/databases/py-
.endif
pre-everything::
-.if defined(WITH_APACHE2) && defined(WITH_LIGHTTPD)
+.if defined(WITH_APACHE) && defined(WITH_LIGHTTPD)
@${ECHO_CMD} "It doesn't make sense to depend on Apache *and* LighHTTPD choose only one."
@${FALSE}
.endif
-.if defined(WITH_MODPYTHON3) && !defined(WITH_APACHE2) && defined(WITH_LIGHTTPD)
+.if defined(WITH_MODPYTHON3) && !defined(WITH_APACHE) && defined(WITH_LIGHTTPD)
@${ECHO_CMD} "mod_python3 needs Apache, please select Apache and deselect LighHTTPD"
@${FALSE}
-.elif defined(WITH_MODPYTHON3) && !defined(WITH_APACHE2)
+.elif defined(WITH_MODPYTHON3) && !defined(WITH_APACHE)
@${ECHO_CMD} "mod_python3 needs Apache, please select Apache"
@${FALSE}
.endif