aboutsummaryrefslogtreecommitdiff
path: root/devel/xmake
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-27 00:05:26 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-27 00:05:26 +0000
commit4f2432e801885ee7741ca55c97c18e947e830918 (patch)
treef2a6abaea6c07386395275cc53207095de021f57 /devel/xmake
parent8020017018ffb9105b01d6bbee14627e7e8a785a (diff)
downloadports-4f2432e801885ee7741ca55c97c18e947e830918.tar.gz
ports-4f2432e801885ee7741ca55c97c18e947e830918.zip
Upgrade to version 1.05.
PR: 7331 Submitted by: Garrett A. Wollman <wollman@lcs.mit.edu>
Notes
Notes: svn path=/head/; revision=12142
Diffstat (limited to 'devel/xmake')
-rw-r--r--devel/xmake/Makefile6
-rw-r--r--devel/xmake/distinfo2
-rw-r--r--devel/xmake/files/patch-aa71
3 files changed, 32 insertions, 47 deletions
diff --git a/devel/xmake/Makefile b/devel/xmake/Makefile
index 9d5701dd4204..9876e2c05ad4 100644
--- a/devel/xmake/Makefile
+++ b/devel/xmake/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: xmake
-# Version required: 1.01
+# Version required: 1.05
# Date created: 28 March 1997
# Whom: dlowe
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/05/07 20:58:50 max Exp $
#
-DISTNAME= xmake-1.01
+DISTNAME= xmake-1.05
CATEGORIES= devel
MASTER_SITES= http://www.backplane.com/xmake/ \
ftp://atari.saturn5.com/pub/dlowe/
diff --git a/devel/xmake/distinfo b/devel/xmake/distinfo
index 75bb5d06e13f..ad2e976b93a3 100644
--- a/devel/xmake/distinfo
+++ b/devel/xmake/distinfo
@@ -1 +1 @@
-MD5 (xmake-1.01.tgz) = 7fb2ebb2c32e3baab4ea22bf7d37bcd6
+MD5 (xmake-1.05.tgz) = 1563ca7d04d2df79bfa9a5c7db532aa7
diff --git a/devel/xmake/files/patch-aa b/devel/xmake/files/patch-aa
index 034ee7514f42..7d10dece1820 100644
--- a/devel/xmake/files/patch-aa
+++ b/devel/xmake/files/patch-aa
@@ -1,43 +1,28 @@
-*** Makefile.orig Thu Feb 6 08:00:00 1997
---- Makefile Mon Apr 28 13:47:27 1997
-***************
-*** 1,11 ****
-
- SRCS= include.c list.c main.c subs.c var.c wild.c
- OBJS= include.o list.o main.o subs.o var.o wild.o
-! CFLAGS= -g -O2 -Wall -Wstrict-prototypes
- LFLAGS=
- EXE= xmake
-! IBDIR= /usr/local/bin
-! IMDIR= /usr/local/man/man1
-
- all: $(EXE)
-
---- 1,12 ----
-
- SRCS= include.c list.c main.c subs.c var.c wild.c
- OBJS= include.o list.o main.o subs.o var.o wild.o
-! CFLAGS= -O2 -Wall
- LFLAGS=
- EXE= xmake
-! PREFIX?= /usr/local
-! IBDIR= ${PREFIX}/bin
-! IMDIR= ${PREFIX}/man/man1
-
- all: $(EXE)
-
-***************
-*** 15,20 ****
- clean:
- rm -f $(OBJS) $(EXE)
-
-! install: all
-! install -c -s -m 755 $(EXE) $(IBDIR)/$(EXE)
-!
---- 16,21 ----
- clean:
- rm -f $(OBJS) $(EXE)
-
-! install:
-! install -c -s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} $(EXE) $(IBDIR)
-! install -c -o ${MANOWN} -g ${MANGRP} -m ${MANMODE} xmake.1 $(IMDIR)
+--- Makefile.orig Sun Jul 26 16:11:40 1998
++++ Makefile Sun Jul 26 16:14:35 1998
+@@ -1,11 +1,12 @@
+
+ SRCS= include.c list.c main.c subs.c var.c wild.c
+ OBJS= include.o list.o main.o subs.o var.o wild.o
+-CFLAGS= -g -O2 -Wall -Wstrict-prototypes
++CFLAGS= -O2 -Wall
+ LFLAGS=
+ EXE= xmake
+-IBDIR= /usr/local/bin
+-IMDIR= /usr/local/man/man1
++PREFIX?= /usr/local
++IBDIR= $(PREFIX)/bin
++IMDIR= $(PREFIX)/man/man1
+ CC= cc
+
+ all: $(EXE)
+@@ -16,6 +17,6 @@
+ clean:
+ rm -f $(OBJS) $(EXE)
+
+-install: all
+- install -c -s -m 755 $(EXE) $(IBDIR)/$(EXE)
+-
++install:
++ install -c -s -o $(BINOWN) -g $(BINGRP) -m $(BINMODE) $(EXE) $(IBDIR)
++ install -c -o $(MANOWN) -g $(MANGRP) -m $(MANMODE) xmake.1 $(IMDIR)