aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTim Vanderhoek <hoek@FreeBSD.org>1998-07-30 15:15:35 +0000
committerTim Vanderhoek <hoek@FreeBSD.org>1998-07-30 15:15:35 +0000
commit0399bdd836c04a21dd844ce7a36c437bfeee8077 (patch)
tree30acbd85618ebf41bdeccd5e4444f9e0a56fbf11 /devel
parent2775e81d33e7b9ffbf69a14be14d5875e63d0832 (diff)
downloadports-0399bdd836c04a21dd844ce7a36c437bfeee8077.tar.gz
ports-0399bdd836c04a21dd844ce7a36c437bfeee8077.zip
Clig, a program to automatically generate usage(), manpage, and commandline
argument processor.
Notes
Notes: svn path=/head/; revision=12220
Diffstat (limited to 'devel')
-rw-r--r--devel/clig/Makefile37
-rw-r--r--devel/clig/distinfo1
-rw-r--r--devel/clig/pkg-comment1
-rw-r--r--devel/clig/pkg-descr12
-rw-r--r--devel/clig/pkg-plist35
5 files changed, 86 insertions, 0 deletions
diff --git a/devel/clig/Makefile b/devel/clig/Makefile
new file mode 100644
index 000000000000..d42bcac4135e
--- /dev/null
+++ b/devel/clig/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: clig
+# Version required: 1.0.2
+# Date created: 27 July 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id$
+#
+
+DISTNAME= clig-1.0.2
+CATEGORIES= devel tcl80
+MASTER_SITES= http://wsd.iitb.fhg.de/~kir/clighome/
+
+MAINTAINER= billf@chc-chimes.com
+
+# This should work with any version of tcl. See also ${MAKE_ENV}.
+BUILD_DEPENDS= ${PREFIX}/bin/tclsh8.0:${PORTSDIR}/lang/tcl80
+RUN_DEPENDS= ${PREFIX}/bin/tclsh8.0:${PORTSDIR}/lang/tcl80
+
+MAN1= clig.1
+
+NO_BUILD= yes
+MAKEFILE= makefile
+MAKE_ENV= tclsh=${PREFIX}/bin/tclsh8.0
+
+do-patch:
+ chmod a+r ${WRKSRC}/CHANGES
+ ${MV} ${WRKSRC}/makefile ${WRKSRC}/makefile.orig
+ ${SED} -e 's#prefix =~/tools#prefix =${PREFIX}/share#' \
+ -e 's#LROOT =~/tools#LROOT =${PREFIX}#' \
+ -e 's#DOCDIR =$$(prefix)/doc#DOCDIR =${PREFIX}/share/doc/clig#' \
+ -e 's#MANDIR =$$(prefix)#MANDIR =${MANPREFIX}#' \
+ ${WRKSRC}/makefile.orig > ${WRKSRC}/makefile
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/WISHLIST ${PREFIX}/share/doc/clig
+
+.include <bsd.port.mk>
diff --git a/devel/clig/distinfo b/devel/clig/distinfo
new file mode 100644
index 000000000000..5816749cbe74
--- /dev/null
+++ b/devel/clig/distinfo
@@ -0,0 +1 @@
+MD5 (clig-1.0.2.tar.gz) = 24accc741b2472fdc5ad5b4df7cef56a
diff --git a/devel/clig/pkg-comment b/devel/clig/pkg-comment
new file mode 100644
index 000000000000..dc7ec69c3675
--- /dev/null
+++ b/devel/clig/pkg-comment
@@ -0,0 +1 @@
+Auto-generate an (argc, argv) processor, usage message, and manpage.
diff --git a/devel/clig/pkg-descr b/devel/clig/pkg-descr
new file mode 100644
index 000000000000..d105709a6e66
--- /dev/null
+++ b/devel/clig/pkg-descr
@@ -0,0 +1,12 @@
+Clig generates C code to take apart the typical command-line arguments
+given to a C program. Input to clig is a simple description file that
+specifies the name and number of options, their type (Flag, String,
+Float, Int) and permissable range, and which options are mandatory. From
+this, clig will generate self-contained C code to include in your program,
+a usage message, and a manual page skeleton.
+
+Clig does a lot more than getopt!
+
+http://wsd.iitb.fhg.de/~kir/clighome
+
+- Bill Fumerola <billf@chc-chimes.com>
diff --git a/devel/clig/pkg-plist b/devel/clig/pkg-plist
new file mode 100644
index 000000000000..be2bebde2043
--- /dev/null
+++ b/devel/clig/pkg-plist
@@ -0,0 +1,35 @@
+bin/clig
+man/man1/clig.1.gz
+share/clig-1.0.2/bin/clig
+share/clig-1.0.2/tcl/genCheckMandatory.tcl
+share/clig-1.0.2/tcl/genStruct.tcl
+share/clig-1.0.2/tcl/genShowOptionValues.tcl
+share/clig-1.0.2/tcl/genParse.tcl
+share/clig-1.0.2/tcl/genMan.tcl
+share/clig-1.0.2/tcl/genDotH.tcl
+share/clig-1.0.2/tcl/genDotC.tcl
+share/clig-1.0.2/tcl/genDefault.tcl
+share/clig-1.0.2/tcl/genUsage.tcl
+share/clig-1.0.2/c/catArgv.c
+share/clig-1.0.2/c/missingErr.c
+share/clig-1.0.2/c/getStringOpts.c
+share/clig-1.0.2/c/getStringOpt.c
+share/clig-1.0.2/c/getIntOpts.c
+share/clig-1.0.2/c/getIntOpt.c
+share/clig-1.0.2/c/getFloatOpts.c
+share/clig-1.0.2/c/getFloatOpt.c
+share/clig-1.0.2/c/checkIntLower.c
+share/clig-1.0.2/c/checkIntHigher.c
+share/clig-1.0.2/c/checkFloatLower.c
+share/clig-1.0.2/c/checkFloatHigher.c
+share/clig-1.0.2/c/template.man
+share/doc/clig/makefile
+share/doc/clig/cmdline.cli
+share/doc/clig/main.c
+share/doc/clig/CHANGES
+share/doc/clig/WISHLIST
+@dirrm share/clig-1.0.2/bin
+@dirrm share/doc/clig
+@dirrm share/clig-1.0.2/c
+@dirrm share/clig-1.0.2/tcl
+@dirrm share/clig-1.0.2