aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorGian-Simon Purkert <gspurki@gmail.com>2021-11-10 06:30:00 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-11-11 12:07:10 +0000
commit04089babef24718ba873fe105ec943388d3f37f3 (patch)
tree52eb52ecdae00d2356ad5d1188108e76d385f094 /devel
parentc3640a17bdf93772bf9dad37abb626c803dbc5b9 (diff)
downloadports-04089babef24718ba873fe105ec943388d3f37f3.tar.gz
ports-04089babef24718ba873fe105ec943388d3f37f3.zip
devel/crc32c: Update to 1.1.2
ChangeLog: https://github.com/google/crc32c/commits/1.1.2 PR: 259271 Reported by: gspurki@gmail.com Approved by: amzo1337@gmail.com (maintainer timeout > 3 weeks)
Diffstat (limited to 'devel')
-rw-r--r--devel/crc32c/Makefile2
-rw-r--r--devel/crc32c/distinfo6
-rw-r--r--devel/crc32c/files/patch-src_crc32c__read__le.h25
3 files changed, 4 insertions, 29 deletions
diff --git a/devel/crc32c/Makefile b/devel/crc32c/Makefile
index d33f59f6cc0a..00ac54e27e2e 100644
--- a/devel/crc32c/Makefile
+++ b/devel/crc32c/Makefile
@@ -1,5 +1,5 @@
PORTNAME= crc32c
-DISTVERSION= 1.1.1
+DISTVERSION= 1.1.2
CATEGORIES= devel
MAINTAINER= amzo1337@gmail.com
diff --git a/devel/crc32c/distinfo b/devel/crc32c/distinfo
index 8393cf0b6f7e..3b2b2e8197c3 100644
--- a/devel/crc32c/distinfo
+++ b/devel/crc32c/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575620103
-SHA256 (google-crc32c-1.1.1_GH0.tar.gz) = a6533f45b1670b5d59b38a514d82b09c6fb70cc1050467220216335e873074e8
-SIZE (google-crc32c-1.1.1_GH0.tar.gz) = 29829
+TIMESTAMP = 1634651489
+SHA256 (google-crc32c-1.1.2_GH0.tar.gz) = ac07840513072b7fcebda6e821068aa04889018f24e10e46181068fb214d7e56
+SIZE (google-crc32c-1.1.2_GH0.tar.gz) = 29819
diff --git a/devel/crc32c/files/patch-src_crc32c__read__le.h b/devel/crc32c/files/patch-src_crc32c__read__le.h
deleted file mode 100644
index 825ccdae5ef4..000000000000
--- a/devel/crc32c/files/patch-src_crc32c__read__le.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/crc32c_read_le.h.orig 2019-07-24 07:21:23 UTC
-+++ src/crc32c_read_le.h
-@@ -30,14 +30,14 @@ inline uint32_t ReadUint32LE(const uint8_t* buffer) {
- // Reads a little-endian 64-bit integer from a 64-bit-aligned buffer.
- inline uint64_t ReadUint64LE(const uint8_t* buffer) {
- #if BYTE_ORDER_BIG_ENDIAN
-- return ((static_cast<uint32_t>(static_cast<uint8_t>(buffer[0]))) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[1])) << 8) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[2])) << 16) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[3])) << 24) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[4])) << 32) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[5])) << 40) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[6])) << 48) |
-- (static_cast<uint32_t>(static_cast<uint8_t>(buffer[7])) << 56));
-+ return ((static_cast<uint64_t>(static_cast<uint8_t>(buffer[0]))) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[1])) << 8) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[2])) << 16) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[3])) << 24) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[4])) << 32) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[5])) << 40) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[6])) << 48) |
-+ (static_cast<uint64_t>(static_cast<uint8_t>(buffer[7])) << 56));
- #else // !BYTE_ORDER_BIG_ENDIAN
- uint64_t result;
- // This should be optimized to a single instruction.