aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
commit13fb0b92a29536c74fd1cea5b5e8e7fb8705be98 (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /devel
parent52a39feebd3a360c0a4633697006081ae2024197 (diff)
downloadports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.tar.gz
ports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=472160
Diffstat (limited to 'devel')
-rw-r--r--devel/aegis/Makefile2
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/codequery/Makefile2
-rw-r--r--devel/geany/Makefile4
-rw-r--r--devel/liborcus/Makefile2
-rw-r--r--devel/oclgrind/Makefile7
-rw-r--r--devel/woff2/Makefile2
7 files changed, 9 insertions, 12 deletions
diff --git a/devel/aegis/Makefile b/devel/aegis/Makefile
index 462f8bbdf58a..2ea56659bd65 100644
--- a/devel/aegis/Makefile
+++ b/devel/aegis/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libcurl.so:ftp/curl
RUN_DEPENDS= tkdiff:textproc/tkdiff
-USES= gettext ghostscript groff perl5 tk
+USES= compiler:c++0x gettext ghostscript groff perl5 tk
USE_GNOME= libxml2
USE_GCC= any
GNU_CONFIGURE= yes
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index a5a38603e95c..724bcdfefa6c 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -13,7 +13,7 @@ COMMENT= Source code indenter and formatter for C, C++, C\#, and Java
LICENSE= MIT
LICENSE_FILE= ${WRKDIR}/astyle/LICENSE.md
-USES= compiler dos2unix gmake
+USES= compiler:c++11-lang dos2unix gmake
ALL_TARGET= astyle
DOS2UNIX_GLOB= *.ini
diff --git a/devel/codequery/Makefile b/devel/codequery/Makefile
index 3cc1a150e350..ffefda493b19 100644
--- a/devel/codequery/Makefile
+++ b/devel/codequery/Makefile
@@ -14,7 +14,7 @@ LICENSE_COMB= multi
LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE.md
LICENSE_FILE_MIT= ${WRKSRC}/querylib/README.txt
-USES= cmake ninja sqlite
+USES= cmake compiler:c++11-lang ninja sqlite
USE_GITHUB= yes
GH_ACCOUNT= ruben2020
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index 053b119dfedf..e22fb1c38c0c 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -15,11 +15,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake libtool \
+ localbase pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_GNOME= cairo gtk20 intltool
-USES= desktop-file-utils gettext-tools gmake libtool \
- localbase pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/devel/liborcus/Makefile b/devel/liborcus/Makefile
index 7bdef4d290e7..64a05d3bfe31 100644
--- a/devel/liborcus/Makefile
+++ b/devel/liborcus/Makefile
@@ -14,8 +14,6 @@ LICENSE= MPL20
BUILD_DEPENDS= ${LOCALBASE}/include/mdds-1.2/mdds/global.hpp:devel/mdds
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-BROKEN_powerpc64= fails to configure: checking for the Boost program_options library... no
-
GNU_CONFIGURE= yes
USES= compiler:c++11-lib libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
diff --git a/devel/oclgrind/Makefile b/devel/oclgrind/Makefile
index 13a398d35da5..25eedcda6363 100644
--- a/devel/oclgrind/Makefile
+++ b/devel/oclgrind/Makefile
@@ -12,20 +12,19 @@ COMMENT= SPIR interpreter and virtual OpenCL device simulator
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_FreeBSD_10= oclgrind is only supported on FreeBSD 11.0 and newer, crashes LLVM 3.4
+
BUILD_DEPENDS= opencl>=0:devel/opencl \
llvm-config50:devel/llvm50
LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
-BROKEN_FreeBSD_10= oclgrind is only supported on FreeBSD 11.0 and newer, crashes LLVM 3.4
-
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= jrprice
GH_PROJECT= Oclgrind
GH_TAGNAME= e99899d
-
USE_LDCONFIG= yes
-USES= cmake
CMAKE_ARGS+= -DLLVM_DIR=${LOCALBASE}/llvm50/share/llvm/cmake
diff --git a/devel/woff2/Makefile b/devel/woff2/Makefile
index 6830b1c62e7b..27720ce6744d 100644
--- a/devel/woff2/Makefile
+++ b/devel/woff2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libbrotlidec.so:archivers/brotli
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lib
USE_GITHUB= yes
GH_ACCOUNT= google
USE_LDCONFIG= yes