aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2021-03-15 21:04:56 +0000
committerJuraj Lutter <otis@FreeBSD.org>2021-03-15 21:04:56 +0000
commit21fa5f77735d46e445d744019d39682b513214d9 (patch)
treec058b515b980b6481d7f98baf3c0e1807d52432c /devel
parent8ea2c89603c2c03050f7fe60bd934356c203d751 (diff)
downloadports-21fa5f77735d46e445d744019d39682b513214d9.tar.gz
ports-21fa5f77735d46e445d744019d39682b513214d9.zip
Add port: devel/node-nan: A Native Abstractions for Node.js.
Reviewed by: osa (mentor) Approved by: osa (mentor) Differential Revision: https://reviews.freebsd.org/D29256
Notes
Notes: svn path=/head/; revision=568509
Diffstat (limited to 'devel')
-rw-r--r--devel/node-nan/Makefile26
-rw-r--r--devel/node-nan/distinfo3
-rw-r--r--devel/node-nan/pkg-descr3
-rw-r--r--devel/node-nan/pkg-plist60
4 files changed, 92 insertions, 0 deletions
diff --git a/devel/node-nan/Makefile b/devel/node-nan/Makefile
new file mode 100644
index 000000000000..43f26fa63a32
--- /dev/null
+++ b/devel/node-nan/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= nan
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.14.2
+CATEGORIES= devel
+PKGNAMEPREFIX= node-
+
+MAINTAINER= otis@FreeBSD.org
+COMMENT= Native Abstractions for Node.js
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= nodejs
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/node_modules/nan
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${PREFIX}/lib/node_modules/nan \
+ "! ( -name \.* -or -path *\/test\/* -or -name test )"
+
+.include <bsd.port.mk>
diff --git a/devel/node-nan/distinfo b/devel/node-nan/distinfo
new file mode 100644
index 000000000000..5729bfb21152
--- /dev/null
+++ b/devel/node-nan/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615675656
+SHA256 (nodejs-nan-v2.14.2_GH0.tar.gz) = 26dce4db0194c4a7b51b33d0324f3cf36eb67be49dc43a043e0a2dffc9dcdd6d
+SIZE (nodejs-nan-v2.14.2_GH0.tar.gz) = 178650
diff --git a/devel/node-nan/pkg-descr b/devel/node-nan/pkg-descr
new file mode 100644
index 000000000000..e8b97d83144b
--- /dev/null
+++ b/devel/node-nan/pkg-descr
@@ -0,0 +1,3 @@
+Native Abstractions for Node.js.
+
+WWW: https://github.com/nodejs/nan
diff --git a/devel/node-nan/pkg-plist b/devel/node-nan/pkg-plist
new file mode 100644
index 000000000000..babf796e742f
--- /dev/null
+++ b/devel/node-nan/pkg-plist
@@ -0,0 +1,60 @@
+lib/node_modules/nan/CHANGELOG.md
+lib/node_modules/nan/LICENSE.md
+lib/node_modules/nan/Makefile
+lib/node_modules/nan/README.md
+lib/node_modules/nan/appveyor.yml
+lib/node_modules/nan/cpplint.py
+lib/node_modules/nan/doc/asyncworker.md
+lib/node_modules/nan/doc/buffers.md
+lib/node_modules/nan/doc/callback.md
+lib/node_modules/nan/doc/converters.md
+lib/node_modules/nan/doc/errors.md
+lib/node_modules/nan/doc/json.md
+lib/node_modules/nan/doc/maybe_types.md
+lib/node_modules/nan/doc/methods.md
+lib/node_modules/nan/doc/new.md
+lib/node_modules/nan/doc/node_misc.md
+lib/node_modules/nan/doc/object_wrappers.md
+lib/node_modules/nan/doc/persistent.md
+lib/node_modules/nan/doc/scopes.md
+lib/node_modules/nan/doc/script.md
+lib/node_modules/nan/doc/string_bytes.md
+lib/node_modules/nan/doc/v8_internals.md
+lib/node_modules/nan/doc/v8_misc.md
+lib/node_modules/nan/examples/async_pi_estimate/README.md
+lib/node_modules/nan/examples/async_pi_estimate/addon.cc
+lib/node_modules/nan/examples/async_pi_estimate/addon.js
+lib/node_modules/nan/examples/async_pi_estimate/async.cc
+lib/node_modules/nan/examples/async_pi_estimate/async.h
+lib/node_modules/nan/examples/async_pi_estimate/binding.gyp
+lib/node_modules/nan/examples/async_pi_estimate/package.json
+lib/node_modules/nan/examples/async_pi_estimate/pi_est.cc
+lib/node_modules/nan/examples/async_pi_estimate/pi_est.h
+lib/node_modules/nan/examples/async_pi_estimate/sync.cc
+lib/node_modules/nan/examples/async_pi_estimate/sync.h
+lib/node_modules/nan/include_dirs.js
+lib/node_modules/nan/nan.h
+lib/node_modules/nan/nan_callbacks.h
+lib/node_modules/nan/nan_callbacks_12_inl.h
+lib/node_modules/nan/nan_callbacks_pre_12_inl.h
+lib/node_modules/nan/nan_converters.h
+lib/node_modules/nan/nan_converters_43_inl.h
+lib/node_modules/nan/nan_converters_pre_43_inl.h
+lib/node_modules/nan/nan_define_own_property_helper.h
+lib/node_modules/nan/nan_implementation_12_inl.h
+lib/node_modules/nan/nan_implementation_pre_12_inl.h
+lib/node_modules/nan/nan_json.h
+lib/node_modules/nan/nan_maybe_43_inl.h
+lib/node_modules/nan/nan_maybe_pre_43_inl.h
+lib/node_modules/nan/nan_new.h
+lib/node_modules/nan/nan_object_wrap.h
+lib/node_modules/nan/nan_persistent_12_inl.h
+lib/node_modules/nan/nan_persistent_pre_12_inl.h
+lib/node_modules/nan/nan_private.h
+lib/node_modules/nan/nan_string_bytes.h
+lib/node_modules/nan/nan_typedarray_contents.h
+lib/node_modules/nan/nan_weak.h
+lib/node_modules/nan/package.json
+lib/node_modules/nan/tools/1to2.js
+lib/node_modules/nan/tools/README.md
+lib/node_modules/nan/tools/package.json