aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-07-29 19:22:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-09 19:47:44 +0000
commit3386640541634bf00c85a63eb409dd1262296291 (patch)
treefce788764f83649ec9428a018263f07b2f911417 /devel
parent80eadab44ca19eb18e7d49dc6035a0757e3f7436 (diff)
downloadports-3386640541634bf00c85a63eb409dd1262296291.tar.gz
ports-3386640541634bf00c85a63eb409dd1262296291.zip
devel/vc-intrinsics: add new port
VC Intrinsics project contains a set of new intrinsics on top of core LLVM IR instructions that represent SIMD semantics of a program targeting GPU. https://github.com/intel/vc-intrinsics
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/vc-intrinsics/Makefile35
-rw-r--r--devel/vc-intrinsics/distinfo3
-rw-r--r--devel/vc-intrinsics/pkg-descr5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 34c29bebb39f..df746d93be4b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7036,6 +7036,7 @@
SUBDIR += varconf
SUBDIR += vasm
SUBDIR += vc
+ SUBDIR += vc-intrinsics
SUBDIR += vcglib
SUBDIR += vera++
SUBDIR += vexcl
diff --git a/devel/vc-intrinsics/Makefile b/devel/vc-intrinsics/Makefile
new file mode 100644
index 000000000000..2fc2c61746ab
--- /dev/null
+++ b/devel/vc-intrinsics/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= vc-intrinsics
+PORTVERSION= s20210730
+CATEGORIES= devel
+PKGNAMESUFFIX= -${FLAVOR}
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= LLVM intrinsics for SIMD on GPU
+
+LICENSE= MIT
+
+FLAVORS= ${12 11 10 90 80 70:L:S/^/llvm/}
+
+BUILD_DEPENDS= ${FLAVOR}>0:devel/${FLAVOR}
+
+USES= cmake compiler:c++11-lib
+USE_GITHUB= yes
+GH_ACCOUNT= intel
+GH_TAGNAME= 05d3f3d
+CMAKE_ARGS= -DLLVM_DIR:PATH="${LOCALBASE}/${FLAVOR}"
+CMAKE_INSTALL_PREFIX= ${PREFIX}/${FLAVOR}
+_PLIST_FILES= include/llvm/GenXIntrinsics/GenXIntrOpts.h \
+ include/llvm/GenXIntrinsics/GenXIntrinsicDescription.gen \
+ include/llvm/GenXIntrinsics/GenXIntrinsicInst.h \
+ include/llvm/GenXIntrinsics/GenXIntrinsics.h \
+ include/llvm/GenXIntrinsics/GenXMetadata.h \
+ include/llvm/GenXIntrinsics/GenXSPIRVReaderAdaptor.h \
+ include/llvm/GenXIntrinsics/GenXSPIRVWriterAdaptor.h \
+ include/llvm/GenXIntrinsics/GenXSimdCFLowering.h \
+ include/llvm/GenXIntrinsics/GenXVersion.h \
+ lib/cmake/LLVMGenXIntrinsics/LLVMGenXIntrinsicsConfig-%%CMAKE_BUILD_TYPE%%.cmake \
+ lib/cmake/LLVMGenXIntrinsics/LLVMGenXIntrinsicsConfig.cmake \
+ lib/libLLVMGenXIntrinsics.a
+PLIST_FILES= ${_PLIST_FILES:S,^,${FLAVOR}/,}
+
+.include <bsd.port.mk>
diff --git a/devel/vc-intrinsics/distinfo b/devel/vc-intrinsics/distinfo
new file mode 100644
index 000000000000..7f6afe2a8395
--- /dev/null
+++ b/devel/vc-intrinsics/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627586549
+SHA256 (intel-vc-intrinsics-s20210730-05d3f3d_GH0.tar.gz) = 7d3df322a91ea9d95ef606b9d5a2580d6deb426f779ba921ae3a799a5e642c4f
+SIZE (intel-vc-intrinsics-s20210730-05d3f3d_GH0.tar.gz) = 126560
diff --git a/devel/vc-intrinsics/pkg-descr b/devel/vc-intrinsics/pkg-descr
new file mode 100644
index 000000000000..5dd07512a175
--- /dev/null
+++ b/devel/vc-intrinsics/pkg-descr
@@ -0,0 +1,5 @@
+VC Intrinsics project contains a set of new intrinsics on top of core
+LLVM IR instructions that represent SIMD semantics of a program
+targeting GPU.
+
+WWW: https://github.com/intel/vc-intrinsics