aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-01 22:31:14 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-01 22:31:14 +0000
commit56035a0de7320669dd46adb0f74563aa0db897fb (patch)
treeb766533687e0facff81941fde972ff138e23b00e /devel
parentb27613ab46707d52777b1f4c667d73760024adcb (diff)
downloadports-56035a0de7320669dd46adb0f74563aa0db897fb.tar.gz
ports-56035a0de7320669dd46adb0f74563aa0db897fb.zip
Only REINPLACE the needed files, making it less likely that Makefile.in gets
older than Makefile.am
Notes
Notes: svn path=/head/; revision=373725
Diffstat (limited to 'devel')
-rw-r--r--devel/ode/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index f7e18479509a..ae44bd15b7d3 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -49,8 +49,8 @@ post-patch:
@${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
-e '/^DEFAULT_INCLUDES/ s|$$| -I$$(top_builddir)/include|' \
-e '/CFLAGS/ s|-O[12]||'
- @${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
- -i "" -e 's|<malloc.h>|<stdlib.h>|g'
+ @${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g' \
+ ${WRKSRC}/build/config-default.h ${WRKSRC}/ou/src/ou/malloc.cpp
post-install:
${SED} -e '/PACKAGE/ s|^|//|; /VERSION/ s|^|//|' ${WRKSRC}/ode/src/config.h \