aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-04-05 04:52:36 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-04-05 04:52:36 +0000
commit5ab881a5d9e41945e066f0332b891e12e66d0841 (patch)
tree1407eca99be95ddb9e55faff3e70910850182df9 /devel
parentb223666a533d6e9084dba015d034ffcf7b72a3b3 (diff)
downloadports-5ab881a5d9e41945e066f0332b891e12e66d0841.tar.gz
ports-5ab881a5d9e41945e066f0332b891e12e66d0841.zip
- Migrate Mk/bsd.fpc.mk to Mk/Uses/fpc.mk
- Convert all fpc-based ports to USES=fpc PR: 227210 Reviewed by: portmgr Approved by: portmgr Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D14617
Notes
Notes: svn path=/head/; revision=466532
Diffstat (limited to 'devel')
-rw-r--r--devel/fpc-bfd/Makefile2
-rw-r--r--devel/fpc-dbus/Makefile2
-rw-r--r--devel/fpc-fcl-async/Makefile2
-rw-r--r--devel/fpc-fcl-base/Makefile1
-rw-r--r--devel/fpc-fcl-db/Makefile1
-rw-r--r--devel/fpc-fcl-extra/Makefile1
-rw-r--r--devel/fpc-fcl-fpcunit/Makefile1
-rw-r--r--devel/fpc-fcl-image/Makefile1
-rw-r--r--devel/fpc-fcl-js/Makefile3
-rw-r--r--devel/fpc-fcl-json/Makefile3
-rw-r--r--devel/fpc-fcl-net/Makefile1
-rw-r--r--devel/fpc-fcl-passrc/Makefile3
-rw-r--r--devel/fpc-fcl-pdf/Makefile3
-rw-r--r--devel/fpc-fcl-registry/Makefile1
-rw-r--r--devel/fpc-fcl-res/Makefile2
-rw-r--r--devel/fpc-fcl-sdo/Makefile1
-rw-r--r--devel/fpc-fcl-sound/Makefile1
-rw-r--r--devel/fpc-fcl-stl/Makefile4
-rw-r--r--devel/fpc-fcl-web/Makefile3
-rw-r--r--devel/fpc-fcl-xml/Makefile2
-rw-r--r--devel/fpc-fppkg/Makefile1
-rw-r--r--devel/fpc-fv/Makefile1
-rw-r--r--devel/fpc-gdbint/Makefile2
-rw-r--r--devel/fpc-newt/Makefile2
-rw-r--r--devel/fpc-pthreads/Makefile2
-rw-r--r--devel/fpc-regexpr/Makefile1
-rw-r--r--devel/fpc-sdl/Makefile1
-rw-r--r--devel/fpc-symbolic/Makefile2
-rw-r--r--devel/fpc-zlib/Makefile2
29 files changed, 35 insertions, 17 deletions
diff --git a/devel/fpc-bfd/Makefile b/devel/fpc-bfd/Makefile
index 5e416497619e..357d549bbe05 100644
--- a/devel/fpc-bfd/Makefile
+++ b/devel/fpc-bfd/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -bfd
COMMENT= Free Pascal interface for the GNU Binary Format description
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-dbus/Makefile b/devel/fpc-dbus/Makefile
index 31c94642e74e..9f9fdca2779c 100644
--- a/devel/fpc-dbus/Makefile
+++ b/devel/fpc-dbus/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -dbus
COMMENT= Free Pascal interface to dbus library
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fcl-async/Makefile b/devel/fpc-fcl-async/Makefile
index d5e4775af266..5b76d24713fb 100644
--- a/devel/fpc-fcl-async/Makefile
+++ b/devel/fpc-fcl-async/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -fcl-async
COMMENT= Free Pascal asynchronous event management (FCL)
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fcl-base/Makefile b/devel/fpc-fcl-base/Makefile
index a47128effb08..da17946c2fbb 100644
--- a/devel/fpc-fcl-base/Makefile
+++ b/devel/fpc-fcl-base/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-base
COMMENT= Free Pascal Component Library base
+USES= fpc
USE_FPC= fcl-res rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-db/Makefile b/devel/fpc-fcl-db/Makefile
index dea37345eb0f..10b11ec0b84c 100644
--- a/devel/fpc-fcl-db/Makefile
+++ b/devel/fpc-fcl-db/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-db
COMMENT= Free Pascal Database Library (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-xml rtl-objpas rtl-extra ibase mysql odbc \
oracle postgres sqlite dblib pxlib fcl-json
diff --git a/devel/fpc-fcl-extra/Makefile b/devel/fpc-fcl-extra/Makefile
index 787554cf472b..ec0e3aea6393 100644
--- a/devel/fpc-fcl-extra/Makefile
+++ b/devel/fpc-fcl-extra/Makefile
@@ -5,6 +5,7 @@ PKGNAMESUFFIX= -fcl-extra
COMMENT= Free Pascal extra libraries (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-res rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-fpcunit/Makefile b/devel/fpc-fcl-fpcunit/Makefile
index 3dafc8971d63..e0ca0f13d0e0 100644
--- a/devel/fpc-fcl-fpcunit/Makefile
+++ b/devel/fpc-fcl-fpcunit/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-fpcunit
COMMENT= Free Pascal unit testing library (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-xml
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-image/Makefile b/devel/fpc-fcl-image/Makefile
index f6be2bb4f0a2..3e90d0dd9ef7 100644
--- a/devel/fpc-fcl-image/Makefile
+++ b/devel/fpc-fcl-image/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-image
COMMENT= Free Pascal image loading and conversion libraries (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-res pasjpeg rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-js/Makefile b/devel/fpc-fcl-js/Makefile
index 4596f375464e..40f56f5433db 100644
--- a/devel/fpc-fcl-js/Makefile
+++ b/devel/fpc-fcl-js/Makefile
@@ -1,12 +1,13 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-js
+PORTREVISION= 1
COMMENT= Free Pascal Javascript scanner/parser/syntax tree (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-res rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-json/Makefile b/devel/fpc-fcl-json/Makefile
index d8b5b66799ff..5768a7e458a9 100644
--- a/devel/fpc-fcl-json/Makefile
+++ b/devel/fpc-fcl-json/Makefile
@@ -1,12 +1,13 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-json
+PORTREVISION= 1
COMMENT= Free Pascal JavaScript Object Notation implemenation (FCL)
+USES= fpc
USE_FPC= fcl-base rtl-objpas fcl-res
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-net/Makefile b/devel/fpc-fcl-net/Makefile
index 3216f38b62ae..688a9917290f 100644
--- a/devel/fpc-fcl-net/Makefile
+++ b/devel/fpc-fcl-net/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-net
COMMENT= Free Pascal network interfaces (FCL)
+USES= fpc
USE_FPC= fcl-base openssl fcl-xml fcl-passrc fcl-async rtl-extra
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-passrc/Makefile b/devel/fpc-fcl-passrc/Makefile
index ec86902bb2be..1b72bf1b2de1 100644
--- a/devel/fpc-fcl-passrc/Makefile
+++ b/devel/fpc-fcl-passrc/Makefile
@@ -1,12 +1,13 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-passrc
+PORTREVISION= 1
COMMENT= Free Pascal language parsing library (FPC)
+USES= fpc
USE_FPC= fcl-base fcl-res rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-pdf/Makefile b/devel/fpc-fcl-pdf/Makefile
index d5012ee76faf..d1dd1d6a447a 100644
--- a/devel/fpc-fcl-pdf/Makefile
+++ b/devel/fpc-fcl-pdf/Makefile
@@ -1,11 +1,12 @@
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-pdf
+PORTREVISION= 1
COMMENT= Free Pascal pdf (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-image fcl-res fcl-xml pasjpeg rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-registry/Makefile b/devel/fpc-fcl-registry/Makefile
index aebc95afaeed..442b55d5589a 100644
--- a/devel/fpc-fcl-registry/Makefile
+++ b/devel/fpc-fcl-registry/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-registry
COMMENT= Free Pascal emulation of Windows registry (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-xml
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-res/Makefile b/devel/fpc-fcl-res/Makefile
index 3df08d001ae5..30eeb5b5fc96 100644
--- a/devel/fpc-fcl-res/Makefile
+++ b/devel/fpc-fcl-res/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -fcl-res
COMMENT= Free Pascal resource handlers (FCL)
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fcl-sdo/Makefile b/devel/fpc-fcl-sdo/Makefile
index ce23288a2180..8086b166dbaf 100644
--- a/devel/fpc-fcl-sdo/Makefile
+++ b/devel/fpc-fcl-sdo/Makefile
@@ -5,6 +5,7 @@ PKGNAMESUFFIX= -fcl-sdo
COMMENT= Free Pascal Service Data Objects implementation (FCL)
+USES= fpc
USE_FPC= dblib fcl-base fcl-db fcl-json fcl-xml ibase mysql odbc \
oracle postgres pxlib rtl-extra sqlite
diff --git a/devel/fpc-fcl-sound/Makefile b/devel/fpc-fcl-sound/Makefile
index c2e19fd9bf20..5f20bbc0e53f 100644
--- a/devel/fpc-fcl-sound/Makefile
+++ b/devel/fpc-fcl-sound/Makefile
@@ -5,6 +5,7 @@ PKGNAMESUFFIX= -fcl-sound
COMMENT= Free Pascal sound loading, storing and converion (FCL)
+USES= fpc
USE_FPC= fcl-base fcl-res rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-stl/Makefile b/devel/fpc-fcl-stl/Makefile
index 10d845c3f56d..c9025e3021ed 100644
--- a/devel/fpc-fcl-stl/Makefile
+++ b/devel/fpc-fcl-stl/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-stl
+PORTREVISION= 1
COMMENT= Free Pascal generic container library (FCL)
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fcl-web/Makefile b/devel/fpc-fcl-web/Makefile
index f424598d55b7..4251ba5cf50c 100644
--- a/devel/fpc-fcl-web/Makefile
+++ b/devel/fpc-fcl-web/Makefile
@@ -1,12 +1,13 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-web
+PORTREVISION= 1
COMMENT= Free Pascal web application libary (FCL)
+USES= fpc
USE_FPC= dblib fcl-async fcl-base fcl-db fcl-xml fcl-json fcl-net \
fcl-fpcunit fcl-passrc fastcgi httpd22 httpd24 ibase mysql \
odbc openssl oracle postgres pxlib rtl-extra sqlite
diff --git a/devel/fpc-fcl-xml/Makefile b/devel/fpc-fcl-xml/Makefile
index fe802103b042..eb1456ad5d55 100644
--- a/devel/fpc-fcl-xml/Makefile
+++ b/devel/fpc-fcl-xml/Makefile
@@ -6,8 +6,8 @@ PKGNAMESUFFIX= -fcl-xml
COMMENT= Free Pascal XML and DOM library (FCL)
+USES= fpc:run
USE_FPC= fcl-base fcl-res rtl-objpas iconvenc
-USE_FPC_RUN= yes
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-fppkg/Makefile b/devel/fpc-fppkg/Makefile
index 141eec54ac1f..3dfc3eb8b40a 100644
--- a/devel/fpc-fppkg/Makefile
+++ b/devel/fpc-fppkg/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fppkg
COMMENT= Free Pascal package manager unit
+USES= fpc
USE_FPC= dblib fastcgi fcl-async fcl-base fcl-db fcl-fpcunit fcl-json \
fcl-net fcl-passrc fcl-web fcl-xml httpd22 httpd24 ibase \
mysql odbc openssl oracle postgres pxlib rtl-extra sqlite
diff --git a/devel/fpc-fv/Makefile b/devel/fpc-fv/Makefile
index 8fb521013c83..e391610220f1 100644
--- a/devel/fpc-fv/Makefile
+++ b/devel/fpc-fv/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fv
COMMENT= FreeVision is a Free Pascal unit for Delphi support
+USES= fpc
USE_FPC= rtl-console rtl-extra
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-gdbint/Makefile b/devel/fpc-gdbint/Makefile
index 2ebd9643b784..9f7dbf41375b 100644
--- a/devel/fpc-gdbint/Makefile
+++ b/devel/fpc-gdbint/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -gdbint
COMMENT= Free Pascal unit providing interface to gdb
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-newt/Makefile b/devel/fpc-newt/Makefile
index 0039516829b2..7d2bd51eaba3 100644
--- a/devel/fpc-newt/Makefile
+++ b/devel/fpc-newt/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -newt
COMMENT= Free Pascal interface to newt library
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-pthreads/Makefile b/devel/fpc-pthreads/Makefile
index 72306e249dda..06171920cce5 100644
--- a/devel/fpc-pthreads/Makefile
+++ b/devel/fpc-pthreads/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -pthreads
COMMENT= Free Pascal wrapper for the pthreads library
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-regexpr/Makefile b/devel/fpc-regexpr/Makefile
index bcce3c555632..8e082790447a 100644
--- a/devel/fpc-regexpr/Makefile
+++ b/devel/fpc-regexpr/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -regexpr
COMMENT= Free Pascal regular expression routines
+USES= fpc
USE_FPC= rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-sdl/Makefile b/devel/fpc-sdl/Makefile
index 1f2f864d7009..0506fa1c64d1 100644
--- a/devel/fpc-sdl/Makefile
+++ b/devel/fpc-sdl/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -sdl
COMMENT= Free Pascal interface to SDL library
+USES= fpc
USE_FPC= pthreads x11
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-symbolic/Makefile b/devel/fpc-symbolic/Makefile
index 6a97aaa34bbe..5728e722a754 100644
--- a/devel/fpc-symbolic/Makefile
+++ b/devel/fpc-symbolic/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -symbolic
COMMENT= FreePascal unit for simple expression parsing and evaluating
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
diff --git a/devel/fpc-zlib/Makefile b/devel/fpc-zlib/Makefile
index ca5dff109bdc..6400c967f92d 100644
--- a/devel/fpc-zlib/Makefile
+++ b/devel/fpc-zlib/Makefile
@@ -6,7 +6,7 @@ PKGNAMESUFFIX= -zlib
COMMENT= Free Pascal interface to the zlib compression library
-USE_FPC= yes
+USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}