aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-10-06 16:04:07 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2019-10-06 16:04:07 +0000
commit5d563dc07c375812648e55965352b7d67e20682e (patch)
tree8a4e8981268c8cc80fcbcc80b1b357e3fdacad96 /devel
parent7efc18df7e15eba55d087914d1d95b2db1e9f4d0 (diff)
downloadports-5d563dc07c375812648e55965352b7d67e20682e.tar.gz
ports-5d563dc07c375812648e55965352b7d67e20682e.zip
devel/spin: Ressurect the port & assign to submitter
it never actually needed gcc, "gcc" was just a hardcoded compiler name instead of "cc". While here, - Upstream switched to GitHub - Update to 6.5.0 PR: 241067 Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=513892
Diffstat (limited to 'devel')
-rw-r--r--devel/spin/Makefile54
-rw-r--r--devel/spin/distinfo3
-rw-r--r--devel/spin/files/patch-Src_main.c20
-rw-r--r--devel/spin/files/patch-Src_spin.y10
-rw-r--r--devel/spin/pkg-descr10
-rw-r--r--devel/spin/pkg-plist3
6 files changed, 100 insertions, 0 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
new file mode 100644
index 000000000000..b273d4ecf9fb
--- /dev/null
+++ b/devel/spin/Makefile
@@ -0,0 +1,54 @@
+# Created by: jhanna@home.com
+# $FreeBSD$
+
+PORTNAME= spin
+PORTVERSION= 6.5.0
+DISTVERSIONPREFIX= version-
+CATEGORIES= devel
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= On-the-fly verification system for asynchronous concurrent systems
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/Src/LICENSE
+
+MAKEFILE= makefile
+ALL_TARGET= all
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DNXT"
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+USE_GITHUB= yes
+GH_ACCOUNT= nimble-code
+GH_PROJECT= Spin
+
+OPTIONS_DEFINE= DOCS EXAMPLES ISPIN
+OPTIONS_DEFAULT= ISPIN
+OPTIONS_SUB= yes
+ISPIN_DESC= Install ispin and TCL/Tk dependency
+ISPIN_USES= shebangfix tk
+
+SHEBANG_FILES= optional_gui/ispin.tcl
+tk_OLD_CMD= /bin/sh
+tk_CMD= ${WISH} -f
+
+post-patch-ISPIN-on:
+ ${REINPLACE_CMD} -e "s|exec wish|#exec wish|" ${WRKSRC}/optional_gui/ispin.tcl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Src/spin ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/Man/spin.1 ${STAGEDIR}${PREFIX}/man/man1
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/Doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/Examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+do-install-ISPIN-on:
+ ${INSTALL_SCRIPT} ${WRKSRC}/optional_gui/ispin.tcl ${STAGEDIR}${PREFIX}/bin/ispin
+
+.include <bsd.port.mk>
diff --git a/devel/spin/distinfo b/devel/spin/distinfo
new file mode 100644
index 000000000000..5776c2ebbc87
--- /dev/null
+++ b/devel/spin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1570219065
+SHA256 (nimble-code-Spin-version-6.5.0_GH0.tar.gz) = 7bd764793621940b7e69eef8210c82c75ccee7745f24927f221d228260505333
+SIZE (nimble-code-Spin-version-6.5.0_GH0.tar.gz) = 4360118
diff --git a/devel/spin/files/patch-Src_main.c b/devel/spin/files/patch-Src_main.c
new file mode 100644
index 000000000000..e74aa879e371
--- /dev/null
+++ b/devel/spin/files/patch-Src_main.c
@@ -0,0 +1,20 @@
+--- Src/main.c.orig 2019-10-04 20:09:58 UTC
++++ Src/main.c
+@@ -103,7 +103,7 @@ void explain(int);
+ can later be truncated at that point
+ */
+ #if 1
+- #define CPP "gcc -std=gnu99 -E -x c" /* 6.4.0 new default on all systems */
++ #define CPP "cc -std=gnu99 -E -x c" /* 6.4.0 new default on all systems */
+ /* if gcc-4 is available, this setting is modified below */
+ #else
+ #if defined(PC) || defined(MAC)
+@@ -579,7 +579,7 @@ void
+ preprocess(char *a, char *b, int a_tmp)
+ { char precmd[1024], cmd[2048];
+ int i;
+-#ifdef PC
++#if 0
+ /* gcc is sometimes a symbolic link to gcc-4
+ that does not work well in cygwin, so we try
+ to use the actual executable that is used.
diff --git a/devel/spin/files/patch-Src_spin.y b/devel/spin/files/patch-Src_spin.y
new file mode 100644
index 000000000000..4403359dea86
--- /dev/null
+++ b/devel/spin/files/patch-Src_spin.y
@@ -0,0 +1,10 @@
+--- Src/spin.y.orig 2019-10-04 20:02:16 UTC
++++ Src/spin.y
+@@ -13,6 +13,7 @@
+ #include <unistd.h>
+ #endif
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #define YYMAXDEPTH 20000 /* default is 10000 */
+ #define YYDEBUG 0
diff --git a/devel/spin/pkg-descr b/devel/spin/pkg-descr
new file mode 100644
index 000000000000..6c173129e732
--- /dev/null
+++ b/devel/spin/pkg-descr
@@ -0,0 +1,10 @@
+Spin is an efficient on-the-fly verification system
+(a `model checker') for asynchronous concurrent systems,
+such as data communication protocols, distributed operating
+systems, database systems, etc.
+It can be used to prove both safety and liveness properties,
+including all correctness requirements expressible in linear
+time temporal logic.
+Spin uses a high level language to specify systems descriptions,
+called PROMELA (PROcess MEta LAnguage).
+WWW: http://spinroot.com
diff --git a/devel/spin/pkg-plist b/devel/spin/pkg-plist
new file mode 100644
index 000000000000..c80a39b890ba
--- /dev/null
+++ b/devel/spin/pkg-plist
@@ -0,0 +1,3 @@
+bin/spin
+%%ISPIN%%bin/ispin
+man/man1/spin.1.gz