aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-11-25 00:21:43 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-11-25 00:21:43 +0000
commit72499a985f3ca4d718f4f2328aaef5df4e2a1c4e (patch)
tree11792b5993e56cadb005c30fcb0434e1e8cdc00c /devel
parent0fc8a0e545ddc4a870f2295952c232e32b054be4 (diff)
downloadports-72499a985f3ca4d718f4f2328aaef5df4e2a1c4e.tar.gz
ports-72499a985f3ca4d718f4f2328aaef5df4e2a1c4e.zip
- Update to 0.6.3
PR: 195337 Submitted by: C Hutchinson <portmaster@bsdforge.com> (maintainer)
Notes
Notes: svn path=/head/; revision=373387
Diffstat (limited to 'devel')
-rw-r--r--devel/ecgi/Makefile8
-rw-r--r--devel/ecgi/distinfo4
-rw-r--r--devel/ecgi/files/patch-html2h_html2h.c16
-rw-r--r--devel/ecgi/files/patch-src_ecgitk.c8
-rw-r--r--devel/ecgi/pkg-descr6
5 files changed, 20 insertions, 22 deletions
diff --git a/devel/ecgi/Makefile b/devel/ecgi/Makefile
index fe1039a004c0..4eeb645e6827 100644
--- a/devel/ecgi/Makefile
+++ b/devel/ecgi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ecgi
-PORTVERSION= 0.6.2
-PORTREVISION= 3
+PORTVERSION= 0.6.3
CATEGORIES= devel
MASTER_SITES= http://bsdforge.com/projects/source/devel/ecgi/
@@ -18,8 +17,6 @@ HEADER_FILES= ecgi.h ecgitk.h include/memfile.h
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
pre-patch:
@${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' ${WRKSRC}/src/memfile.c
@@ -31,10 +28,7 @@ do-install:
.for file in ${HEADER_FILES}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/include/ecgi
.endfor
-
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/ecgitut.txt ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/devel/ecgi/distinfo b/devel/ecgi/distinfo
index 9339f2d777b2..823ebd9b2c92 100644
--- a/devel/ecgi/distinfo
+++ b/devel/ecgi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ecgi-0.6.2.tar.xz) = e8d8f00a9209c2ef87e100d35c15bc0e54c3f778e34c9551703f66c88d29e331
-SIZE (ecgi-0.6.2.tar.xz) = 163836
+SHA256 (ecgi-0.6.3.tar.xz) = 154f6b13f7023d4eccf87c93f081b794784d6e2c26ea9027c22922ced47c54fd
+SIZE (ecgi-0.6.3.tar.xz) = 162116
diff --git a/devel/ecgi/files/patch-html2h_html2h.c b/devel/ecgi/files/patch-html2h_html2h.c
index 56860e4cded7..77ae70df2c42 100644
--- a/devel/ecgi/files/patch-html2h_html2h.c
+++ b/devel/ecgi/files/patch-html2h_html2h.c
@@ -1,5 +1,5 @@
---- html2h/html2h.c.orig 2014-04-26 08:44:43.000000000 +0000
-+++ html2h/html2h.c
+--- html2h/html2h.c.orig 2014-11-24 13:09:14.000000000 -0800
++++ html2h/html2h.c 2014-11-24 13:25:12.000000000 -0800
@@ -6,15 +6,10 @@
void usage()
@@ -8,22 +8,24 @@
-html2h v0.1
-usage:
- html2h input.html [output.h]
--
+-
- if output is not set, input.h will be generated and overwritten!
-
- debug messages are written to stderr!
-
+ printf("html2h v0.1\nusage:\n \
-+ html2h input.html [output.h]\n\n \
-+ if output is not set, input.h will be generated and overwritten!\n\n \
-+ debug messages are written to stderr!\n\n \
+++ html2h input.html [output.h]\n\n \
+++ if output is not set, input.h will be generated and overwritten!\n\n \
+++ debug messages are written to stderr!\n\n \
");
exit(0);
-@@ -415,4 +410,4 @@ void pexit(char *msg, const char *commen
+@@ -415,4 +410,6 @@
{
fprintf(stderr, "%s%s\n", msg, comment);
exit(1);
-}
\ No newline at end of file
++
+}
++
diff --git a/devel/ecgi/files/patch-src_ecgitk.c b/devel/ecgi/files/patch-src_ecgitk.c
index 60bd4565c41d..26ce96bb3332 100644
--- a/devel/ecgi/files/patch-src_ecgitk.c
+++ b/devel/ecgi/files/patch-src_ecgitk.c
@@ -1,11 +1,11 @@
---- src/ecgitk.c.orig 2014-04-26 08:53:43.000000000 +0000
-+++ src/ecgitk.c
-@@ -23,7 +23,7 @@ int ctkRedirect(const char *format, ...)
+--- src/ecgitk.c.orig 2014-11-24 13:35:51.000000000 -0800
++++ src/ecgitk.c 2014-11-24 13:36:16.000000000 -0800
+@@ -23,7 +23,7 @@
{
char buf[4096];
int used;
- va_list *ap;
+ va_list ap;
-
+
va_start(ap, (void*)format);
used=vsnprintf(buf, 4095, format, ap);
diff --git a/devel/ecgi/pkg-descr b/devel/ecgi/pkg-descr
index 737d8e022854..a245e3a7d173 100644
--- a/devel/ecgi/pkg-descr
+++ b/devel/ecgi/pkg-descr
@@ -1,9 +1,11 @@
ecgi (easy CGI Libary) is an ANSI C library for the creation of
CGI-based Web applications. It transparently supports the CGI methods
-GET and POST and also multipart/form-data file uploads. The user
+GET and POST, and also multipart/form-data file uploads. The user
interface is designed to be as easy as possible and maintains full
compatibility to cgic 0.5.
It also contains a library independent introduction to CGI programming
-with C, a .html to .h HTML template preprocessor, and fast,
+with C, an .html to .h HTML template preprocessor, and fast,
block-allocating memory files.
+
+WWW: http://bsdforge.com/projects/devel/ecgi/